A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo Custom Edition (Bungie/Gearbox) »Halo CE General Discussion »i have no init.txt file in haloCE root directory

Page 1 of 2 Go to page: · [1] · 2 · Next
Author Topic: i have no init.txt file in haloCE root directory (49 messages, Page 1 of 2)
Moderators: Dennis

UnevenElefant5
Joined: May 3, 2008

she/her this fag bashes back


Posted: Jun 4, 2008 12:30 PM    Msg. 1 of 49       
i have no init.txt file in haloCE root directory any help you can provide would be nice.


Advancebo
Joined: Jan 14, 2008


Posted: Jun 4, 2008 02:14 PM    Msg. 2 of 49       
u make it yourself


UnevenElefant5
Joined: May 3, 2008

she/her this fag bashes back


Posted: Jun 4, 2008 07:38 PM    Msg. 3 of 49       
how do i do that?
Pardon my nubishness


Advancebo
Joined: Jan 14, 2008


Posted: Jun 4, 2008 07:41 PM    Msg. 4 of 49       
Dennis says, "Halo CE: How to Run a Dedicated Server"
From the Halo CE Section
http://hce.halomaps.org/index.cfm?nid=323


johnnyno1
Joined: Dec 11, 2011


Posted: Apr 6, 2012 09:04 PM    Msg. 5 of 49       
ummm...I did what that guide told me to do, but when I tried to run the HaloCEStart.bat, it says it could not find C:\Program, even though I put in the Drive and the Path correctly (I copied and pasted). Why is this happening?


abkarch
Joined: Mar 20, 2010


Posted: Apr 6, 2012 09:29 PM    Msg. 6 of 49       
Quote: --- Original message by: johnnyno1
ummm...I did what that guide told me to do, but when I tried to run the HaloCEStart.bat, it says it could not find C:\Program, even though I put in the Drive and the Path correctly (I copied and pasted). Why is this happening?

If you save it in the root directory for halo CE (C:\Program Files\Microsoft Games\Halo Custom Edition), you don't have to add C:\.

Just type in the BAT file "haloceded.exe" without the rest of the directory listed.
Edited by abkarch on Apr 6, 2012 at 09:30 PM


Dennis

Joined: Jan 27, 2005

"We are made of starstuff. ― Carl Sagan


Posted: Apr 6, 2012 10:05 PM    Msg. 7 of 49       
Quote: --- Original message by: johnnyno1
ummm...I did what that guide told me to do, but when I tried to run the HaloCEStart.bat, it says it could not find C:\Program, even though I put in the Drive and the Path correctly (I copied and pasted). Why is this happening?
If the path has spaces in it you need to enclose the path with quotes.


johnnyno1
Joined: Dec 11, 2011


Posted: Apr 7, 2012 04:52 PM    Msg. 8 of 49       
after following the guide herehttp://hce.halomaps.org/index.cfm?nid=323 and putting quotations around my path, a message pops up saying windows cannot find "-exec". What does that mean?


ally
Joined: Jun 23, 2010

Aye Ready


Posted: Apr 7, 2012 05:20 PM    Msg. 9 of 49       
have you tried taking away the quotes around -exec?

edit: or just do away with the .bat file and put your init.txt into your halo ce program files folder,
then just run the haloceded.exe, the init.txt should be found by the .exe. this is how mine runs.
provided your init.txt is setup properly there should be no problems for the server to run.
Edited by ally on Apr 7, 2012 at 05:23 PM


johnnyno1
Joined: Dec 11, 2011


Posted: Apr 7, 2012 05:22 PM    Msg. 10 of 49       
my script looks like this now start "haloceded.exe" -exec "init.txt" and windows still cannot find -exec.


ally
Joined: Jun 23, 2010

Aye Ready


Posted: Apr 7, 2012 05:23 PM    Msg. 11 of 49       
try what i mentioned above your last post.


johnnyno1
Joined: Dec 11, 2011


Posted: Apr 7, 2012 05:35 PM    Msg. 12 of 49       
So the batch file is optional? OK I'll just run haloceded without the batch file ^.^


ally
Joined: Jun 23, 2010

Aye Ready


Posted: Apr 7, 2012 05:44 PM    Msg. 13 of 49       
yes you don't really need it, just make sure the init.txt is in the haloce games folder and setup properly.
for example
sv_name enjoy_fair_play
sv_mapcycle_add ratrace CTF
sv_mapcycle_add carousel CTF
sv_mapcycle_timeout 10
sv_password whatever
sv_maxplayers 4

password is obviously optional.

run your haloceded. if you have a secondary firewall which will popup allow the ports.


johnnyno1
Joined: Dec 11, 2011


Posted: Apr 8, 2012 02:13 PM    Msg. 14 of 49       
So this would work:
sv_name "TeamKillOnlyOrGTFO"
sv_public 1
sv_maxplayers 16
sv_mapcycle_timeout 15
sv_mapcycle_add bloodgulch "thebestctf"<---custom gametype
sv_mapcycle_add bloodgulch "thebestslayer"<---- custom gametype
sv_motd "motd.txt"<---- custom message of the day
sv_mapcycle_begin
I've changed my server port to 2304 and my client port to 2305. I enter my own IP (192.168.1.68:2304) to join my own game, but I am unable to join the game. Why?
Edited by johnnyno1 on Apr 8, 2012 at 02:33 PM


ally
Joined: Jun 23, 2010

Aye Ready


Posted: Apr 8, 2012 02:34 PM    Msg. 15 of 49       
looks fine, also the sv_mapcycle_begin command is optional.
instead of having it in the init.txt, you can remove that and run your haloceded
then in the console window just type that command in, then you can do the
end command to put the server into idle mode until you want to start it again.
i usually just go to the server list and then join mine from there, when i have it running.


johnnyno1
Joined: Dec 11, 2011


Posted: Apr 8, 2012 02:40 PM    Msg. 16 of 49       
Yeah...I tried joining my game from the server list, but I couldn't find it. I set the filter to No full servers, only ctf, must be team, yes empty server, any ping, but i couldn't find my server. :(


Dumb AI
Joined: Sep 18, 2011

Dead.


Posted: Apr 8, 2012 02:53 PM    Msg. 17 of 49       
I don't think you cn join your own server.


ally
Joined: Jun 23, 2010

Aye Ready


Posted: Apr 8, 2012 03:05 PM    Msg. 18 of 49       
@Dumb Ai, i don't think you are thinking straight, why would you not be able to join your own server?

jonny make sure you have the correct ports forwarded and that your routers firewall isn't blocking.

also try changing the public 1 to public true, i remember that working on someone else's sever for some reason.
Edited by ally on Apr 8, 2012 at 03:06 PM

Edited by ally on Apr 8, 2012 at 03:07 PM


johnnyno1
Joined: Dec 11, 2011


Posted: Apr 8, 2012 03:13 PM    Msg. 19 of 49       
Alright.
sv_name "TeamKillOnlyOrGTFO"
sv_public True
sv_maxplayers 16
sv_mapcycle_timeout 15
sv_mapcycle_add bloodgulch "thebestctf"
sv_mapcycle_add bloodgulch "thebestslayer"
sv_motd "motd.txt"
sv_mapcycle_begin
how's that?


ally
Joined: Jun 23, 2010

Aye Ready


Posted: Apr 8, 2012 03:15 PM    Msg. 20 of 49       
test it
also what does the last line in the console window say when you have the server running?
Edited by ally on Apr 8, 2012 at 03:17 PM


johnnyno1
Joined: Dec 11, 2011


Posted: Apr 8, 2012 03:19 PM    Msg. 21 of 49       
Dedicated Server is running on map bloodgulch <0/16 players>
Use the 'sv_end_game' command to stop the game.
halo<

Still can't find my server on server list, and can't join by direct IP
Edited by johnnyno1 on Apr 8, 2012 at 03:24 PM


ally
Joined: Jun 23, 2010

Aye Ready


Posted: Apr 8, 2012 03:24 PM    Msg. 22 of 49       
ah okay just saw your edit there.
do you have a secondary firewall?
are there any problems joining other servers online?
what version are your running your server on and do you have the version changer set to a different version?
Edited by ally on Apr 8, 2012 at 03:26 PM


johnnyno1
Joined: Dec 11, 2011


Posted: Apr 8, 2012 08:40 PM    Msg. 23 of 49       
No secondary firewall, no problems joining other servers online. What do you mean by which version am I running my server on?


ally
Joined: Jun 23, 2010

Aye Ready


Posted: Apr 8, 2012 09:25 PM    Msg. 24 of 49       
that means if your haloce is updated to 1.09 and your server starts on 1.09.
but you have used the halo version changer to play servers on the 1.00ce update then you won't see your own server.
are you totally sure you have allowed the needed ports?


johnnyno1
Joined: Dec 11, 2011


Posted: Apr 8, 2012 10:36 PM    Msg. 25 of 49       
I've downloaded haloce as 1.00 but I ran haloupdate afterwards. Does that mean I'm up to date?


ally
Joined: Jun 23, 2010

Aye Ready


Posted: Apr 8, 2012 11:36 PM    Msg. 26 of 49       
yeah you should be fine then if you had a proper key and updated.
then your server will be on 1.09 and you should see it in the 1.09 server list.
okay so you said the ports have been allowed in your router, and have said no
secondary firewall should be blocking you from joining your server.
your init.txt is fine.

if you had all that setup then you should be good to go and join your server,
i see no reason at all what is stopping you.

one last thought: if your server is running on ports 2302-2303
then change your game ports to 2304-2305 and try that.
Edited by ally on Apr 8, 2012 at 11:40 PM


Dumb AI
Joined: Sep 18, 2011

Dead.


Posted: Apr 9, 2012 09:08 PM    Msg. 27 of 49       
Quote: --- Original message by: ally

@Dumb Ai, i don't think you are thinking straight, why would you not be able to join your own server?

jonny make sure you have the correct ports forwarded and that your routers firewall isn't blocking.

also try changing the public 1 to public true, i remember that working on someone else's sever for some reason.
Edited by ally on Apr 8, 2012 at 03:06 PM

Edited by ally on Apr 8, 2012 at 03:07 PM

You don't THINK straight but you can WALK straight.I was told that you couldn't join your own server.I even tried it.


Maniac1000
-Helpful Poster-
Joined: Feb 24, 2007


Posted: Apr 9, 2012 09:38 PM    Msg. 28 of 49       
Never get bored saying ally is correct.
If you are running the regular 2302 and 2303 ports then you need to add -port2304 or another port# to the dedi shortcut target.
And also open that port in your router.
You can join your own dedi from same pc.
Edited by Maniac1000 on Apr 9, 2012 at 09:42 PM


johnnyno1
Joined: Dec 11, 2011


Posted: Apr 9, 2012 11:08 PM    Msg. 29 of 49       
add -port2304 to the dedicated shortcut? what does that mean?


abkarch
Joined: Mar 20, 2010


Posted: Apr 9, 2012 11:13 PM    Msg. 30 of 49       
in the .BAT file, add that line.
Also, to join my own server, i had to change something in "network settings" when in the actual game itself.


Maniac1000
-Helpful Poster-
Joined: Feb 24, 2007


Posted: Apr 9, 2012 11:26 PM    Msg. 31 of 49       
Do not use the bat file.
Use the init that you made.
Right click the dedi shortcut and select properties.
In the target box add -port2304
Apply and ok.
Open that port in router.


johnnyno1
Joined: Dec 11, 2011


Posted: Apr 9, 2012 11:57 PM    Msg. 32 of 49       
dedi shortcut? You mean a shortcut icon to haloceded.exe? because if you mean that, I don't have a shortcut to it.... Also, I was too lazy to make a .Bat file. :/
Edited by johnnyno1 on Apr 9, 2012 at 11:57 PM


Maniac1000
-Helpful Poster-
Joined: Feb 24, 2007


Posted: Apr 10, 2012 12:04 AM    Msg. 33 of 49       
Then right click the dedi and make a shortcut, then do what I said.


johnnyno1
Joined: Dec 11, 2011


Posted: Apr 10, 2012 07:32 PM    Msg. 34 of 49       
You might be expecting this, but when I did, a message popped up saying 'The name "C:\Program Files\Microsoft Games\Halo Custom Edition\haloceded.exe-port2304" specified in the target box is invalid'


abkarch
Joined: Mar 20, 2010


Posted: Apr 10, 2012 07:38 PM    Msg. 35 of 49       
i had this problem...i have a .BAT file in my CE directory that I use to run everything else. the .BAT files says in it:

haloceded.exe -port 23XX (XX being whatever the last two digits are)

and it worked just fine for me.
But whatever, Maniac knows more about this stuff in general than me.

 
Page 1 of 2 Go to page: · [1] · 2 · Next

 
Previous Older Thread    Next newer Thread







Time: Tue October 22, 2019 10:03 PM 235 ms.
A Halo Maps Website