A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo Custom Edition (Bungie/Gearbox) »Halo CE Technical / Map Design »Ce deletes player

Author Topic: Ce deletes player (21 messages, Page 1 of 1)
Moderators: Dennis

skoron
Joined: Dec 29, 2008


Posted: Dec 29, 2008 06:34 PM    Msg. 1 of 21       
I am working on creating a map. Everything seems to work until testing. Every time I load the level, halo generates an exception before the map loads. If, in Sapien, I change all the player spawns to gametype:none, then the map seems to be able to load, although of course I can't spawn. Whenever the exception appears, the debug.txt shows player unexpectedly deleted at the end of the most recent report. Does anyone know what the problem is, and if so , how to fix it? Oh, and this was made in gmax and it also says that the map only has 0 portals and 1 cluster, but I'm not sure if this is important or not.


Lone Warrior
Joined: Dec 14, 2008

-Himalayan Wizard and Mystical Guru of the Mts.-


Posted: Dec 29, 2008 07:07 PM    Msg. 2 of 21       
Hmmm, I've never encountered this error before, although I have a hunch. Open the scenario tag in Guerilla and make sure the gametype is set to Multiplayer, not single-player. That could be the problem, although if the problem persists, post back.


skoron
Joined: Dec 29, 2008


Posted: Dec 29, 2008 07:22 PM    Msg. 3 of 21       
I checked, and it is set to multiplayer, but still does not work.


Dennis

Joined: Jan 27, 2005

"We are made of starstuff. ― Carl Sagan


Posted: Dec 29, 2008 07:27 PM    Msg. 4 of 21       
Try moving your spawn points farther apart and be sure you don't have them too near the BSP edge. Meaning that there is enough room between the spawn point and BSP, like a wall, for the player to spawn without being embedded in the BSP


skoron
Joined: Dec 29, 2008


Posted: Dec 29, 2008 07:46 PM    Msg. 5 of 21       
All right, I tried that and it still gives the exception.


skoron
Joined: Dec 29, 2008


Posted: Dec 29, 2008 08:11 PM    Msg. 6 of 21       
How can I check this? As far as I know, I'm using just the basic masterchief that's already in the CE tags.


Gamma927
Joined: Jun 12, 2008

Steam: gamma927


Posted: Dec 29, 2008 09:18 PM    Msg. 7 of 21       
If you modified the tag called globals.globals, that may explain the problem. Have you extracted any maps recently, and overwritten your tags with theirs?


skoron
Joined: Dec 29, 2008


Posted: Dec 29, 2008 09:27 PM    Msg. 8 of 21       
No, this is actually the first time I've tried to make a CE map.


Gamma927
Joined: Jun 12, 2008

Steam: gamma927


Posted: Dec 29, 2008 09:32 PM    Msg. 9 of 21       
So you did not rip any tags?


skoron
Joined: Dec 29, 2008


Posted: Dec 29, 2008 10:08 PM    Msg. 10 of 21       
No, no tags were ripped.


Gamma927
Joined: Jun 12, 2008

Steam: gamma927


Posted: Dec 29, 2008 10:35 PM    Msg. 11 of 21       
Hmmm... Are you sure it doesn't give any error in tool?


skoron
Joined: Dec 29, 2008


Posted: Dec 29, 2008 10:54 PM    Msg. 12 of 21       
No errors appear in tool, it seems to compile without error. Should a map have no portals?


Gamma927
Joined: Jun 12, 2008

Steam: gamma927


Posted: Dec 29, 2008 11:22 PM    Msg. 13 of 21       
I've never actually made one that I've modeled, so I'm afraid I cannot help you. Maybe someone else can?


black doom
Joined: Oct 4, 2008

we will never stop, we can win the "impossible"


Posted: Dec 30, 2008 09:59 AM    Msg. 14 of 21       
is there any netgame flags on the map like ctf flags and such? did you edited the globals? if not, could you try move over the map in sapien then post here debug text?


skoron
Joined: Dec 29, 2008


Posted: Dec 30, 2008 03:10 PM    Msg. 15 of 21       
Here's what it shows every time it gets the exception in the debug.

12.29.08 23:01:32 sapien pc 01.00.00.0609 ----------------------------------------------
12.29.08 23:01:32 reference function: _write_to_error_file
12.29.08 23:01:32 reference address: 401b13
12.29.08 23:01:32 Couldn't read map file './sapienbeta.map'
12.29.08 23:01:33 CreateDevice succeeded with refresh rate = 0
12.29.08 23:01:33 Initializing 10 button 5 axis 1 pov joystick 'Controller (XBOX 360 For Windows)'
12.29.08 23:01:33 Successfully initialized device axis 258 instance number 1 - Y Axis to range [-4096,4096]
12.29.08 23:01:33 Successfully initialized device axis 2 instance number 0 - X Axis to range [-4096,4096]
12.29.08 23:01:33 Successfully initialized device axis 1026 instance number 4 - Y Rotation to range [-4096,4096]
12.29.08 23:01:33 Successfully initialized device axis 770 instance number 3 - X Rotation to range [-4096,4096]
12.29.08 23:01:33 Successfully initialized device axis 514 instance number 2 - Z Axis to range [-4096,4096]
12.29.08 23:01:33 Successfully initialized device button 4 instance number 0 - Button 0
12.29.08 23:01:33 Successfully initialized device button 260 instance number 1 - Button 1
12.29.08 23:01:33 Successfully initialized device button 516 instance number 2 - Button 2
12.29.08 23:01:33 Successfully initialized device button 772 instance number 3 - Button 3
12.29.08 23:01:33 Successfully initialized device button 1028 instance number 4 - Button 4
12.29.08 23:01:33 Successfully initialized device button 1284 instance number 5 - Button 5
12.29.08 23:01:33 Successfully initialized device button 1540 instance number 6 - Button 6
12.29.08 23:01:33 Successfully initialized device button 1796 instance number 7 - Button 7
12.29.08 23:01:33 Successfully initialized device button 2052 instance number 8 - Button 8
12.29.08 23:01:33 Successfully initialized device button 2308 instance number 9 - Button 9
12.29.08 23:01:33 Successfully initialized device POV 16 instance number 0 - Hat Switch to range [-4096,4096]
12.29.08 23:01:33 Could not initialize unknown device object 192 instance number 0 - Collection 0 - Game Pad
12.29.08 23:01:33 Could not initialize unknown device object 448 instance number 1 - Collection 1
12.29.08 23:01:33 Could not initialize unknown device object 704 instance number 2 - Collection 2
12.29.08 23:01:33 Could not initialize unknown device object 960 instance number 3 - Collection 3
12.29.08 23:01:33 Increasing sound decompression buffer size to 1048576 bytes
12.29.08 23:01:42 local player 0, weapon (0x0), deleted unexpectedly


UnevenElefant5
Joined: May 3, 2008

she/her this fag bashes back


Posted: Dec 30, 2008 09:13 PM    Msg. 16 of 21       
try it using mouse and keyboard, 360 controller is not good, atleast i couldnt get it go work right...


skoron
Joined: Dec 29, 2008


Posted: Dec 30, 2008 09:59 PM    Msg. 17 of 21       
still isn't working. Here's the error message it gives now. Oh, and the 360 controller works for all the other custom maps I have.

12.30.08 20:03:22 sapien pc 01.00.00.0609 ----------------------------------------------
12.30.08 20:03:22 reference function: _write_to_error_file
12.30.08 20:03:22 reference address: 401b13
12.30.08 20:03:22 Couldn't read map file './sapienbeta.map'
12.30.08 20:03:22 CreateDevice succeeded with refresh rate = 0
12.30.08 20:03:23 Increasing sound decompression buffer size to 1048576 bytes
12.30.08 20:04:06 local player 0, weapon (0x0), deleted unexpectedly
Edited by skoron on Dec 30, 2008 at 10:00 PM

Edit: O.K. awhile back, I had compiled the tutorial map, which loaded in-game and worked fine, so I just swapped the structure_bsp of the tutorial. scenario with mine, but using the tutorial scenario, and it loaded the map with no exceptions. Either I'm messing up somewhere with editing the scenario, or guerrilla or Sapien is.
Edited by skoron on Dec 31, 2008 at 10:01 AM


black doom
Joined: Oct 4, 2008

we will never stop, we can win the "impossible"


Posted: Jan 1, 2009 06:37 AM    Msg. 18 of 21       
Quote: --- Original message by: skoron

still isn't working. Here's the error message it gives now. Oh, and the 360 controller works for all the other custom maps I have.

12.30.08 20:03:22 sapien pc 01.00.00.0609 ----------------------------------------------
12.30.08 20:03:22 reference function: _write_to_error_file
12.30.08 20:03:22 reference address: 401b13
12.30.08 20:03:22 Couldn't read map file './sapienbeta.map'
12.30.08 20:03:22 CreateDevice succeeded with refresh rate = 0
12.30.08 20:03:23 Increasing sound decompression buffer size to 1048576 bytes
12.30.08 20:04:06 local player 0, weapon (0x0), deleted unexpectedly
Edited by skoron on Dec 30, 2008 at 10:00 PM

Edit: O.K. awhile back, I had compiled the tutorial map, which loaded in-game and worked fine, so I just swapped the structure_bsp of the tutorial. scenario with mine, but using the tutorial scenario, and it loaded the map with no exceptions. Either I'm messing up somewhere with editing the scenario, or guerrilla or Sapien is.
Edited by skoron on Dec 31, 2008 at 10:01 AM


switching structure_bsp on existing scenario often exeptions. it is becuse most of the objects are wrongly placed and probaly some collisions fliped into each other and exeptioned.


Koo294
Joined: Nov 30, 2008

How is she when she doesn't surf?


Posted: Jan 1, 2009 07:26 AM    Msg. 19 of 21       
i got this too yesterday. Are you trying to run it on ctf when you haven't set it up for ctf (thats what was wrong for me)


skoron
Joined: Dec 29, 2008


Posted: Jan 1, 2009 08:29 PM    Msg. 20 of 21       
Switching the structure_bsp seemed to work for me, I don't get exceptions any more. And also, no, I had it set on slayer, not CTF, so it shouldn't have been the problem.


hell master
Joined: Mar 24, 2009


Posted: Jan 27, 2010 11:32 AM    Msg. 21 of 21       
I have a similar problem,

and yes i Have all my spawn points set to all game types. I DIDNT SWITCH THE BSP i only modded the materials. Would that count as switch the BSP?

 

 
Previous Older Thread    Next newer Thread







Time: Fri April 3, 2020 12:04 AM 219 ms.
A Halo Maps Website