A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo Custom Edition (Bungie/Gearbox) »Halo CE Technical / Map Design »Fog region exception

Author Topic: Fog region exception (9 messages, Page 1 of 1)
Moderators: Dennis

sleepy1212
Joined: Feb 4, 2009

sunnier than you www.quantumfusionclan.com


Posted: Jul 31, 2009 01:40 PM    Msg. 1 of 9       
EXCEPTION halt in \halopc\haloce\source\tag_files\tag_groups.c,#3157: #-1 is not a valid structure_bsp_fog_region_block index in [#0,#1)

Sapien loads fine when i remove the '$' from the materials and object name. it's just a single plane (water!$).

I went back through 2 tuts, which were the same, for making the shader. I thought the problem might've been there but the shader is set up right, i think. Of course the exception makes me think it's in the model...i just don't know how.


chrisk123999
Joined: Aug 10, 2008

=CE= Chris [Captain] [=]


Posted: Jul 31, 2009 02:06 PM    Msg. 2 of 9       
Does your map have more then 1 BSP?

I've ran into problems with each BSP having it's own fog palette. Try to have each BSP have the same exact fog palette.


sleepy1212
Joined: Feb 4, 2009

sunnier than you www.quantumfusionclan.com


Posted: Jul 31, 2009 09:23 PM    Msg. 3 of 9       
no....actually it's just a little box map i whipped up to test out some stuff. it only has one fog plane so there's no intersections . never had this problem before but then again, i've never successfully created water either lol.

fog palette......isn't that part of the bsp tag...couldn't edit anything in for that in guerilla.

also, even as render only the plane doesn't show up in sapien...is that normal?


chrisk123999
Joined: Aug 10, 2008

=CE= Chris [Captain] [=]


Posted: Aug 1, 2009 10:39 AM    Msg. 4 of 9       
Does your water plane cover the whole map? Or does it have different separate pieces?
Edited by chrisk123999 on Aug 1, 2009 at 10:41 AM


BeachParty clan
Joined: Oct 12, 2008

Sooo... You wanna switch to Red team huh?


Posted: Aug 1, 2009 10:55 AM    Msg. 5 of 9       
everything should show in sapien

fog palette needs sectors, not a plane, only water does, but both should show up


sleepy1212
Joined: Feb 4, 2009

sunnier than you www.quantumfusionclan.com


Posted: Aug 1, 2009 01:34 PM    Msg. 6 of 9       
Quote: --- Original message by: chrisk123999

Does your water plane cover the whole map? Or does it have different separate pieces?
Edited by chrisk123999 on Aug 1, 2009 at 10:41 AM


it's small compared to the map. and it's just a single plane (32 poly's i think) can some of the plane's tri's be hidden under the bsp or just the outermost verts?



Quote: --- Original message by: BeachParty clan
everything should show in sapien

fog palette needs sectors, not a plane, only water does, but both should show up


i get neither in sapien...hmm what's this about sectors?


chrisk123999
Joined: Aug 10, 2008

=CE= Chris [Captain] [=]


Posted: Aug 2, 2009 01:19 AM    Msg. 7 of 9       
Well, does the water bend and have a fog? Normally if it's just ocean, I have one big square that covers the whole map.


Vick Jr
Joined: Jun 26, 2008

Well enough alone...


Posted: Aug 2, 2009 10:19 AM    Msg. 8 of 9       
I would make the water work first before applying fog. The water plane should be a single plane (like 2 triangles) that covers the entire water surface. A fog plane doesn't have to cover anything. It just defines the orientation of a fog plane. Make sure that the normal is pointing away from where the fog should be and that there aren't 2 fog planes in one portal.


sleepy1212
Joined: Feb 4, 2009

sunnier than you www.quantumfusionclan.com


Posted: Aug 3, 2009 07:55 PM    Msg. 9 of 9       
Quote: --- Original message by: chrisk123999
Well, does the water bend and have a fog? Normally if it's just ocean, I have one big square that covers the whole map.


That's pretty much all it is, one big square.

I found out the error is from having whole tri's outside the bsp. I deleted those and got no errors (including 'no leaves' errors in tool) regardless of what shader symbols i use.

unfortunately, even as render only the plane doesn't show up in sapien or in-game which i think may be from the .shader_transparent_water because other "plane's!" will show up if i use environment or one of the chicagos like with lights.

another possibility is radiosity quality or maybe my graphics card just sucks.

EDIT:

found out more...sapien wouldn't let me use the $ symbol before and i think it might be because of the bitmap/material name. it was originally mapname_water!$. i changed it to simply water!$ and it worked but it did add an odd shader to my list:

material #.shader_transparent_water.

still cant see the water but i have an old graphics card that pretty much makes all water suck in halo. even the stream in beaver creek is just a translucent blue plane with no reflection or ripples.

since other shaders will probably work to give a cheapened water plane (albeit without ripples) i'll use those, make a separate fog plane, and add the particles and water effects accordingly. sucks but, unless someone wants to put it all in there for me, it's gonna have to be that way. either that or /water.
Edited by sleepy1212 on Aug 7, 2009 at 12:57 PM

 

 
Previous Older Thread    Next newer Thread







Time: Sun January 19, 2020 4:39 PM 219 ms.
A Halo Maps Website