A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo Custom Edition (Bungie/Gearbox) »Halo CE General Discussion »Help with Sapien.

Author Topic: Help with Sapien. (28 messages, Page 1 of 1)
Moderators: Dennis

blood eagle
Joined: Feb 3, 2008


Posted: Aug 9, 2009 03:26 AM    Msg. 1 of 28       
Can someone please help me. I cant figure out how to get sapien to work for my first halo ce map.

I was watching this tutorial http://www.youtube.com/watch?v=cpqtqRonEg4&feature=related and from part 1 through 3 every thing i did was fine until I opened up sapien

The problem is that when i open my map.scenario in sapien, all I see is grey in the sapien window and not that camera type view of my level that im supposed to see.

Help anyone? Ive been stuck on this for quite some time and would really appreciate assistance.


Surf Team
Joined: Dec 8, 2008

We make surf maps for you.


Posted: Aug 9, 2009 05:39 AM    Msg. 2 of 28       
Quote: --- Original message by: blood eagle
Can someone please help me. I cant figure out how to get sapien to work for my first halo ce map.

I was watching this tutorial http://www.youtube.com/watch?v=cpqtqRonEg4&feature=related and from part 1 through 3 every thing i did was fine until I opened up sapien

The problem is that when i open my map.scenario in sapien, all I see is grey in the sapien window and not that camera type view of my level that im supposed to see.

Help anyone? Ive been stuck on this for quite some time and would really appreciate assistance.


Have you ran lightmaps yet with tool??

Open up tool, type in "lightmaps levels\test\mapname\mapname mapname 0 0.9" and you will have basic lightmaps.


blood eagle
Joined: Feb 3, 2008


Posted: Aug 9, 2009 03:44 PM    Msg. 3 of 28       
by tool, do you mean that cmd.exe command window?

because that where I typed "lightmaps levels\test\mapname\mapname mapname 0 0.9".


jacknme
Joined: Aug 29, 2008

If you see this, you must be in an old topic


Posted: Aug 10, 2009 12:40 AM    Msg. 4 of 28       
Quote: --- Original message by: blood eagle
by tool, do you mean that cmd.exe command window?

because that where I typed "lightmaps levels\test\mapname\mapname mapname 0 0.9".


Yes, and if you type in in the cmd window, you need to type
tool ightmaps levels\test\mapname\mapname mapname 0 0.9


blood eagle
Joined: Feb 3, 2008


Posted: Aug 10, 2009 02:10 AM    Msg. 5 of 28       
thats exactly what ive done many times before and sapien still wont show my map.

I followed the tutorial by every step exactly. cmd.exe even says its done with the map.

damn all this. please help.
Edited by blood eagle on Aug 10, 2009 at 02:11 AM


jacknme
Joined: Aug 29, 2008

If you see this, you must be in an old topic


Posted: Aug 10, 2009 02:29 AM    Msg. 6 of 28       
Quote: --- Original message by: blood eagle

thats exactly what ive done many times before and sapien still wont show my map.

I followed the tutorial by every step exactly. cmd.exe even says its done with the map.

damn all this. please help.
Edited by blood eagle on Aug 10, 2009 at 02:11 AM


Did you give the textures shaders and select the texture in the base map box in guerrilla for the shader?


blood eagle
Joined: Feb 3, 2008


Posted: Aug 10, 2009 09:40 AM    Msg. 7 of 28       
Sorry but how exactly do I do that texture stuff in Guerilla.

The only things ive changed in Guerilla are the SKIES and the STARTING EQUIPMENT.


Arteen
Joined: Mar 8, 2008

...


Posted: Aug 10, 2009 09:50 AM    Msg. 8 of 28       
Have you tried moving the camera around? Maybe your camera is just in an odd position. Also, when you ran structure on your map in Tool, did you create any new shaders? If so, you need to set those up in Guerilla. Also, could you run lightmaps again and post the corresponding entry from the debug.txt file?


Higuy
Joined: Mar 6, 2007

@lucasgovatos


Posted: Aug 10, 2009 10:20 AM    Msg. 9 of 28       
is the folder and stuff actually called "mapname"?


blood eagle
Joined: Feb 3, 2008


Posted: Aug 10, 2009 10:50 AM    Msg. 10 of 28       

The problem is I cant even get my map to show in Sapien. I open the file and Sapien stays grey.

and no, the mapname is bliss like from the tutorial.
Edited by blood eagle on Aug 10Edited by blood eagle on Aug 10, 2009 at 10:51 AM
Edited by blood eagle on Aug 10, 2009 at 10:51 AM


Higuy
Joined: Mar 6, 2007

@lucasgovatos


Posted: Aug 10, 2009 11:27 AM    Msg. 11 of 28       
the you should be typing
tool structure levels\bliss bliss
tool lightmaps levels\bliss\bliss bliss 0 0.9

Or is that what you are typing?
Don't be typing mapname.


blood eagle
Joined: Feb 3, 2008


Posted: Aug 10, 2009 01:43 PM    Msg. 12 of 28       
Ive already tried tool lightmaps levels\bliss\bliss bliss 0 0.9
and it still doesnt show.

Im not sure if Sapien itself has a problem, I download it and it opens properly without any problems.


jacknme
Joined: Aug 29, 2008

If you see this, you must be in an old topic


Posted: Aug 11, 2009 04:48 AM    Msg. 13 of 28       
Quote: --- Original message by: blood eagle
Ive already tried tool lightmaps levels\bliss\bliss bliss 0 0.9
and it still doesnt show.

Im not sure if Sapien itself has a problem, I download it and it opens properly without any problems.


Type it in tool. There is a way to do it in Sapien, just more tedious


blood eagle
Joined: Feb 3, 2008


Posted: Aug 11, 2009 09:32 AM    Msg. 14 of 28       
Quote: --- Original message by: jacknme
Quote: --- Original message by: blood eagle
Ive already tried tool lightmaps levels\bliss\bliss bliss 0 0.9
and it still doesnt show.

Im not sure if Sapien itself has a problem, I download it and it opens properly without any problems.


Type it in tool. There is a way to do it in Sapien, just more tedious


Would you mind telling me how it happens in sapien?

The Tool method just isnt working for me.
Edited by blood eagle on Aug 11, 2009 at 09:36 AM


Gamma927
Joined: Jun 12, 2008

Steam: gamma927


Posted: Aug 11, 2009 09:45 AM    Msg. 15 of 28       
To do Sapien, type


radiosity_quality 1
radiosity_start


It takes a LOT longer though.


blood eagle
Joined: Feb 3, 2008


Posted: Aug 11, 2009 09:51 AM    Msg. 16 of 28       
Quote: --- Original message by: Gamma927
To do Sapien, type


radiosity_quality 1
radiosity_start


It takes a LOT longer though.


sorry but where exactly do i type this again? in tool?


Gamma927
Joined: Jun 12, 2008

Steam: gamma927


Posted: Aug 11, 2009 09:54 AM    Msg. 17 of 28       
Sapien. Hit the ~ button like you would if you were cheating in Halo, and type in the first command. Then, hit enter, and it should return "1". Then, type in the second command.


blood eagle
Joined: Feb 3, 2008


Posted: Aug 11, 2009 10:34 AM    Msg. 18 of 28       
Quote: --- Original message by: Gamma927
Sapien. Hit the ~ button like you would if you were cheating in Halo, and type in the first command. Then, hit enter, and it should return "1". Then, type in the second command.


I did what you said. I opened up sapien and pressed the ~ button, but every time I press it, my mouse cursor just vanishes and I have to Ctrl Alt Delete sapien to close it.

Is there something wrong that is happening with my computer itself or Sapien?


Gamma927
Joined: Jun 12, 2008

Steam: gamma927


Posted: Aug 11, 2009 10:35 AM    Msg. 19 of 28       
You have to wait it out. Probably a few hours. Or you can do tool, which takes about 2 minutes.


blood eagle
Joined: Feb 3, 2008


Posted: Aug 11, 2009 12:48 PM    Msg. 20 of 28       
Quote: --- Original message by: Gamma927
You have to wait it out. Probably a few hours. Or you can do tool, which takes about 2 minutes.


Ok, I typed tool lightmaps levels\bliss\bliss bliss 0 0.9 in tool (cmd.exe right?) and after a few seconds, it said at the bottom of the window,

bitmap created
finished levels\bliss/bliss
done


now when I open Sapien, and then i open bliss.scenario, Sapian opens but i still cant see my map.

the camera view box is just gray still.
Edited by blood eagle on Aug 11, 2009 at 12:50 PM


jacknme
Joined: Aug 29, 2008

If you see this, you must be in an old topic


Posted: Aug 12, 2009 05:56 AM    Msg. 21 of 28       
Quote: --- Original message by: blood eagle

Quote: --- Original message by: Gamma927
You have to wait it out. Probably a few hours. Or you can do tool, which takes about 2 minutes.


Ok, I typed tool lightmaps levels\bliss\bliss bliss 0 0.9 in tool (cmd.exe right?) and after a few seconds, it said at the bottom of the window,

bitmap created
finished levels\bliss/bliss
done


now when I open Sapien, and then i open bliss.scenario, Sapian opens but i still cant see my map.

the camera view box is just gray still.
Edited by blood eagle on Aug 11, 2009 at 12:50 PM


Gave it shaders?


blood eagle
Joined: Feb 3, 2008


Posted: Aug 12, 2009 08:47 AM    Msg. 22 of 28       
How do I give it shaders?


sleepy1212
Joined: Feb 4, 2009

sunnier than you www.quantumfusionclan.com


Posted: Aug 12, 2009 09:43 AM    Msg. 23 of 28       
Is it all grey, or can you at least see the sky you chose?

If you can't see the sky you chose you need to go back to guerilla.

If you can see the sky in sapien just not the map, run radiosity like they said before by hitting the ~ key. but you don't have to wait forever for it to complete if you use radiosity_quality 0. just wait until you see numbers at the top left, hit ~ again and type radiosity_save and hit enter. your map will show up. you can compile and it will look just fine in-game for testing.

when you're ready to finalize your map re-run radiosity quality 1 and let it finish...which usually takes a long time.

Quote: --- Original message by: blood eagleI did what you said. I opened up sapien and pressed the ~ button, but every time I press it, my mouse cursor just vanishes and I have to Ctrl Alt Delete sapien to close it.


The cursor is supposed to disappear, instead you should see "halo" in pink letters at the bottom left. that is where you type your commands.
Edited by sleepy1212 on Aug 12, 2009 at 09:47 AM


SiMuLaCrUm
Joined: Oct 25, 2006

too digital


Posted: Aug 12, 2009 09:46 AM    Msg. 24 of 28       
Finalizing should be done in tool.

Well it created the lightmap... But it's still not working... It's probably a lack of shaders, unless you are using stock textures, in which case, something must be wrong elsewhere...


sleepy1212
Joined: Feb 4, 2009

sunnier than you www.quantumfusionclan.com


Posted: Aug 12, 2009 09:52 AM    Msg. 25 of 28       
Quote: --- Original message by: SiMuLaCrUm
Finalizing should be done in tool.

Well it created the lightmap... But it's still not working... It's probably a lack of shaders, unless you are using stock textures, in which case, something must be wrong elsewhere...


When you create a lightmap in tool, don't you have to put that (mapname.bitmap) in the bsp tag in guerilla?


Gamma927
Joined: Jun 12, 2008

Steam: gamma927


Posted: Aug 12, 2009 09:53 AM    Msg. 26 of 28       
It's automatically directed.


SiMuLaCrUm
Joined: Oct 25, 2006

too digital


Posted: Aug 12, 2009 09:54 AM    Msg. 27 of 28       
Tool does that for you when it creates it. You don't need to mess with anything to get the lightmap to work.


blood eagle
Joined: Feb 3, 2008


Posted: Aug 13, 2009 01:30 AM    Msg. 28 of 28       
Ok, all the suggestions given to me seem not to help, Ive been on this sapien problem for too long so I might just ignore this topic for a while and relax from trying to make a map.

Sorry if my problem wasnt specific enough for some people but if your willing to help me still just send me a private message. Big thanks to everybody who tried to help.

I'll be back in a few days or so but for now, its time for a break.


Edited by blood eagle on Aug 13, 2009 at 01:33 AM

 

 
Previous Older Thread    Next newer Thread







Time: Fri July 3, 2020 6:40 PM 125 ms.
A Halo Maps Website