A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo Custom Edition (Bungie/Gearbox) »Halo CE Technical / Map Design »Custom Vehicles in Bloodgulch (Errors)

Author Topic: Custom Vehicles in Bloodgulch (Errors) (20 messages, Page 1 of 1)
Moderators: Dennis

Master Jake
Joined: Sep 20, 2009

Haii


Posted: Sep 20, 2009 02:47 PM    Msg. 1 of 20       
This is getting very annoying. I have spent hours researching, searching and reading forums, trying things out, etc. No luck. Everything fails. Someone please help.

Problem 1:

Custom vehicles don't appear in game.
Let's take the vehicle titled "jet" from the map "hugeass." I downloaded the tagpack with the vehicle, extracted (in all the right places). In "tags\vehicles\jet" you can now find all the models and sub folders and etc.

I open Guerrilla
I open globals.globals
I find the vehicles, I delete rwarthog and then add a new one.
I click the 3 dots "..." and browse for the jet model.
Done, I save.

I go to sapien, I click Edit Types and import the jet model. I go to the units vehicles, I delete all rocket warthogs. I then add the jet model. I go on the list and find all the "NONE"'s (since I just deleted the rwarthog they are empty. I replace them all with the jet model, click the Slayer, CTF, etc. defaults and enabled for each gametype.

The jets appear in sapien, so I think it's working. I save scenario, close sapien, open tool, build the cache file, open the HCE and go into the map.

And guess what I see... nothing. Where the vehicle should be is in empty spot. I have checked guerrilla looking for a red text box signalizing that somethings missing or in the wrong spot. It's not. Everything is in the right spot and should be working. But it's not working.

It does this for every custom vehicle I've tried to add.

Problem 2: VERY COMMON

Nearly all of the custom tags I download don't work. I put them in the right spots and then try to import them into Sapien but I get some weird message about the pallete being screwed up and to contact my nearest bungie programmer. I've read and read and read and tried to figure it out, it always fails.

Like I said, this happens for most tags. I rarely find one that works, the jet I got lucky with. I also found that the "glendale" tag works. Mongoose is one that I would love to inject in Bloodgulch, but it fails. Many of the weapons I try to import fail as well. I've only had success with the Minigun and Ak47 so far.

--------------------------------------

Sorry for it being so lengthy, but I wanted to explain so that someone wouldn't point one of the above out if they tried to help.

Does anyone know what I'm doing wrong or how to fix this problem? I would love to get it working so I can play around some more.


chrisk123999
Joined: Aug 10, 2008

=CE= Chris [Captain] [=]


Posted: Sep 20, 2009 02:50 PM    Msg. 2 of 20       
1. They aren't in the globals so they won't spawn by default. Replace (NOT ADD), them in your globals. Or script them in.

2. Many of the tags on this site are missing stuff. Look at you debug.txt to see what they are missing. Redirect if possible.


Master Jake
Joined: Sep 20, 2009

Haii


Posted: Sep 20, 2009 02:54 PM    Msg. 3 of 20       
I screwed around with the vehicles in my globals.globals tag yesterday and forgot to make a globals backup. Can you tell me what vehicles are in there in order from top to bottom so I can re-add them, save, them back that up?


UnevenElefant5
Joined: May 3, 2008

she/her this fag bashes back


Posted: Sep 20, 2009 03:21 PM    Msg. 4 of 20       
Just extract it from a default map.
Edited by UnevenElefant5 on Sep 20, 2009 at 03:21 PM


Master Jake
Joined: Sep 20, 2009

Haii


Posted: Sep 20, 2009 03:26 PM    Msg. 5 of 20       
I tried using HEK Plus to extract it from Bloodgulch, but it was the same, so then I tried a single player map (b40) and it's still the same. I deleted the old globals file before rextracting.

The changes I made are still in the file :/


Gamma927
Joined: Jun 12, 2008

Steam: gamma927


Posted: Sep 20, 2009 03:51 PM    Msg. 6 of 20       
Set it to overwrite.


Master Jake
Joined: Sep 20, 2009

Haii


Posted: Sep 20, 2009 06:50 PM    Msg. 7 of 20       
I set HEK Plus to overwrite existing tags and then extracted globals.globals from bloodgulch again. I opened it in Guerilla but my previous changes are still in there. So I tried from b40 but same.

PS - Forgive my insolence, but I just started trying to CE mod a couple days ago and have ran into these problems.


Gamma927
Joined: Jun 12, 2008

Steam: gamma927


Posted: Sep 20, 2009 07:06 PM    Msg. 8 of 20       
Make sure Guerilla is closed while extracting the tag. Open Guerilla after you've finished extracting.


Master Jake
Joined: Sep 20, 2009

Haii


Posted: Sep 20, 2009 07:23 PM    Msg. 9 of 20       
Still :(

could it have anything to do with me being on Vista?


Gamma927
Joined: Jun 12, 2008

Steam: gamma927


Posted: Sep 20, 2009 07:27 PM    Msg. 10 of 20       
Probably not. I didn't have this problem when I used to use Vista, and I still don't have the problem when using 7.


FtDSpartn
Joined: May 1, 2009

Verified AI.


Posted: Sep 20, 2009 07:27 PM    Msg. 11 of 20       
Nope,never had these problems on vista."Edit: ^Same post time"
Edited by FtDSpartn on Sep 20, 2009 at 07:28 PM


XlzQwerty1
Joined: Aug 6, 2009


Posted: Sep 20, 2009 07:29 PM    Msg. 12 of 20       
1. Open HEK+

2. Open Bloodgulch or any other original multiplayer map

3. In HEK+, open the globals folder

4. Find globals.globals and right click it, then select "Extract To..." Make sure Overwrite is unchecked

5. A window will pop up asking where you want to extract it to, so pick a random folder such as:
(haloce folder)\tags\globals\original\

6. Open guerilla or kornman v2 and find the globals.globals tag you just extracted, then open it

See if this works for you


Master Jake
Joined: Sep 20, 2009

Haii


Posted: Sep 20, 2009 09:00 PM    Msg. 13 of 20       
Yep, Qwerty. That worked, thanks.

When I copy that file in tags\globals\original to just globals and overwrite the other gloabals.globals file though, then open it in guerrilla, still the same as it use to be. But when I open the file in the \original folder, it is back to normal.

So that's not good :/


ViciousWhiskers
Joined: Dec 19, 2007

Give it a try.


Posted: Sep 21, 2009 05:08 PM    Msg. 14 of 20       

Edited by ViciousWhiskers on Aug 7, 2013 at 07:23 PM


Master Jake
Joined: Sep 20, 2009

Haii


Posted: Sep 21, 2009 05:31 PM    Msg. 15 of 20       
I did try that, still guerrilla thinks it's the other one. Maybe guerrilla stores a TEMP file somewhere to keep track of stuff for some reason. Maybe it accesses that file and saves to that file and not the actual original. I don't know :(

I've ran into so many problems. I even switched all the vehicles back, added a custom into the globals, added the tag into sapien, placed it, compiled, and it's still an empty spot.


XlzQwerty1
Joined: Aug 6, 2009


Posted: Sep 21, 2009 06:48 PM    Msg. 16 of 20       
Well then I don't know, this never happened to me before. Maybe vista stores a temp file?


Maniac1000
-Helpful Poster-
Joined: Feb 24, 2007


Posted: Sep 21, 2009 08:41 PM    Msg. 17 of 20       
Did you overwrite the Bloodgulch.map with one that has bad globals, then try to rip the globals from Bloodgulch?
Rip globals/globals from danger canyon (only rip that file and check overwrite) and check the box that says "use existing directories (always check that one)
That WILL fix your globals. If you still have a problem then post the last paragraph of your debug.txt here and explain what is happening or not happening.


Master Jake
Joined: Sep 20, 2009

Haii


Posted: Sep 22, 2009 02:03 AM    Msg. 18 of 20       
I didn't overwrite the bloodgulch map with the bad globals, no. When I extracted the ones from bloodgulch into a separate folder they are the good globals, but for some reason, no matter how many times i overwrite the globals in the regular globals folder with good globals, they always remain as the bad ones.

Where is the box that says use existing directories?


defyant
Joined: Oct 26, 2009


Posted: Oct 26, 2009 01:08 AM    Msg. 19 of 20       
1. I've had this problem before, and as far as I can tell, you can't have more than 4 of a vehicle in a map(or maybe it's team?). Maybe the vehicle team index affects this. Anyway, try that, see if it works.
2. Lots of tags are buggy, check your debug.txt in the halo CE root directory. Sometimes you haven't extracted the tags to the right folder or something, or copying over similar files will do the trick.
- In response to last post, close globals.globals when BEFORE closing guerilla, then re-extract the globals, then open up guerilla again and open up the (hopefully) re-extracted globals.globals.


sleepy1212
Joined: Feb 4, 2009

sunnier than you www.quantumfusionclan.com


Posted: Oct 26, 2009 05:25 PM    Msg. 20 of 20       
to add to this: some of the vehicle tags come with tags that won't error, like cyborg_animation...you can load the vehicle fine in sapien but its not there in game because there is no animation for the biped to enter the vehicle. things like hud messages and animations come in long lists and you have to open those dropdowns and make sure they're in there.

 

 
Previous Older Thread    Next newer Thread







Time: Sun August 9, 2020 9:56 PM 172 ms.
A Halo Maps Website