A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo Custom Edition (Bungie/Gearbox) »Halo CE Technical / Map Design »sapien goes screwwy again

Author Topic: sapien goes screwwy again (12 messages, Page 1 of 1)
Moderators: Dennis

darkassassin14
Joined: Jul 23, 2007

El. Psy. Congroo.


Posted: Oct 21, 2009 07:31 PM    Msg. 1 of 12       
i got this error and i dont no wat it is

10.21.09 19:25:16 a hobo pc 01.01.00.0609 ----------------------------------------------
10.21.09 19:25:16 reference function: _write_to_error_file
10.21.09 19:25:16 reference address: 401b13
10.21.09 19:25:16 Couldn't read map file './a_hobobeta.map'
10.21.09 19:25:17 Retrying CreateDevice with default refresh rate...


Greenfuzz
Joined: Nov 18, 2008

PM me if you have CoD MW for Wii


Posted: Oct 21, 2009 08:40 PM    Msg. 2 of 12       
Theres no error. Try opening up regular sapien


Matooba
Joined: Dec 26, 2005

Crust on Halomaps! :)


Posted: Oct 21, 2009 08:43 PM    Msg. 3 of 12       
Are you missing some of the debug?
Also, you running dual core?
With XP run task manager and set affinity to use only one CPU or right click shortcut and run in win 98 mode.
For vista right click shortcut / run as admin.
Also you could try right clicking on your desktop go to properties, then go to the settings tab and make sure the color quality is 32 bit.

Edited by Matooba on Oct 21, 2009 at 08:54 PM


darkassassin14
Joined: Jul 23, 2007

El. Psy. Congroo.


Posted: Oct 23, 2009 04:07 PM    Msg. 4 of 12       
ok i tried with original sapien and it gives the same error. im not running dual core and just in case i checked the affinity thing and its not thr so its not that. and thats all to the debug. i tried my map and an original and thrs no difference.


cheezburger
Joined: Oct 29, 2009


Posted: Oct 29, 2009 03:49 AM    Msg. 5 of 12       
The error "can not find ./toolbeta.map" was not a problem, just part of the developers code.
I might be wrong, but this could be inconsequential.
Also, you might be attempting to load an unsupported filetype. (e.g. trying to open .map files in guerilla displays a similar error then crashes. Beyond that, I can't help


XlzQwerty1
Joined: Aug 6, 2009


Posted: Oct 29, 2009 03:33 PM    Msg. 6 of 12       
No, you can't open anything else in sapien but .scenario files because sapien only supports .scenario files

I have had this problem before since after I reformatted my computer, I think what I did to fix it was change the color qualities in the desktop's settings menu from 16-bit to 32-bit. Check to see what your color quality is (Right-click desktop>properties>settings>color quality).
Edited by XlzQwerty1 on Oct 29, 2009 at 03:34 PM


darkassassin14
Joined: Jul 23, 2007

El. Psy. Congroo.


Posted: Nov 2, 2009 02:47 PM    Msg. 7 of 12       
i reinstalled HEK and now it works but now i got this new error during radiosity

10.26.09 18:21:24 a hobo pc 01.01.00.0609 ----------------------------------------------
10.26.09 18:21:24 reference function: _write_to_error_file
10.26.09 18:21:24 reference address: 401b13
10.26.09 18:21:24 Couldn't read map file './a_hobobeta.map'
10.26.09 18:21:24 CreateDevice succeeded with refresh rate = 0
10.26.09 18:21:25 Sound card doesn't meet minimum hardware requirements. Disabling hardware option.
10.26.09 18:21:25 Increasing sound decompression buffer size to 1048576 bytes
10.26.09 18:22:50 local player 0, weapon (0x0), deleted unexpectedly
10.26.09 18:27:29 EAX: 0xFFFFFFFE
10.26.09 18:27:29 EBX: 0xFFFFE201
10.26.09 18:27:29 ECX: 0x0012F298
10.26.09 18:27:29 EDX: 0x000002CC
10.26.09 18:27:29 EDI: 0x0012F298
10.26.09 18:27:29 ESI: 0x00000000
10.26.09 18:27:29 EBP: 0x0012F170
10.26.09 18:27:29 ESP: 0x0012F160
10.26.09 18:27:29 EIP: 0x7C90E514, C3 8D A4 24 ?????
10.26.09 18:27:29 EXCEPTION halt in \halopc\haloce\source\memory\data.c,#495: object looping sounds index #0 (0xe26f0000) is unused or changed

much more of an error now isnt it


sleepy1212
Joined: Feb 4, 2009

sunnier than you www.quantumfusionclan.com


Posted: Nov 3, 2009 03:10 AM    Msg. 8 of 12       
did sapien close itself or did it say 'out of memory'?


aco
Joined: Nov 4, 2009


Posted: Nov 4, 2009 01:36 AM    Msg. 9 of 12       
seems like hardware issue, but in case you screwed some in scenario, when you run tool, right click on cmd or tool++ and do run as admin, and structure and lightmaps it again .. and then try sapien, also with rightclick run as admin ...

if dont work ... do this as last desperate measure, or make copy of your current .scenario, open it in guerilla, and delete all weapons, all scenery, all vehicles, etc .. practicly delete all, and in globals bring back halo default vehicles, and default weps ...

this is a desperate measure ...


darkassassin14
Joined: Jul 23, 2007

El. Psy. Congroo.


Posted: Dec 21, 2009 10:39 PM    Msg. 10 of 12       
well i gave up on that problem and didnt want to start a new thread. so now i got a new problem while trying to do lightmaps with tool

12.21.09 22:32:11 tool pc 01.00.00.0609 ----------------------------------------------
12.21.09 22:32:11 reference function: _write_to_error_file
12.21.09 22:32:11 reference address: 42ca20
12.21.09 22:32:11 Couldn't read map file './toolbeta.map'
12.21.09 22:32:12 i'm going to render debug lightmaps for 1 of levels\test\multi_level\multi_level, and i'll stop when red+blue+green = 0.000001.
Hit control-c now if this isn't right.
12.21.09 22:32:13 the meter definition ui\hud\cyborg shield does not specify a stencil bitmap group.
12.21.09 22:32:13 the meter definition ui\hud\cyborg body does not specify a stencil bitmap group.
12.21.09 22:32:14 WARNING: 1 clusters in structure_bsp levels\test\multi_level\multi_level have no background sound or sound environment.
12.21.09 22:32:14 done

thats all it does no numbers or anything and as you can see it only took a few seconds so i no its not actually done
Edited by darkassassin14 on Dec 21, 2009 at 10:42 PM


sleepy1212
Joined: Feb 4, 2009

sunnier than you www.quantumfusionclan.com


Posted: Dec 21, 2009 11:05 PM    Msg. 11 of 12       
i've had this before...it's some kind of modeling error like bad UV's or z-buffers or something. post your debug from the structure command


darkassassin14
Joined: Jul 23, 2007

El. Psy. Congroo.


Posted: Dec 21, 2009 11:09 PM    Msg. 12 of 12       
there wer no errors when doing the structure command. only error was i forgot to name the texture on the model and it said WARNING: randomly chose one of the 2 shaders called 'material #' (you should fix this!). so i renamed and it work without errors

 

 
Previous Older Thread    Next newer Thread







Time: Tue August 4, 2020 4:08 AM 266 ms.
A Halo Maps Website