A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo Custom Edition (Bungie/Gearbox) »Halo CE Technical / Map Design »SAPIEN PROBLEMS

Author Topic: SAPIEN PROBLEMS (20 messages, Page 1 of 1)
Moderators: Dennis

Perko
Joined: Dec 7, 2009

yes, really!


Posted: Dec 19, 2009 08:53 PM    Msg. 1 of 20       
sapien is messed up. how do i get it to work
anyways what is the scenario?
forgive me for being so ignorant
Edited by Perko on Dec 19, 2009 at 08:57 PM


sargejohnson
Joined: Apr 20, 2009

Shall we play a game?


Posted: Dec 19, 2009 10:05 PM    Msg. 2 of 20       
need more detail on your problem there, does sapien close itself when opening any .scenario file? Or does it close when opening a particular .scenario file?
Open the .scenario file in sapien, and when sapien closes. find debug.txt and post the last paragraph of it here.


Perko
Joined: Dec 7, 2009

yes, really!


Posted: Dec 19, 2009 10:58 PM    Msg. 3 of 20       
i extracted the scenario from bloodgulch (levels\test\bloodgulch) and when i try to open it it says, 'you tried to open a non-scenario file. Bad!'
the only things debug.txt says is for guerilla. i checked the bloodgulch.scenario tag and extracted it again and tried again. still not working.


MechWarrior001
Joined: Mar 13, 2007


Posted: Dec 20, 2009 12:32 AM    Msg. 4 of 20       
all tags need to be in the tags subdirectory of the HCE root folder. (usually ...\...\Halo Custom Edition\tags) or Guerilla & Sapien will not see them as tags. Your trying to open a scenario tag outside of the tags directory so sapien thinks it's not a scenario tag.


Perko
Joined: Dec 7, 2009

yes, really!


Posted: Dec 20, 2009 12:40 AM    Msg. 5 of 20       
awesome help. cheers bro
another problem, when i try to put the blitzkrieg.dle plugin in the plugins directory for 3dsmax, it won't recognize it

also with sapien, how do you move the camera around? all i can do is click and go somewhere
Edited by Perko on Dec 20, 2009 at 01:02 AM


Dark Neon
Joined: Jun 8, 2009


Posted: Dec 20, 2009 10:25 AM    Msg. 6 of 20       
Hold the Scroll wheel thing on the mouse down and use these keys to move around. W = forward, A = Left, D = Right, S = Backwards, F = down and R = Move up.


Perko
Joined: Dec 7, 2009

yes, really!


Posted: Dec 20, 2009 04:36 PM    Msg. 7 of 20       
awesome. how do i swing the camera around though?


Perko
Joined: Dec 7, 2009

yes, really!


Posted: Dec 21, 2009 04:44 PM    Msg. 8 of 20       
lol


Headhunter09
Joined: May 6, 2008

This is the truth.


Posted: Dec 21, 2009 05:56 PM    Msg. 9 of 20       
and SHIFT increases speed


Perko
Joined: Dec 7, 2009

yes, really!


Posted: Dec 21, 2009 07:02 PM    Msg. 10 of 20       
how do you add weapons to place them around the map?
Edited by Perko on Dec 22, 2009 at 10:31 PM


sargejohnson
Joined: Apr 20, 2009

Shall we play a game?


Posted: Dec 22, 2009 10:47 PM    Msg. 11 of 20       
are you trying to place weapons for mp maps or sp maps?


Perko
Joined: Dec 7, 2009

yes, really!


Posted: Dec 22, 2009 10:56 PM    Msg. 12 of 20       
mp for bloodgulch cos i imported extra things and i want to place them

now it won't even open bloodgulch. debug sez

12.23.09 17:30:57 sapien pc 01.00.00.0609 ----------------------------------------------
12.23.09 17:30:57 reference function: _write_to_error_file
12.23.09 17:30:57 reference address: 401b13
12.23.09 17:30:57 Couldn't read map file './sapienbeta.map'
12.23.09 17:30:58 CreateDevice succeeded with refresh rate = 0
12.23.09 17:30:58 Sound card doesn't meet minimum hardware requirements. Disabling hardware option.
12.23.09 17:30:58 Increasing sound decompression buffer size to 1048576 bytes
12.23.09 17:30:58 the model 'weapons\m134-minigun\m134-minigun' and the collision model 'weapons\m134-minigun\shaders\triggergrip' don't match (node counts don't match)
12.23.09 17:30:58 the object 'weapons\m134-minigun\m134 minigun' will not be collidable
12.23.09 17:30:59 local player 0, weapon (0x0), deleted unexpectedly
12.23.09 17:30:59 EAX: 0x00120124
12.23.09 17:30:59 EBX: 0x00000001
12.23.09 17:30:59 ECX: 0x0012C268
12.23.09 17:30:59 EDX: 0x3F7D8C54
12.23.09 17:30:59 EDI: 0x0012BD90
12.23.09 17:30:59 ESI: 0x00000000
12.23.09 17:30:59 EBP: 0x0012BC68
12.23.09 17:30:59 ESP: 0x0012BC58
12.23.09 17:30:59 EIP: 0x7C90E514, C3 8D A4 24 ?????
12.23.09 17:30:59 EXCEPTION halt in \halopc\haloce\source\tag_files\tag_groups.c,#3157: #2 is not a valid powered_mass_point_block index in [#0,#2)

and i can't extract it again because HEK+ is broken. its doing the thing where it can't open bitmap tags becasue 'they are in use by another process' when nothing else is open


Edited by Perko on Dec 23, 2009 at 01:36 AM


deslakle
Joined: Dec 17, 2009


Posted: Dec 23, 2009 12:35 PM    Msg. 13 of 20       
Okay, I am not trying to be abusive, but almost everything you are asking about except your last post are directly in the HEK tutorial that comes with it. I recommend you read that and look at some tutorials on this site. They are very helpful. The official HEK tutorial can be found at:

http://hce.halomaps.org/hek/

Also, I believe your debug is saying that m134-minigun gbxmodel and m134-minigun collision model have different node counts, so you may want to fix that. I don't know what that EXCEPTION halt means, though.


Perko
Joined: Dec 7, 2009

yes, really!


Posted: Dec 23, 2009 04:37 PM    Msg. 14 of 20       
yeah i know that there is the tutorial but it's sooooooo much easier asking people who have actually done the things than reading about them



as for the minigun, no, it's not collidable because it didn't come with a collision model. That's not the problem becasue I opened the scenario before and it was fine. The exception is what's making it crash, i know that much. I think that if i could extract the whole map again then it would be fixed


thanks for the help guys, you rock


CAN SOMEONE FIX SAPIEN FOR GOOD OR MAKE SOMETHING THAT WORKS

How do you add custom vehicles into your map using Sapien?
Edited by Perko on Dec 24, 2009 at 02:44 AM


sargejohnson
Joined: Apr 20, 2009

Shall we play a game?


Posted: Dec 24, 2009 08:27 AM    Msg. 15 of 20       
you add custom vehicles to maps in two ways.
you either replace the default vehicles that are in globals.globals, or you script them in.
first method allows up to 6 types of vehicles and is easier, second method allows a lot more but is a lot more complicated.
which method do you want?

also, the exception error in your previous post indicates that something you added to your map has a screwed-up physics file. Delete each and every vehicle in the map one by one until you find out which one is exceptioning your map.


Perko
Joined: Dec 7, 2009

yes, really!


Posted: Dec 25, 2009 06:43 PM    Msg. 16 of 20       
it was becasue i got the scenario from an existing map and saved it as a new map. i was trying to open the old scenario which made sapien unhappy so i just opened the new one



as for the vehicles, the short way sounds better becasue i can't be bothered to script. can u post how to cos i have no idea
You guys rock and thx for putting up with the ultra-n00b (me)


also, if i have modified an existing model in 3dsmax, how would i get it into the game? plz help me cos im a n00b
Edited by Perko on Dec 26, 2009 at 12:00 AM


sargejohnson
Joined: Apr 20, 2009

Shall we play a game?


Posted: Dec 26, 2009 12:46 AM    Msg. 17 of 20       
here's how to replace the vehicles in your .globals file
1. in your tags folder, look for the folder called globals, then open it and look for globals.globals.
2. open globals.globals in Guerilla, and then scroll down to the section labelled Multiplayer Information, then to its subsection Vehicles.
3. Replace the vehicles you see in the drop-down box there with the vehicles you want, and you are done.

if it doesn't help, post it here.


Perko
Joined: Dec 7, 2009

yes, really!


Posted: Dec 26, 2009 12:49 AM    Msg. 18 of 20       
so then do i have to save it and build the map? or will i be able to place them in ahobo straight away?

also, does anyone know how i could possibly have turned off the chat and game information writing on the left of the screen? mine is not appearing.
Edited by Perko on Dec 26, 2009 at 12:56 AM


sargejohnson
Joined: Apr 20, 2009

Shall we play a game?


Posted: Dec 26, 2009 09:42 AM    Msg. 19 of 20       
you will have to save your new globals.globals before you put the new vehicles in sapien/ahobo.

also, your latter problem is similar to what i have (and i have posted a thread about it). Though these solutions didn't help for me (so i still have the problem lol), but you can still try them and hope they work:
http://hce.halomaps.org/index.cfm?nid=268


Perko
Joined: Dec 7, 2009

yes, really!


Posted: Dec 26, 2009 11:06 PM    Msg. 20 of 20       
HOORAY EVERYTHINGS BROKEN
the chat things didn't work so im downloading the game again
HEK+ is broken cos when i try to extract stuff it says that the bitmaps are used by another process when nothing is open
ahobo is broke cos adding the vehicles doesn't work
as a result, i'm done with halo CE. I have deleted it off of my computer and am never playing it again. No, this is not a rash decision. I have thought long and hard about it.
Edited by Perko on Dec 27, 2009 at 12:05 AM

 

 
Previous Older Thread    Next newer Thread







Time: Mon January 27, 2020 10:45 PM 93 ms.
A Halo Maps Website