A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo Custom Edition (Bungie/Gearbox) »Halo CE Technical / Map Design »Indecipherable Error from Sapien

Author Topic: Indecipherable Error from Sapien (12 messages, Page 1 of 1)
Moderators: Dennis

HogdriverOneFiveFive
Joined: Dec 21, 2007

Prodigal Son Returns-Actual Join Date April, 2006.


Posted: Feb 2, 2010 10:36 PM    Msg. 1 of 12       
Ive been able to fix 90% of other Sapien errors, they were mostly "Could not find path" errors. I was thinking of deleting every scenery object, ect untill i found the problem and nailed it to a damn wall.
Here it is. No reason given... literally.

02.02.10 22:32:19 sapien pc 01.00.00.0609 ----------------------------------------------
02.02.10 22:32:19 reference function: _write_to_error_file
02.02.10 22:32:19 reference address: 401b13
02.02.10 22:32:19 Couldn't read map file './sapienbeta.map'
02.02.10 22:32:19 CreateDevice succeeded with refresh rate = 0
02.02.10 22:32:20 Sound card doesn't meet minimum hardware requirements. Disabling hardware option.
02.02.10 22:32:20 Increasing sound decompression buffer size to 1048576 bytes
02.02.10 22:32:21 WARNING: 38 clusters in structure_bsp levels\vertigo_city_original\vertigo_city_original have no background sound or sound environment.
02.02.10 22:32:21 local player 0, weapon (0x0), deleted unexpectedly
02.02.10 22:32:21 EAX: 0x00120120
02.02.10 22:32:21 EBX: 0x10692B01
02.02.10 22:32:21 ECX: 0x0012C268
02.02.10 22:32:21 EDX: 0x3F7DCF55
02.02.10 22:32:21 EDI: 0x0012BD88
02.02.10 22:32:21 ESI: 0x00000000
02.02.10 22:32:21 EBP: 0x0012BC60
02.02.10 22:32:21 ESP: 0x0012BC50
02.02.10 22:32:21 EIP: 0x7C90EB94, C3 8D A4 24 ?????
02.02.10 22:32:21 EXCEPTION halt in \halopc\haloce\source\physics\physics.c,#390:
Edited by HogdriverOneFiveFive on Feb 2, 2010 at 10:38 PM
Edited by HogdriverOneFiveFive on Feb 2, 2010 at 10:38 PM


Maniac1000
-Helpful Poster-
Joined: Feb 24, 2007


Posted: Feb 2, 2010 10:51 PM    Msg. 2 of 12       


HogdriverOneFiveFive
Joined: Dec 21, 2007

Prodigal Son Returns-Actual Join Date April, 2006.


Posted: Feb 2, 2010 11:06 PM    Msg. 3 of 12       
So... run in windows 98 mode? lol, thats silly.

Its that easy?

It appears that two vehicles cause the error. The infallible Wasp, and the AA Wraith i downloaded from this site.

02.02.10 23:08:02 sapien pc 01.00.00.0609 ----------------------------------------------
02.02.10 23:08:02 reference function: _write_to_error_file
02.02.10 23:08:02 reference address: 401b13
02.02.10 23:08:02 Couldn't read map file './sapienbeta.map'
02.02.10 23:08:02 CreateDevice succeeded with refresh rate = 0
02.02.10 23:08:02 Sound card doesn't meet minimum hardware requirements. Disabling hardware option.
02.02.10 23:08:02 Increasing sound decompression buffer size to 1048576 bytes
02.02.10 23:08:04 WARNING: 38 clusters in structure_bsp levels\vertigo_city_original\vertigo_city_original have no background sound or sound environment.
02.02.10 23:08:04 local player 0, weapon (0x0), deleted unexpectedly
02.02.10 23:08:27 EAX: 0x00000000
02.02.10 23:08:27 EBX: 0x00000001
02.02.10 23:08:27 ECX: 0x7C80240F
02.02.10 23:08:27 EDX: 0x7C90EB94
02.02.10 23:08:27 EDI: 0x0013BD90
02.02.10 23:08:27 ESI: 0x00000000
02.02.10 23:08:27 EBP: 0x0013BC68
02.02.10 23:08:27 ESP: 0x0013BC58
02.02.10 23:08:27 EIP: 0x7C90EB94, C3 8D A4 24 ?????
02.02.10 23:08:27 EXCEPTION halt in \halopc\haloce\source\tag_files\tag_groups.c,#3157: #2 is not a valid powered_mass_point_block index in [#0,#2)
Did what it said, spit out another.

(bolded to show emphasis)
Edited by HogdriverOneFiveFive on Feb 2, 2010 at 11:11 PM
Edited by HogdriverOneFiveFive on Feb 2, 2010 at 11:28 PM


sargejohnson
Joined: Apr 20, 2009

Shall we play a game?


Posted: Feb 3, 2010 01:31 AM    Msg. 4 of 12       
the aa wraith has corrupt physics, replace the physics file originally referenced in the vehicle tag to the normal wraith's physics file, then retry compiling.
as for the wasp, i wouldn't know what error it has until you fix the aa wraith up first.


sleepy1212
Joined: Feb 4, 2009

sunnier than you www.quantumfusionclan.com


Posted: Feb 3, 2010 08:58 AM    Msg. 5 of 12       
The wasp on here is missing stuff. pelican_engine.sound_looping comes to mind.


chrisk123999
Joined: Aug 10, 2008

=CE= Chris [Captain] [=]


Posted: Feb 4, 2010 08:00 PM    Msg. 6 of 12       
You can easily rip the sound from SP...


Gamma927
Joined: Jun 12, 2008

Steam: gamma927


Posted: Feb 4, 2010 08:07 PM    Msg. 7 of 12       
Missing tags wouldn't cause exceptions.


sleepy1212
Joined: Feb 4, 2009

sunnier than you www.quantumfusionclan.com


Posted: Feb 4, 2010 08:37 PM    Msg. 8 of 12       
Quote: --- Original message by: Gamma927
Missing tags wouldn't cause exceptions.

the one i mentioned will keep sapien from loading.


Gamma927
Joined: Jun 12, 2008

Steam: gamma927


Posted: Feb 4, 2010 10:16 PM    Msg. 9 of 12       
But unless the sound is corrupted, it won't cause an exception in the debug text. It would instead cause a file_read error, which WOULD prevent Sapien from loading, but would create a different debug output.


sleepy1212
Joined: Feb 4, 2009

sunnier than you www.quantumfusionclan.com


Posted: Feb 4, 2010 11:04 PM    Msg. 10 of 12       
Quote: --- Original message by: Gamma927
But unless the sound is corrupted, it won't cause an exception in the debug text. It would instead cause a file_read error, which WOULD prevent Sapien from loading, but would create a different debug output.

ya know what, i remember this because i used them both in a map at the same time and had tag errors. it was probably the wraith physics that caused the exception. i fixed everything all at once so i just assumed the exception could be from any of those errors.


Dwood
Joined: Oct 23, 2007

Judge Ye Therefore


Posted: Feb 5, 2010 07:00 AM    Msg. 11 of 12       
Remove vehicles from your map one by one until it loads.


MechWarrior001
Joined: Mar 13, 2007


Posted: Feb 7, 2010 07:05 PM    Msg. 12 of 12       
You either tried to manually set your inertial matrix block values or your center of mass/gravity values in the physics tag. Those values & the xx/zz/yy moment values are calculated automatically after you give the physics tag mass points. They will cause errors if you try to input them manually. Also, about the powered mass point error, is it possible you have too many flags checked at once? I use 3 most of the time, usually only the ground/water/air friction flags.

 

 
Previous Older Thread    Next newer Thread







Time: Tue August 4, 2020 2:06 PM 187 ms.
A Halo Maps Website