A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo Custom Edition (Bungie/Gearbox) »Halo CE Technical / Map Design »editable mesh to poly problem and odd tool errors i'm getting

Author Topic: editable mesh to poly problem and odd tool errors i'm getting (4 messages, Page 1 of 1)
Moderators: Dennis

Halo Frooblet
Joined: Apr 7, 2009


Posted: Jun 20, 2010 05:18 PM    Msg. 1 of 4       
Ok, this problem i'm having is a little messed up, and i couldn't find a similar thread in the fourms.

I started making a map and throughout the modeling process i switched in between editable mesh and editable poly a few times, and 95% of the modeling was done with editable mesh.

The problems are what's going on when i export this and run it in tool.

I first exported the map when it was an editable mesh, tool created a bsp and there were no edge errors. When i got around to opening the map in sapian, some of the polygons and structures were flipped inside out...

I then went back to the model and converted it to an editable poly and then exported it.
When i ran it through tool, tool found open edges, the next weird part is that when i imported the wrl error into 3ds max7 and checked up on the open edges, NONE of them were open, and i checked multiple times.

I'm wondering if i'm having this problem because i switched in between mesh and poly while still modeling? Also, What can i do to fix what ever is going on?


GameCreat0r
Joined: Apr 9, 2010

"Perhaps the ending has not yet been written..."


Posted: Jun 21, 2010 03:53 AM    Msg. 2 of 4       
open edges don't always look open. Let's say you got 4 vertecies of whitch one high and 3 lower ones on a row.
.

. . .

Now If you make a face only attached over the outer 3 vertecies you got yourself 2 open edges. Also 3ds max can make 2 faces one itself whitch is exactly what you don't want again. So check if any of your faces passes by an vertex for no reason and fix that.

Also it should work fine in editeble mesh I never used poly.
Edited by Niels on Jun 21, 2010 at 03:54 AM


SlappyThePirate
Joined: Aug 24, 2009

You are irritating, I'll release nothing


Posted: Jun 21, 2010 05:59 PM    Msg. 3 of 4       
face
_________________
face | face
face |

There should always be vertices at the intersection.


Halo Frooblet
Joined: Apr 7, 2009


Posted: Jun 22, 2010 11:28 AM    Msg. 4 of 4       
There are definitely no open edges where it marks them. I checked every polygon a million times... the map is completely sealed. Also, this only happens when i export this in editable poly. When its an editable mesh there are no open edges, but for some reason, in the bsp, some faces are flipped around and the textures aren't showing up right even though the textures and shaders don't have any problems....

 

 
Previous Older Thread    Next newer Thread







Time: Sun December 15, 2019 4:03 PM 187 ms.
A Halo Maps Website