A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo Custom Edition (Bungie/Gearbox) »Halo CE Technical / Map Design »I made a turret, it gives exceptions when I exit it.

Author Topic: I made a turret, it gives exceptions when I exit it. (15 messages, Page 1 of 1)
Moderators: Dennis

OpsY
Joined: Feb 19, 2007

Frobisher Bay


Posted: Dec 1, 2010 11:15 AM    Msg. 1 of 15       
Can anyone help on that? I made side turrets on the Halo 3 frigate ( and one or two others as test) and they give me exception whenever I exit it. I don't know why that is! I am able to properly get inside it, fire, use it all as planned but I cannot exit it after I have entered or BOOM, exception.


any help appreciated!


BOB
Joined: Jan 2, 2011

i like cake


Posted: Jan 2, 2011 10:47 AM    Msg. 2 of 15       
I'm kind of a noob at this but its happened to me before, because of the collision model. Since the collision model didn't match the gbxmodel it wouldn't collide, therefore when you got out BOOM exception. Try double checking your collision model.


Maniac1000
-Helpful Poster-
Joined: Feb 24, 2007


Posted: Jan 2, 2011 12:00 PM    Msg. 3 of 15       
If the node checksums match then that wouldnt be a problem?


MoooseGuy
Joined: Aug 10, 2008

I Approve This Message.


Posted: Jan 3, 2011 02:51 AM    Msg. 4 of 15       
I don't think it's the collision model... I have been on scenery that has collision problems, and I bounce all over the place like a mofo. The problem is in your exit animation.


MoooseGuy
Joined: Aug 10, 2008

I Approve This Message.


Posted: Jan 3, 2011 05:06 AM    Msg. 5 of 15       
I'm glad I don't have to deal with things like this. XD


Grant2498
Joined: Jan 10, 2011

Procrastinators UNITE!... Tomorrow...


Posted: Jan 10, 2011 03:35 PM    Msg. 6 of 15       
Same thing is happened to me! I'm not quite sure, but I think it may have something to do with the collision geometry. The collision I used didn't match the GBXModel, and It gives me an exception when I exit it. I'm gonna try to fix the collision, and see if it does anything...


Cheddars
Joined: Oct 30, 2010

Rave to the Grave.


Posted: Jan 13, 2011 05:26 PM    Msg. 7 of 15       
If it is collision model it will say it when you build the map something like node count don't match.the vehicle will not collide


Grant2498
Joined: Jan 10, 2011

Procrastinators UNITE!... Tomorrow...


Posted: Jan 13, 2011 08:05 PM    Msg. 8 of 15       
I fixed the collision model and I don't get exceptions anymore.


OpsY
Joined: Feb 19, 2007

Frobisher Bay


Posted: Mar 24, 2011 07:43 PM    Msg. 9 of 15       
Sorry for the bump, the nodelist checksum match, that's not the issue. I would believe it's related to the exit animation, can anyone help me find what i'm trying to find? I really know nothing about animations tags and what is actually doing the wrong... Can anyone give a little hand?


Kruger
Joined: Dec 20, 2010

rawr


Posted: Mar 30, 2011 05:02 PM    Msg. 10 of 15       
Do you have an exit animation for it? If not make one. If you do, make sure it is being used by checking the .model_animation tag in guerrilla.


OpsY
Joined: Feb 19, 2007

Frobisher Bay


Posted: Mar 31, 2011 12:12 PM    Msg. 11 of 15       
Right I have no idea how to make an exit animation and how to reference it in the animation tag. Can anyone help me with that?


Kruger
Joined: Dec 20, 2010

rawr


Posted: Mar 31, 2011 10:42 PM    Msg. 12 of 15       
Well crap, my bad. I haven't done turrets in a while and forgot that they didn't have exiting animations built into the turret tags.
Go into your vehicle tag and under the seat label what did you put? Try setting it to W-gunner.
Edited by Kruger on Mar 31, 2011 at 10:45 PM


OpsY
Joined: Feb 19, 2007

Frobisher Bay


Posted: Apr 2, 2011 08:51 PM    Msg. 13 of 15       
It's already set at W-gunner. I made a turret once before and it didn't do that... but all the ones I've tryed ever since do that.


Kruger
Joined: Dec 20, 2010

rawr


Posted: Apr 5, 2011 12:46 AM    Msg. 14 of 15       
Does your turret have the same marker setup as the warthog turret?


OpsY
Joined: Feb 19, 2007

Frobisher Bay


Posted: Apr 12, 2011 12:09 PM    Msg. 15 of 15       
I fixed it with ODST Nick's help and here's the answer, in case someone wonders or happens to use the SEARCH function someday. Depsite the fact the turret does Not have collisions, the feet of the biped interesting with the base of the turret was causing the exception. Moving the #gunner node a few units back solved this issue. Thanks everyone.

 

 
Previous Older Thread    Next newer Thread







Time: Thu October 17, 2019 3:38 PM 312 ms.
A Halo Maps Website