A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo Custom Edition (Bungie/Gearbox) »Halo CE Technical / Map Design »tool gives"some shaders were not defined" error

Author Topic: tool gives"some shaders were not defined" error (11 messages, Page 1 of 1)
Moderators: Dennis

Kevin117
Joined: Jul 30, 2011


Posted: Jul 30, 2011 06:05 AM    Msg. 1 of 11       
So I'm new to the map-making business but I can't seem to get it to work.

I tried to follow the HEK tutorial for creating maps using 3ds max 2011. I exported my max file using BlueStreak. But when I tried to compile the jms file using tool it asks me to "choose a type for the shader 'example_tutorial_ground'" It doesn't matter which shader I pick because it always ends up giving the error. "some shaders were not defined" at the end.

Also, when I try to run radiosity in Sapien the ground (which is all I created) in the level doesn't show up (sky shows up fine).

I followed part 1 of "level creation" in the HEK tutorial as best I could. And I have a feeling my problem lies with the way I defined the materials in 3ds Max.

Help would be appreciated.


Kevin117
Joined: Jul 30, 2011


Posted: Jul 30, 2011 07:02 PM    Msg. 2 of 11       
I've tried running radiosity and it just gives a bunch of 0's, implying there is nothing to light.

As for the material, I've already set it in scenario_structure_bsp with the correct bitmap. Are there any special settings I need to use to make it show up? I'm using the example_tutorial_ground that comes with the HEK tutorial.

All it shows in radiosity is the sky and a blue square on the ground where the bitmap for where the ground should be.

Is there anywhere I can find a tutorial on how to create levels in 3ds max 2011 for halo ce? That might help...


ally
Joined: Jun 23, 2010

Aye Ready


Posted: Jul 30, 2011 07:09 PM    Msg. 3 of 11       
hopefully i can help you man, if when you run radiosity_quality 0
and the numbers do count down to all zeros then that is it done.
next you hit the tilde key again then type radiosity_save
now your map should show up.
any problems post back.


Kevin117
Joined: Jul 30, 2011


Posted: Jul 30, 2011 07:12 PM    Msg. 4 of 11       
The numbers start at 0 and they go nowhere.

I do radiosity_quality 0 then radiosity_start and in less then a second all the numbers are at 0.

Only the sky which i selected as a tag shows along with a lightblue box where the ground bitmap should be.


ally
Joined: Jun 23, 2010

Aye Ready


Posted: Jul 30, 2011 07:24 PM    Msg. 5 of 11       
did you definetly do all that was needed:
name your textures/materials correct.
create a shader_environment file.
did you edit the scenario file in guerilla.

if you did them for sure. try running radiosity with tool
the command is, tool lightmaps levels\nameofyourmap\nameofyourmap nameofyourmap 0 0.9


0.09 is to test.


Kevin117
Joined: Jul 30, 2011


Posted: Jul 30, 2011 07:35 PM    Msg. 6 of 11       
We'll I"m not to sure I created a shader_environment file? It doesn't say anything about that in the tutorial...

Usually when I try to compile my jms file in tool it says "choose a type for the shader " and I pick 1 (shader_enviornment). And then after that it gives the error "some shaders were not defined".

Is there a more appropriate way to create a shader_environment file?


ally
Joined: Jun 23, 2010

Aye Ready


Posted: Jul 30, 2011 07:44 PM    Msg. 7 of 11       
when tool gives you that option from 1-9 and you choose one of them, tool will then put a shder file in your tags folder, the shader file it puts there relates to the bitmap that needs it.

you should open guerilla then in guerilla locate the shader file (should be at the bottom of the list in your tags folder). you need to edit this file, put a tick beside simple parameterization then scroll down to base map now in the ... click it and give the path to your ground bitmap(as you said you only added a ground) close the guerilla window and cliick yes to save, then continue.
your shader problem should be gone.


Kevin117
Joined: Jul 30, 2011


Posted: Jul 30, 2011 08:27 PM    Msg. 8 of 11       
When I try to give a path to the ground bitmap, I press open but it but the box remains clear. My bitmap is located under the data directory. Is it only allowed to be under the tags directory?


ally
Joined: Jun 23, 2010

Aye Ready


Posted: Jul 30, 2011 08:50 PM    Msg. 9 of 11       
you should be locating the bitmap in your tags folder, it should be in the folder called bitmaps from when you compiled your bitmaps in tool.


Kevin117
Joined: Jul 30, 2011


Posted: Jul 30, 2011 09:20 PM    Msg. 10 of 11       
Thanks. I got it to work. It was a combination of me not exporting my bitmaps using tool and not saving my radiosity.


ally
Joined: Jun 23, 2010

Aye Ready


Posted: Jul 30, 2011 10:48 PM    Msg. 11 of 11       
good news :)

 

 
Previous Older Thread    Next newer Thread







Time: Tue November 19, 2019 4:46 PM 172 ms.
A Halo Maps Website