A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo CE Maps (Bungie/Gearbox) »Halo CE General Discussion »Halo CE on Windows 7.

Page 1 of 2 Go to page: · [1] · 2 · Next
Author Topic: Halo CE on Windows 7. (38 messages, Page 1 of 2)
Moderators: Dennis

Flyboy
Joined: Jan 7, 2012


Posted: Jan 7, 2012 03:32 PM          Msg. 1 of 38
I honestly don't know if this is a problem with me running WIndows 7 64-Bit, or my radeon 6850 video card.

I'm having the typical problem of the black screen with music playing and menu sounds being heard on the main menu of both Halo 1 and Halo CE - I read that this could be a problem with forced AA, but I did my best to disable AA (The best you can do with catalyst is set it to "Application managed" setting), but nothing seems to be working. I tried installing various patches found here on the site but nothing at all is having any affect.

Any advice?


Maniac1000
-Helpful Poster-
Joined: Feb 24, 2007

ally for Taoiseach


Posted: Jan 7, 2012 03:35 PM          Msg. 2 of 38
The black screen and only music is always caused by AA.
You must have not done it right somehow.


Co1t3r
Joined: Dec 13, 2008

I'm so awesome right now!


Posted: Jan 7, 2012 03:36 PM          Msg. 3 of 38
Are you running the latest drivers for you video card? It's not Windows 7 64-bit problem since it run perfectly for me.


Flyboy
Joined: Jan 7, 2012


Posted: Jan 7, 2012 03:37 PM          Msg. 4 of 38
Yeah, I gathered that. But my catalyst settings are clearly set to "application managed" in regards to AA (they always have been). I don't know what more I can do than that.

Quote: --- Original message by: Co1t3r
Are you running the latest drivers for you video card? It's not Windows 7 64-bit problem since it run perfectly for me.

I am up to date with catalyst version 11.12
Edited by Flyboy on Jan 7, 2012 at 03:38 PM


Waffles
Joined: Nov 18, 2010

fufufuuu


Posted: Jan 7, 2012 03:40 PM          Msg. 5 of 38
turn AA off then, and try again.


Flyboy
Joined: Jan 7, 2012


Posted: Jan 7, 2012 03:41 PM          Msg. 6 of 38
Quote: --- Original message by: waffles
turn AA off then, and try again.

Exactly what I'm trying to do. But how do I do that? The only settings available in catalyst are either enable AA or set it to "Application managed" setting.


Maniac1000
-Helpful Poster-
Joined: Feb 24, 2007

ally for Taoiseach


Posted: Jan 7, 2012 03:42 PM          Msg. 7 of 38
Mine has always been application controlled.


Flyboy
Joined: Jan 7, 2012


Posted: Jan 7, 2012 03:43 PM          Msg. 8 of 38
Yup. My settings look exactly like that.


Maniac1000
-Helpful Poster-
Joined: Feb 24, 2007

ally for Taoiseach


Posted: Jan 7, 2012 03:49 PM          Msg. 9 of 38
The last post in http://forums.gearboxsoftware.com/showthread.php?t=71334 tells to stop an amd service.
I have no idea if this is a good idea or not.


Flyboy
Joined: Jan 7, 2012


Posted: Jan 7, 2012 03:53 PM          Msg. 10 of 38
I can definitely see why that would work. However I tried it, to no effect.


TauSigmaNova
Joined: Jan 31, 2011

If love is blind, I guess I'll buy myself a cane


Posted: Jan 7, 2012 04:00 PM          Msg. 11 of 38


Flyboy
Joined: Jan 7, 2012


Posted: Jan 7, 2012 04:02 PM          Msg. 12 of 38
That's the same setting as what maniac posted, just in standard view and not advanced view.


TauSigmaNova
Joined: Jan 31, 2011

If love is blind, I guess I'll buy myself a cane


Posted: Jan 7, 2012 04:05 PM          Msg. 13 of 38
You 150 percent sure?

Maybe try running in compatibility, or Windows Basic scheme?


Flyboy
Joined: Jan 7, 2012


Posted: Jan 7, 2012 04:08 PM          Msg. 14 of 38
I am absolutey 343 percent cereal.

I tried running in compatibility, and windows basic scheme doesn't seem to work either.


Maniac1000
-Helpful Poster-
Joined: Feb 24, 2007

ally for Taoiseach


Posted: Jan 7, 2012 04:08 PM          Msg. 15 of 38
Try adding -safemode to the target line of your shortcut to haloce.exe.
so it reads

"C:\Program Files\Microsoft Games\Halo\halo.exe" -safemode
Edited by Maniac1000 on Jan 7, 2012 at 04:10 PM


Flyboy
Joined: Jan 7, 2012


Posted: Jan 7, 2012 04:09 PM          Msg. 16 of 38
Oh dear. Halo CE in safemode? Oh well. If it works, it works. I'll give it a shot.

EDIT: Well now. It works.
Edited by Flyboy on Jan 7, 2012 at 04:11 PM


Maniac1000
-Helpful Poster-
Joined: Feb 24, 2007

ally for Taoiseach


Posted: Jan 7, 2012 04:14 PM          Msg. 17 of 38
try remove the safemode arguement and add umm..the videowith height refresh rate command, or maybe it is a pixel shader command, i would mess with those.

-use11
Forces the game to run as a shader 1.1 card.

-use14
Forces the game to run as a shader 1.4 card.

-use20
Forces the game to run as a shader 2.0 card.

-safemode
Disables as much as possible from the game.

-window
Runs the game in a window.

-width640
Forces the game to run at 640x480.

-vidmode w,h,r
Forces the game to run at width, height, refresh rate.


Flyboy
Joined: Jan 7, 2012


Posted: Jan 7, 2012 04:17 PM          Msg. 18 of 38
Hold up. I just tried running it without safemode or any paramaters...and it works. Hmm.

So to run the game in 16:9 widescreen (preferably 1080p, naturally), I can just set a resolution in the paramaters?


Maniac1000
-Helpful Poster-
Joined: Feb 24, 2007

ally for Taoiseach


Posted: Jan 7, 2012 04:20 PM          Msg. 19 of 38
yup, there are a ton more commands than what i posted too.
Edited by Maniac1000 on Jan 7, 2012 at 04:22 PM


Flyboy
Joined: Jan 7, 2012


Posted: Jan 7, 2012 04:25 PM          Msg. 20 of 38
Alright. Magically, running it in safe mode just once seems to have made it work.

I just want to change the FOV, and I think I'll be set. How do I do that?

Other than that, thanks for the help. :)


Maniac1000
-Helpful Poster-
Joined: Feb 24, 2007

ally for Taoiseach


Posted: Jan 7, 2012 04:28 PM          Msg. 21 of 38
You would need an app for that, i think is the only way.
Open sauce will do it, i think Limited made and app also. There are a few that can do it, i think.
I have never bothered with that though, so somebody else will have to help with that.

Sky's the limit - http://hce.halomaps.org/index.cfm?fid=5267 should work.
You are welcome.
Edited by Maniac1000 on Jan 7, 2012 at 04:31 PM


Jaz
Joined: Mar 21, 2010

[Insert sarcastic comment here]


Posted: Jan 7, 2012 04:31 PM          Msg. 22 of 38
Quote: --- Original message by: Maniac1000
try remove the safemode arguement and add umm..the videowith height refresh rate command, or maybe it is a pixel shader command, i would mess with those.

-use11
Forces the game to run as a shader 1.1 card.

-use14
Forces the game to run as a shader 1.4 card.

-use20
Forces the game to run as a shader 2.0 card.

-safemode
Disables as much as possible from the game.

-window
Runs the game in a window.

-width640
Forces the game to run at 640x480.

-vidmode w,h,r
Forces the game to run at width, height, refresh rate.


Would -use50 do anything btw? I'm planning to get a new PC, and the GPU will have Shader 5.0 support so it'd be pretty awesome updating Halo with support for that.


Derpfish23
Joined: Dec 28, 2011


Posted: Jan 7, 2012 04:42 PM          Msg. 23 of 38
Quote: --- Original message by: Jaz
Would -use50 do anything btw? I'm planning to get a new PC, and the GPU will have Shader 5.0 support so it'd be pretty awesome updating Halo with support for that.



Flyboy
Joined: Jan 7, 2012


Posted: Jan 7, 2012 04:50 PM          Msg. 24 of 38
One more question, if I may?

The multiplayer servers are down - but I heard that they went back up in some way a few years ago. How do I connect to them?


Jaz
Joined: Mar 21, 2010

[Insert sarcastic comment here]


Posted: Jan 7, 2012 04:54 PM          Msg. 25 of 38
Quote: --- Original message by: Derpfish23
Quote: --- Original message by: Jaz
Would -use50 do anything btw? I'm planning to get a new PC, and the GPU will have Shader 5.0 support so it'd be pretty awesome updating Halo with support for that.

http://i.imgur.com/ET30v.jpg


Shader Models are supported by Microsoft. Halo is supported by Microsoft. See the link?


Maniac1000
-Helpful Poster-
Joined: Feb 24, 2007

ally for Taoiseach


Posted: Jan 7, 2012 04:57 PM          Msg. 26 of 38
Quote: --- Original message by: Flyboy
One more question, if I may?

The multiplayer servers are down - but I heard that they went back up in some way a few years ago. How do I connect to them?


I see servers on version 1.09 and 1.00.
are you on one of those versions?

1.08 has 0 servers i think


Derpfish23
Joined: Dec 28, 2011


Posted: Jan 7, 2012 04:57 PM          Msg. 27 of 38
Uh... no. If Microsoft wanted to give Halo CE Shader Models 5.0, they would have to rewrite the entire engine to support it.


Jaz
Joined: Mar 21, 2010

[Insert sarcastic comment here]


Posted: Jan 7, 2012 04:59 PM          Msg. 28 of 38
Quote: --- Original message by: Derpfish23
Uh... no. If Microsoft wanted to give Halo CE Shader Models 5.0, they would have to rewrite the entire engine to support it.


And my lack of knowledge for something to do with a topic entirely out of my area of work is funny?


Derpfish23
Joined: Dec 28, 2011


Posted: Jan 7, 2012 05:02 PM          Msg. 29 of 38
Quote: --- Original message by: Jaz
And my lack of knowledge for something to do with a topic entirely out of my area of work is funny?

Yes.


Maniac1000
-Helpful Poster-
Joined: Feb 24, 2007

ally for Taoiseach


Posted: Jan 7, 2012 05:12 PM          Msg. 30 of 38
Derpfish23, this thread could do without your immature posts.
There was a question asked, so just answer it without trying to make someone else feel bad please.
I am sure Jazz knows things in this world that you do not.

http://hce.halomaps.org/?nid=311
Edited by Maniac1000 on Jan 7, 2012 at 05:19 PM


Dennis

Joined: Jan 27, 2005

We were all young once, but some of us got over it


Posted: Jan 7, 2012 06:54 PM          Msg. 31 of 38
Stay on topic please.


Jaz
Joined: Mar 21, 2010

[Insert sarcastic comment here]


Posted: Jan 7, 2012 07:01 PM          Msg. 32 of 38
Quote: --- Original message by: Dennis
Stay on topic please.


Surely it would make more sense for issues related to this thread and to Windows 7 to be discussed here rather than taking up space in the rest of the forum?


Dennis

Joined: Jan 27, 2005

We were all young once, but some of us got over it


Posted: Jan 7, 2012 07:18 PM          Msg. 33 of 38
Quote: --- Original message by: qwertyuiop15
He was obviously talking to me.
I was talking to anyone not directly answering the original poster's question.

General discussion of any operating system is off topic in this forum. Answering questions or discussion of how to get Halo CE to operate on them is on topic.


dstone2004
Joined: May 25, 2012


Posted: May 25, 2012 09:25 AM          Msg. 34 of 38
Tried everything on this thread but still can't get Hale CE to work.
I get error saying that it can't comnnect to Gamespy network.

Halo PC Multiplayer works but only in a window, fullscreen all I see is a dark purple blank screen.


I have Win 7 Ult. SP1 64bit, and a Nvidia GTX470 video card.


abkarch
Joined: Mar 20, 2010

No items, fox only, final destination


Posted: May 25, 2012 05:20 PM          Msg. 35 of 38
maybe your network isnt working?
Run halo PC as administrator, and add (assuming you are smart enough to do this, as you have something higher end like a 470) an exception for halo CE to your firewall.

 
Page 1 of 2 Go to page: · [1] · 2 · Next

 
Previous Older Thread    Next newer Thread





Time: Fri April 18, 2014 9:48 PM 141 ms.
A Halo Maps Website