A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo Custom Edition (Bungie/Gearbox) »Halo CE General Discussion »Problem with dedicated server...

Author Topic: Problem with dedicated server... (11 messages, Page 1 of 1)
Moderators: Dennis

Chaos_Zero
Joined: May 19, 2010


Posted: Feb 25, 2012 10:20 AM    Msg. 1 of 11       
Hello again. As the title says i am having a problem connecting to a dedicated server for halo CE. This whole setup is a bit out there, so stick with me please...

The server box is very powerful 8 processors and more then enough memory, no problems there. The router/modem box forwards to the server on ports 2302-2303. The server runs ubuntu server 64 bit with a virtualbox windows xp 32 bit home edition installed on it. Halo has been installed on this machine and i set up the init file as described by the guide on this site. The server starts fine.

On another ISP (the server is the only thing on the first connection), i can see my server title but i can not connect. It just says "negotiating connection to server" and drops.

Thanks for reading.


sargejohnson
Joined: Apr 20, 2009

Shall we play a game?


Posted: Feb 25, 2012 10:04 PM    Msg. 2 of 11       
The router may have had its ports forwarded, but does your virtualbox OS, virtualbox and ubuntu server allow your Halo server to accept incoming connections?
You need to ensure that all 3 also allow Halo to accept inbound connections.

Basically, check your firewall exceptions in the virtualbox OS for the Halo dedicated server's .exe. As for virtualbox and ubuntu server, I have no experience with them, so you'd have to figure them out yourself/ wait for someone here with experience to help you.


Chaos_Zero
Joined: May 19, 2010


Posted: Feb 25, 2012 10:26 PM    Msg. 3 of 11       
ok well it is something stupider then usual i suppose, and i have no idea how to solve it.

When i try to join from the lobby it tries to join on the wrong port. For example i set the command line switch and the portforward to port 22962 but when i select to join the game it tries on some other seemingly random port like 22300 (it varies).

If i try to join my game with direct ip from someone elses network it works fine, so i am not sure why the problem is just joining from the list. Any solution to this?


Somone77
Joined: Aug 25, 2007

-Passive Helper- http://somone77.net


Posted: Feb 26, 2012 01:27 AM    Msg. 4 of 11       
You said you were running on Ubuntu server, try shutting down iptables as it could be filtering the ports. If it works after this, you'll want to make an iptables exception, do some googling to find how to do that, but do not leave iptables off.

To test if the ports are open, get nmap and run:
sudo nmap 127.0.0.1/24

and look on the list for the correct port, if it says "filtered" then there is most likely a firewall blocking it.
Edited by Somone77 on Feb 26, 2012 at 01:29 AM


Chaos_Zero
Joined: May 19, 2010


Posted: Feb 26, 2012 02:15 AM    Msg. 5 of 11       
i stopped iptables but it is still using random ports now its on 23040 when i just tried to join.

i do not understand why this is happening...

if you try to join the server its 70.111.202.19:22962

you should be able to join fine, why should joining from the list be any different?
Edited by Chaos_Zero on Feb 26, 2012 at 02:16 AM


Nickster5000
Joined: Dec 11, 2010


Posted: Feb 26, 2012 03:52 AM    Msg. 6 of 11       
Quote: --- Original message by: ODST_Nick
Did you ever get the server to work?

I would recommend you use ports 2300-2340. I just spent 7 hours setting up servers today (H2SHC/RZS servers, GO PLAY THEM!)

My friend, the owner of the server hosting company I am an admin for, told me that the even number ports (2300,2302,2304, etc.) are the server ports, and the odd numbers (2301,2303,2305,etc.) are the client ports. He also said the ports correspond to next to each other (ex, 2300 is the server, and 2301 is the client port. 2302 is the server, 2303 is the client, etc.) So I have 6 servers I am working on, 2300,2302,2304,2306,2308,2310

There's your server setup right there.


Hope this helps.

E: How to make the server run on a certian port: Make a shortcut of the haloceded.exe, right click, properties, at the target directory, type -port #

Ex: -port 2300


Edited by ODST_Nick on Feb 26, 2012 at 03:54 AM
Edited by ODST_Nick on Feb 26, 2012 at 03:55 AM


Chaos_Zero
Joined: May 19, 2010


Posted: Feb 26, 2012 09:19 AM    Msg. 7 of 11       
Quote: --- Original message by: Chaos_Zero
When i try to join from the lobby it tries to join on the wrong port. For example i set the command line switch and the portforward to port 22962 but when i select to join the game it tries on some other seemingly random port like 22300 (it varies).


sorry if i was not clear but i have tried this.


Nickster5000
Joined: Dec 11, 2010


Posted: Feb 26, 2012 01:07 PM    Msg. 8 of 11       
foward the ports I suggested above & try what I said.


Chaos_Zero
Joined: May 19, 2010


Posted: Feb 26, 2012 01:57 PM    Msg. 9 of 11       
ok, i forwarded 2308-2309 udp and tcp. as well as port 80 for the heck of it.

I changed these settings in virtualbox and the modem. I set the shortcut to "-port 2308" and ran.
same thing, it goes to connecting and now tries on port 23101. I have not set this port anywhere.
Edited by Chaos_Zero on Feb 26, 2012 at 02:02 PM


Mator
Joined: Aug 17, 2009

Froom-Invent0r


Posted: Aug 13, 2012 04:26 AM    Msg. 10 of 11       
I know this is about 6 months late, but I've seen this problem before. There's no way to get around it that I know of asides from getting a new router. Essentially, something poopy goes down between your computer and the gamespy master server list and the port to connect to gets all flippeded up. No idea how to fix it.


Dennis

Joined: Jan 27, 2005

"We are made of starstuff. ― Carl Sagan


Posted: Aug 13, 2012 11:26 PM    Msg. 11 of 11       
Quote: --- Original message by: Chaos_Zero
I set the shortcut to "-port 2308" and ran.
same thing, it goes to connecting and now tries on port 23101. I have not set this port anywhere.
This is normal. The initial port (2308 in this case) is used to make the connection and then the accepting program (Halo server) tells the client that the connection will continue on an alternate port so other connections to the server can be made. You can only make one sustained connection on a single port in any TCP or UDP based program.

 

 
Previous Older Thread    Next newer Thread







Time: Sun January 19, 2020 8:57 AM 391 ms.
A Halo Maps Website