A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo Custom Edition (Bungie/Gearbox) »Halo CE General Discussion »Help with sound importing into tool.

Author Topic: Help with sound importing into tool. (3 messages, Page 1 of 1)
Moderators: Dennis

Nickster5000
Joined: Dec 11, 2010


Posted: Jun 23, 2012 03:47 AM    Msg. 1 of 3       
Hello guys.

I am having a little problem.

Whenever I import sounds into tool, it says "importing sound.... lalala" and never says done. When I open it in guerilla, under the "permutations" section, nothing is there.

I've had this issue on my last PC, and idk if I am doing something wrong, or what.

I refered to both e3po's and kirby's sound tutorial, and they said to render it into 2 different formats. I did both, both did the same thing.

Any help will be appreciated, and thanks in advance.


Higuy
Joined: Mar 6, 2007

@lucasgovatos


Posted: Jun 23, 2012 12:48 PM    Msg. 2 of 3       
Watch my tutorial instead:

http://vimeo.com/18808279

covers every aspect you should know.

The problem your most likely having anyway is that your not typing the directory correctly. You need to end the link with the folders name that has another folder in it which has the sound. Its either that or the file is a correct format/too large.


Nickster5000
Joined: Dec 11, 2010


Posted: Jun 23, 2012 03:07 PM    Msg. 3 of 3       
Quote: --- Original message by: Private Caboose

It means it either doesn't exist, or it is too big. Remember, don't name the sound. The .wav file should be at 22050hz 16 bit mono. No stereo.
Then type this in
"tool sounds "sound\music\custom song" ogg 1"

I put quotation marks so I can have spaces in my work, and not underscores. Anyway, that should help.
Edited by Private Caboose on Jun 23, 2012 at 10:53 AM


Did that, didnt work.
I think I said in my OP I did everything correctly. I am going to try that quality however.

And i'm going to refer to your tutorial next higuy.

I'll give you both feedback via xfire.


Now, when I compiled it the first time, it said it imported. When I re-compiled it, it said it was corrupted:

C:\Program Files (x86)\Microsoft Games\Halo Custom Edition>tool sounds rzs_halo\
sounds\dialouge\search_squad ogg 128000
Failed to load/create D3D
Couldn't read map file './toolbeta.map'
Importing rzs_halo\sounds\dialouge\search_squad

C:\Program Files (x86)\Microsoft Games\Halo Custom Edition>tool sounds rzs_halo\
sounds\dialouge\search_squad ogg 128000
Couldn't read map file './toolbeta.map'
Importing rzs_halo\sounds\dialouge\search_squad
fixed corrupt tag enum field (sample rate*).
the sound tag 'rzs_halo\sounds\dialouge\search_squad' may be corrupt.

C:\Program Files (x86)\Microsoft Games\Halo Custom Edition>

This sound is a piece of dialouge that is 368 kb's big, and I rendered it with higuy's settings in his tutorial.

I deleted the .sound file I just made with higuy's settings, and replaced it using Hiralis's settings. It imported.


C:\Program Files (x86)\Microsoft Games\Halo Custom Edition>tool sounds rzs_halo\
sounds\dialouge\search_squad ogg 1
Couldn't read map file './toolbeta.map'
Importing rzs_halo\sounds\dialouge\search_squad

C:\Program Files (x86)\Microsoft Games\Halo Custom Edition>

But when I open it in guerilla...



The same thing happened with higuy's settings. Let's recompile Hiralis's settings in tool again....

C:\Program Files (x86)\Microsoft Games\Halo Custom Edition>tool sounds rzs_halo\
sounds\dialouge\search_squad ogg 1
Couldn't read map file './toolbeta.map'
Importing rzs_halo\sounds\dialouge\search_squad
fixed corrupt tag enum field (sample rate*).
the sound tag 'rzs_halo\sounds\dialouge\search_squad' may be corrupt.

I have no idea how to fix this, but I have an idea it has something to do with "fixed corrupt tag enum field (sample rate*).", but since I am not the best with audio terms, I dont know what this error means.

Again, any help will be appreciated, and thanks in advance.


Edited by ODST_Nick on Jun 23, 2012 at 04:01 PM

IF ANYONE EVER CHECKS THIS.... Well, don't have guerilla open when you compile sounds. That was my problem ALL ALONG. WOW. I fail xD
Edited by Nickster5000 on Jul 30, 2013 at 10:25 PM

 

 
Previous Older Thread    Next newer Thread







Time: Tue May 26, 2020 1:34 PM 313 ms.
A Halo Maps Website