A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo Custom Edition (Bungie/Gearbox) »Halo CE Technical / Map Design »Need help adding the Wasp to a scenario

Author Topic: Need help adding the Wasp to a scenario (6 messages, Page 1 of 1)
Moderators: Dennis

Kills_Alone
Joined: Jun 17, 2009

I ain't got no candy for you, NO CANDY


Posted: Jun 19, 2013 03:01 AM    Msg. 1 of 6       
Hey people.

This is probably gonna sound like a noob question but I haven't done that much work with Halo Custom Edition, more with Halo 2 Vista.


So I wanna add this Wasp to a scenario, which I have done with Guerilla, but when I go to load the scenario in Sapien it crashes. Remove the vehicle and it loads fine. Even adding the vehicle to the scenario's vehicle palette causes the crash. I tried adding it to the tutorial scenario as well just to make sure.

There where also updated cyborg.model_animations included, so I backed up my original and added them to the \characters\cyborg directory.

So is there a known issue with this vehicle or is there something else I need to do to properly add a vehicle?


EDIT: Found the problem immediately after I post, always like that.

I am missing this tag: sound\sfx\vehicles\pelican_engine

I think its a .sound_looping or just a .sound tag, does anyone have this file? I am temporarily using the ghost's .sound_looping tag.


------


Another problem, when I add the vehicle to the scenario it is not appearing in-game in Slayer even though that box is checked. Does it need to be added to globals.globals or somewhere else?



Thankx for any help,

K_A


Edited by Kills_Alone on Jun 19, 2013 at 03:37 AM


Kills_Alone
Joined: Jun 17, 2009

I ain't got no candy for you, NO CANDY


Posted: Jun 19, 2013 05:11 AM    Msg. 2 of 6       
Okay, I found the two Pelican sound files I needed inside of Immure.

So is there any reason a vehicle will not appear in the compiled map? I opened my map with Halo Editing Kit Plus and the Wasp tags are there but in-game its just not there.


altis94
Joined: Oct 5, 2012

Join my Discord https://discord.gg/GDVEaRD


Posted: Jun 19, 2013 06:24 AM    Msg. 3 of 6       
Make sure that vehicle is in globals and you have all gametypes checked for it in sapien.


Kills_Alone
Joined: Jun 17, 2009

I ain't got no candy for you, NO CANDY


Posted: Jun 19, 2013 07:26 PM    Msg. 4 of 6       
Okay I fixed my globals.globals and I removed excess vehicles.

The Wasp is in-game and the map is not exceptioning. I set the cyborg biped to use the modified model_animations again, but the Wasp is not board-able even though it should be. If I replace it with a Reach Warthog I have then that works fine; I can drive it around no problem.

So any idea why the Wasp will not allow me to get on it or in the passenger seat? There is no dialogue to sit on it, if I nade flip it then I get the dialog to flip it back over but thats it.


ally
Joined: Jun 23, 2010

Aye Ready


Posted: Jun 20, 2013 08:22 AM    Msg. 5 of 6       
can't quite remember to be honest, but i think you have to set the seat as w-driver
in the cyborg.model_animations tag, you will see the drop down box at the top (units).


Kills_Alone
Joined: Jun 17, 2009

I ain't got no candy for you, NO CANDY


Posted: Jun 20, 2013 08:14 PM    Msg. 6 of 6       
I got it, I had to extract the vehicle's tags from the map Immure as something was wrong with the Halomap's version. :)

 

 
Previous Older Thread    Next newer Thread







Time: Sun December 15, 2019 8:59 AM 218 ms.
A Halo Maps Website