A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo Custom Edition (Bungie/Gearbox) »Halo CE Technical / Map Design »A30 Campaign Scripts Problems (and a few more)

Author Topic: A30 Campaign Scripts Problems (and a few more) (5 messages, Page 1 of 1)
Moderators: Dennis

lilpod13
Joined: Oct 5, 2013


Posted: Mar 16, 2014 09:37 PM    Msg. 1 of 5       
I was trying to edit A30 using HEK+ and the original scenario tag works fine, I open it up in guerilla and it says the scripts are there, nothing out of the ordinary. After I recompiled the map, I play the map and no scripts are running. I check the NEW scenario tag with guerilla and it now says globals, scripts, references, and source files are now gone(just a blank space). However, when I make a new scenario with A10 the scripts are still there and are all working fine. Any suggestions on how to fix this? (I already tried recompiling the scripts with Zteam's scripts but that didn't work)

Also, the muzzle flash for the assault rifle and pistol are not showing when firing (fps and on other marines/crewman) AND blood decals aren't showing (pre-placed and ones that should be placed when a unit is hit). Help please?

This is the debug text when OPENING the new scenario in Sapien for the first time

03.16.14 21:38:53 sapien pc 01.00.00.0609 ----------------------------------------------
03.16.14 21:38:53 reference function: _write_to_error_file
03.16.14 21:38:53 reference address: 401b13
03.16.14 21:38:53 Couldn't read map file './sapienbeta.map'
03.16.14 21:38:53 CreateDevice succeeded with refresh rate = 0
03.16.14 21:38:54 Sound card doesn't meet minimum hardware requirements. Disabling hardware option.
03.16.14 21:38:54 Increasing sound decompression buffer size to 1048576 bytes
03.16.14 21:38:55 WARNING: cannot create mounted weapons for c_dropship, exceeded MAXIMUM_NUMBER_OF_MOUNTED_WEAPON_UNITS
03.16.14 21:38:55 WARNING: cannot create mounted weapons for c_dropship, exceeded MAXIMUM_NUMBER_OF_MOUNTED_WEAPON_UNITS
03.16.14 21:38:55 WARNING: cannot create mounted weapons for c_dropship, exceeded MAXIMUM_NUMBER_OF_MOUNTED_WEAPON_UNITS
03.16.14 21:38:55 WARNING: cannot create mounted weapons for c_dropship, exceeded MAXIMUM_NUMBER_OF_MOUNTED_WEAPON_UNITS
03.16.14 21:38:55 WARNING: cannot create mounted weapons for c_dropship, exceeded MAXIMUM_NUMBER_OF_MOUNTED_WEAPON_UNITS
03.16.14 21:38:55 WARNING: cannot create mounted weapons for c_dropship, exceeded MAXIMUM_NUMBER_OF_MOUNTED_WEAPON_UNITS
03.16.14 21:38:56 local player 0, weapon (0x0), deleted unexpectedly
03.16.14 21:39:00 WARNING: biped pilot (pilot (pilot_intro)) fell outside world and was erased
(This "fixed corrupt tag flags field" goes on for about 150+ lines above this)
03.16.14 21:39:07 fixed corrupt tag flags field (defending).
03.16.14 21:39:07 fixed corrupt tag flags field (defending search).
03.16.14 21:39:07 fixed corrupt tag flags field (defending guard).
03.16.14 21:39:07 fixed corrupt tag flags field (pursuing).
03.16.14 21:39:07 fixed corrupt tag flags field (attacking).
03.16.14 21:39:07 fixed corrupt tag flags field (attacking search).
03.16.14 21:39:07 fixed corrupt tag flags field (attacking guard).
03.16.14 21:39:07 fixed corrupt tag flags field (defending).
03.16.14 21:39:07 fixed corrupt tag flags field (defending search).
03.16.14 21:39:07 fixed corrupt tag flags field (defending guard).
03.16.14 21:39:07 fixed corrupt tag flags field (pursuing).
03.16.14 21:39:07 the scenario tag 'levels\a30\a3012' may be corrupt.
Edited by lilpod13 on Mar 16, 2014 at 09:42 PM


Masters1337
Joined: Mar 5, 2006

halonaminator's unfortunate idol


Posted: Mar 20, 2014 02:47 PM    Msg. 2 of 5       
It would seem that your scenario is indeed corrupted when it was extracted, it doesn't appear to be a script related error. It could be the scripts are calling something that is then loaded into the scenario which results in something being loaded... but given your error that doesnt seem to make much sense either.

As far as your other errors, it seems like the effect tags were corrupted when using HEK+, perhaps you are using an older version? The decals I have no clue about.


lilpod13
Joined: Oct 5, 2013


Posted: Mar 20, 2014 04:55 PM    Msg. 3 of 5       
Found out about the muzzle flash and decals, turns out that for some reason when I reinstalled halo CE it set all the graphics to minimum, that's why I wasn't seeing them.

As for the a30 problem, I found there was some sort of problem with the .map file and it wasn't extracting the scripts correctly. :/

But now I have a new problem: The level was loading fine before, but now I get this error in my debug text file when opening sapien:

03.20.14 16:48:29 file_read('tags\scenery\waterfalls\spray_emitter_medium\bitmaps\waterfall_mist.bitmap') error 0x00000026 'Reached the end of the file. '
03.20.14 16:48:29 couldn't read #5376 bytes from offset #172 in local tag 'tags\scenery\waterfalls\spray_emitter_medium\bitmaps\waterfall_mist.bitmap'
03.20.14 16:48:29 file_read('tags\scenery\waterfalls\spray_emitter_medium\bitmaps\waterfall_mist.bitmap') error 0x00000026 'Reached the end of the file. '
03.20.14 16:48:29 couldn't read #64 bytes from offset #5548 in local tag 'tags\scenery\waterfalls\spray_emitter_medium\bitmaps\waterfall_mist.bitmap'
03.20.14 16:48:29 couldn't read elements for bitmap_group_sequence_block block
03.20.14 16:48:29 file_read('tags\scenery\waterfalls\spray_emitter_medium\bitmaps\waterfall_mist.bitmap') error 0x00000026 'Reached the end of the file. '
03.20.14 16:48:29 couldn't read #48 bytes from offset #5548 in local tag 'tags\scenery\waterfalls\spray_emitter_medium\bitmaps\waterfall_mist.bitmap'
03.20.14 16:48:29 couldn't read elements for bitmap_data_block block
03.20.14 16:48:29 failed to load bitmap tag 'scenery\waterfalls\spray_emitter_medium\bitmaps\waterfall_mist'
03.20.14 16:48:29 failed to load particle tag 'scenery\waterfalls\spray_emitter_medium\waterspray'
03.20.14 16:48:29 failed to load effect tag 'scenery\waterfalls\spray_emitter_medium\jetspray_medium'
03.20.14 16:48:29 failed to load scenery tag 'scenery\waterfalls\spray_emitter_medium\spray_emitter_medium'
03.20.14 16:48:30 EAX: 0x00000000
03.20.14 16:48:30 EBX: 0x0F0DDE01
03.20.14 16:48:30 ECX: 0x00000000
03.20.14 16:48:30 EDX: 0x00000000
03.20.14 16:48:30 EDI: 0x0018EDC8
03.20.14 16:48:30 ESI: 0x00000000
03.20.14 16:48:30 EBP: 0x0018ECA0
03.20.14 16:48:30 ESP: 0x0018EC90
03.20.14 16:48:30 EIP: 0x77DE0C42, 83 C4 04 C2 ?????
03.20.14 16:48:30 EXCEPTION halt in \halopc\haloce\source\tag_files\tag_groups.c,#3142: offset>=0 && offset+size<=data->size

Already tried overwriting the waterfall scenery three times and reinstalling HEK+ once.

I'm thinking about reinstalling Halo CE and HEK and just resetting all my tags and hope my a30 map won't be corrupted and the scenario will open after extracting normal tags and inserting scorpion+cinematic tags.


Masters1337
Joined: Mar 5, 2006

halonaminator's unfortunate idol


Posted: Mar 21, 2014 12:36 AM    Msg. 4 of 5       
couldn't read elements and bytes errors are definitely from corrupted tags.

If you are ripping from SP, make sure you only do it from PC maps, not CE.

Reinstalling and re ripping is probably the best route to go.


lilpod13
Joined: Oct 5, 2013


Posted: Mar 21, 2014 04:14 PM    Msg. 5 of 5       
Yeah I did rip the first one from SP, but the second error came from when I ripped a new copy of the scenario. Looks like I might have to reinstall halo combat evolved to get a new map file, or maybe delete the map file and repair.

Edit: Okay, I've figured it out that it is happening after I open it with sapien, because the original a30 scenario tag has scripts and the like but after I save it there are no scripts. I honestly have no clue on how to fix this now, since it only happens on a30 and it happens to no other map I have edited. Also guerilla is now getting an error text when I open it, saying that it fixed the corrupted flag fields and that the scenario tag may be corrupted.

Looks like I won't be editing a30 anytime soon
Edited by lilpod13 on Mar 21, 2014 at 05:09 PM

 

 
Previous Older Thread    Next newer Thread







Time: Wed October 23, 2019 1:07 PM 375 ms.
A Halo Maps Website