A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo Custom Edition (Bungie/Gearbox) »Halo CE General Discussion »Tool Error

Author Topic: Tool Error (9 messages, Page 1 of 1)
Moderators: Dennis

Nickster5000
Joined: Dec 11, 2010


Posted: Jul 1, 2014 02:24 AM    Msg. 1 of 9       
Hey Everyone,

I was wondering what this error means:

EXCEPTION halt in \halopc\haloce\source\memory\array.c,#130: index>=0 && index<a
rray->count

I googled it, and all the hits I got had no solutions.

Thank you so much!


Super Flanker
Joined: Oct 5, 2012

The length of your life depends on my aim.


Posted: Jul 1, 2014 03:15 AM    Msg. 2 of 9       
Quote: --- Original message by: Nickster5000
Hey Everyone,

I was wondering what this error means:

EXCEPTION halt in \halopc\haloce\source\memory\array.c,#130: index>=0 && index<a
rray->count

I googled it, and all the hits I got had no solutions.

Thank you so much!


I would advise before you make any "major" changes, to any tag, bsp, model, shader whatever you make a short change log.

It's up to you what you write, in it. But general notes about any changes e.t.c are good. This helps you easily track down the causes of these kind of errors.

Can you remember any changes you made between the time the map was working and before it stopped working?


Nickster5000
Joined: Dec 11, 2010


Posted: Jul 1, 2014 03:39 AM    Msg. 3 of 9       
I was trying to use the "model" command importing a custom reach frigate that I modeled. I got all of my other three custom ships that I modeled but the frigate.


Super Flanker
Joined: Oct 5, 2012

The length of your life depends on my aim.


Posted: Jul 1, 2014 05:00 AM    Msg. 4 of 9       
Quote: --- Original message by: Nickster5000
I was trying to use the "model" command importing a custom reach frigate that I modeled. I got all of my other three custom ships that I modeled but the frigate.


Array count may point to the geometry.

Is the frigate which is giving you problems, vastly different to the ones which have compiled?

is the poly count higher, are there any markers or nodes which shouldn't be there?


altis94
Joined: Oct 5, 2012

Join my Discord https://discord.gg/GDVEaRD


Posted: Jul 1, 2014 07:36 AM    Msg. 5 of 9       
[08:42] Nickster5000: all of the mat id's are set correctly.


Nickster5000
Joined: Dec 11, 2010


Posted: Jul 1, 2014 07:26 PM    Msg. 6 of 9       
C:\Program Files (x86)\Microsoft Games\Compile Folder>tool model RZS_Halo\scener
y\frigate
Couldn't read map file './toolbeta.map'
### frigate.JMS
### WARNING found #130 degenerate triangles.

detail worst-case worst-case
level vertices triangles
--------- ---------- ----------
superlow 29291 20098
low 29291 20098
medium 29291 20098
high 29291 20098
superhigh 29291 20098

C:\Program Files (x86)\Microsoft Games\Compile Folder>


It was too high poly. I realized the turrets I had on it were cylindrical with 18 sides which was the cause. I fixed them and now it compiled :D Thank you for those who helped.



Darkzealotx
Joined: Jun 15, 2014


Posted: Jul 1, 2014 07:28 PM    Msg. 7 of 9       
That looks horrible.


Super Flanker
Joined: Oct 5, 2012

The length of your life depends on my aim.


Posted: Jul 1, 2014 08:43 PM    Msg. 8 of 9       
Quote: --- Original message by: Darkzealotx
That looks horrible.


That is no way to talk about your genitals.

I was right nickster? xD


Darkzealotx
Joined: Jun 15, 2014


Posted: Jul 1, 2014 09:09 PM    Msg. 9 of 9       
You know it.

 

 
Previous Older Thread    Next newer Thread







Time: Wed November 20, 2019 4:18 PM 171 ms.
A Halo Maps Website