A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo Custom Edition (Bungie/Gearbox) »Halo CE Technical / Map Design »Tool lightmaps error

Author Topic: Tool lightmaps error (4 messages, Page 1 of 1)
Moderators: Dennis

muffinman496
Joined: Jan 11, 2011

Who wants a muffin


Posted: Aug 2, 2014 11:51 PM    Msg. 1 of 4       
I have been making maps for a while now but i recently ran into a new problem.

C:\Program Files (x86)\Microsoft Games\Halo Custom Edition>tool lightmaps levels
\test\u\u u 0 0.9
Couldn't read map file './toolbeta.map'
i'm going to render debug lightmaps for u of levels\test\u\u, and i'll stop when
red+blue+green = 0.900000.
Hit control-c now if this isn't right.
WARNING: 1 clusters in structure_bsp levels\test\u\u have no background sound or
sound environment.
start levels\test\u\u
radiosity error: degenerate triangle [or triangle with bad uvs] (see blue in err
or geometry)
failed levels\test\u\u
done


I have already imported the .wrl file to try to see where the bad uvs are but, there is no blue highlighting any degenerate triangles in the .wrl file anywhere.


Jesse
Joined: Jan 18, 2009

Discord: Holy Crust#4500


Posted: Aug 3, 2014 02:27 AM    Msg. 2 of 4       
Make sure you import the debug.wrl, not the one of your BSP name.

Also as a tip, I've noticed that the major errors tend to be either the first or last VIFS objects.


Super Flanker
Joined: Oct 5, 2012

The length of your life depends on my aim.


Posted: Aug 3, 2014 10:09 AM    Msg. 3 of 4       
Quote: --- Original message by: muffinman496
I have been making maps for a while now but i recently ran into a new problem.

C:\Program Files (x86)\Microsoft Games\Halo Custom Edition>tool lightmaps levels
\test\u\u u 0 0.9
Couldn't read map file './toolbeta.map'
i'm going to render debug lightmaps for u of levels\test\u\u, and i'll stop when
red+blue+green = 0.900000.
Hit control-c now if this isn't right.
WARNING: 1 clusters in structure_bsp levels\test\u\u have no background sound or
sound environment.
start levels\test\u\u
radiosity error: degenerate triangle [or triangle with bad uvs] (see blue in err
or geometry)
failed levels\test\u\u
done


I have already imported the .wrl file to try to see where the bad uvs are but, there is no blue highlighting any degenerate triangles in the .wrl file anywhere.


Xfire: ssflanker303

Send me your max file, I'll show you how to fix it.


muffinman496
Joined: Jan 11, 2011

Who wants a muffin


Posted: Aug 3, 2014 11:34 PM    Msg. 4 of 4       
@Jesee thanks man that did it! I just got back into map making after a long break and forgot about the 'debug.wrl'

 

 
Previous Older Thread    Next newer Thread







Time: Mon June 17, 2019 7:49 PM 172 ms.
A Halo Maps Website