A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo Custom Edition (Bungie/Gearbox) »Halo CE General Discussion »Recorded_animation script error

Author Topic: Recorded_animation script error (7 messages, Page 1 of 1)
Moderators: Dennis

SOI_7
Joined: Mar 23, 2012

Tatsumaki best waifu


Posted: Feb 13, 2015 06:11 PM    Msg. 1 of 7       
I have tried to compile some scripts for a10, editing the original campaign scripts that zteam released on the forum. When I try to compile them in Sapien, though, it says a bunch of errors like "recorded_animation x and recorded animation y have the same name". In the script, though, there are no recorded_animation references.
Did someone find this error before, and solved it?


MatthewDratt
Joined: Sep 11, 2010

Newly redesigned MattDratt.com


Posted: Feb 13, 2015 06:19 PM    Msg. 2 of 7       
its probably not a script error

look under recorded animations and see if two of them have the same name


SOI_7
Joined: Mar 23, 2012

Tatsumaki best waifu


Posted: Feb 14, 2015 06:30 AM    Msg. 3 of 7       
I checked, at least each recorded animation has a duplicate with the same name. The point is, since none of them are referenced in the script, I don't know which one should I rename/delete without causing troubles


the concerned thros
Joined: Nov 20, 2017


Posted: Sep 7, 2018 10:41 AM    Msg. 4 of 7       
Quote: --- Original message by: SOI_7
I checked, at least each recorded animation has a duplicate with the same name. The point is, since none of them are referenced in the script, I don't know which one should I rename/delete without causing troubles

How did you fix this I am screwing with a10 right now and I can't do shiz


SOI_7
Joined: Mar 23, 2012

Tatsumaki best waifu


Posted: Sep 7, 2018 02:42 PM    Msg. 5 of 7       
Quote: --- Original message by: the concerned thros
Quote: --- Original message by: SOI_7
I checked, at least each recorded animation has a duplicate with the same name. The point is, since none of them are referenced in the script, I don't know which one should I rename/delete without causing troubles

How did you fix this I am screwing with a10 right now and I can't do shiz



I ended up deleting the duplicates. It gave me no errors, apart a slightly different angle in few cutscenes, but nothing really tragic


MosesofEgypt
Joined: Apr 3, 2013


Posted: Sep 8, 2018 03:53 AM    Msg. 6 of 7       
Refinery gives you the option to rename all duplicates when extracting scenarios. It's in the settings. I made that option specifically to allow recompiling scripts.


the concerned thros
Joined: Nov 20, 2017


Posted: Sep 8, 2018 04:59 AM    Msg. 7 of 7       
Quote: --- Original message by: SOI_7
Quote: --- Original message by: the concerned thros
Quote: --- Original message by: SOI_7
I checked, at least each recorded animation has a duplicate with the same name. The point is, since none of them are referenced in the script, I don't know which one should I rename/delete without causing troubles

How did you fix this I am screwing with a10 right now and I can't do shiz



I ended up deleting the duplicates. It gave me no errors, apart a slightly different angle in few cutscenes, but nothing really tragic

Would you mind to send me your working scenario?
Quote: --- Original message by: MosesofEgypt
Refinery gives you the option to rename all duplicates when extracting scenarios. It's in the settings. I made that option specifically to allow recompiling scripts.

I have problem with refinery not extracting all the tags even tho there aren't any tags to overwrite and the admin thing even tho I already run the admin version of it and disabled UAC and I'm using Windows 10, it still gives me this admin error thing that I can't extract the other tags.

 

 
Previous Older Thread    Next newer Thread







Time: Sun October 21, 2018 3:54 PM 203 ms.
A Halo Maps Website