A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo Custom Edition (Bungie/Gearbox) »Halo CE General Discussion »HAC2 + OS compat fix

Page 1 of 3 Go to page: · [1] · 2 · 3 · Next
Author Topic: HAC2 + OS compat fix (98 messages, Page 1 of 3)
Moderators: Dennis

Btcc22
Joined: Dec 17, 2012


Posted: Mar 3, 2015 07:34 PM    Msg. 1 of 98       
Consider this is quick test version - I'd release it under through normal mechanism but for reasons relating to the broken blog site, I can't until I get that mess fixed.

If you'd like to try it out, just copy this file into your main CE folder. Note that this will disable auto-updating. If everything's fine, I'll release it and update this thread.
Edited by Btcc22 on Mar 3, 2015 at 07:36 PM


Xx1Talon1xX
Joined: Feb 2, 2015

Mexicans, Mexicans Everywhere!


Posted: Mar 3, 2015 07:39 PM    Msg. 2 of 98       
:D

I kinda had it working, now I getting crashing to desktop when ever it tries to load...
Edited by Xx1Talon1xX on Mar 3, 2015 at 07:55 PM


TailsTheGamer
Joined: Mar 7, 2013

Meow


Posted: Mar 3, 2015 08:11 PM    Msg. 3 of 98       
Thanks man! Had to use hac_widescreen 0 to fix the squashed HUD :P
Edited by TailsTheGamer on Mar 4, 2015 at 02:45 AM


Danger_zone_98
Joined: Nov 26, 2012


Posted: Mar 3, 2015 08:11 PM    Msg. 4 of 98       
Get this several times




And then this



MatthewDratt
Joined: Sep 11, 2010

CE3 - Takedown - HaloCE3.com


Posted: Mar 3, 2015 08:18 PM    Msg. 5 of 98       
Also getting unable to load 998


Xx1Talon1xX
Joined: Feb 2, 2015

Mexicans, Mexicans Everywhere!


Posted: Mar 3, 2015 08:19 PM    Msg. 6 of 98       
Quote: --- Original message by: Danger_zone_98
Get this several times

http://i.imgur.com/rj8Jmc4.png


And then this

http://i.imgur.com/BI1mBzO.png


Ya, if I have the loader still in Controls it crashes like this. But if I take it out it works, but I can't use custom text and other features.....


Btcc22
Joined: Dec 17, 2012


Posted: Mar 3, 2015 08:21 PM    Msg. 7 of 98       
I'll take a look into the reported issues.


bourrin33
Joined: Oct 19, 2009

HEK not installed tho


Posted: Mar 3, 2015 08:27 PM    Msg. 8 of 98       
I have no compatility problem as open sauce won't install back after being uninstalled. Long live HAC.


stunt_man
Joined: Sep 22, 2009

GMYF - Now hosting proper MLG gametypes!


Posted: Mar 3, 2015 08:31 PM    Msg. 9 of 98       
Quote: --- Original message by: Zetren
http://screenshot.xfire.com/s/130303691-4.jpg


Nice map
Edited by stunt_man on Mar 3, 2015 at 08:32 PM


bourrin33
Joined: Oct 19, 2009

HEK not installed tho


Posted: Mar 3, 2015 08:35 PM    Msg. 10 of 98       
@zee train just play maps where this widget doesn't appear. Eg bigass


Btcc22
Joined: Dec 17, 2012


Posted: Mar 3, 2015 09:26 PM    Msg. 11 of 98       
I've made a few changes and uploaded a new version. The HUD scaling issue should be fixed* and those still having problems getting the game to load should have more luck. If it still doesn't load, please make sure you've actually put hac.dll in your root CE directory and not elsewhere.

*OS and HAC handle HUD scaling differently (but to pretty much the same effect) except for the game type icons and background, which are handled in the same fashion as there's only one way to fix those and it's pretty hacky. It's tricky enough to make sure those are always scaled and positioned properly without having to account for the possibility of another program making changes to them behind your back, so to speak.

Quote: --- Original message by: Zetren
Hmm. I have the same loader.dll (same as before the new OS) in my controls with this new hac.dll in my Halo CE root. Everything is good except for the aforementioned bug and two things being mapped to F7


If you hit F7 to exit OpenSauce's menu rather than escape, SJ will be disabled. It's not great but it's not exactly a game-breaker. For now, OpenSauce is in a much better position to provide an option to remap the key than HAC.
Edited by Btcc22 on Mar 3, 2015 at 09:31 PM


Xx1Talon1xX
Joined: Feb 2, 2015

Mexicans, Mexicans Everywhere!


Posted: Mar 3, 2015 09:45 PM    Msg. 12 of 98       
I'm not sure whats wrong, when I have the loader in Controls and hac.dll in the main directory and then try running the game I get to see halo splash screen and then it crashes to blackness with a white box and then I get a message of, Halo has crashed......

Im not sure if its you or me, but If I remove the loader, the game will play and I see more servers but no other hac stuff works


Btcc22
Joined: Dec 17, 2012


Posted: Mar 3, 2015 10:22 PM    Msg. 13 of 98       
That's strange. Don't suppose you could post the error log if OpenSauce/HAC/Halo has made one? If not, the details from the crash box would be useful.


MatthewDratt
Joined: Sep 11, 2010

CE3 - Takedown - HaloCE3.com


Posted: Mar 3, 2015 10:40 PM    Msg. 14 of 98       
hac.dll is placed in Microsoft Games/Halo Custom Edition/hac.dll

and you keep loader in Halo Custom Edition/controls/loader.dll

yeah still getting the 998 error


TailsTheGamer
Joined: Mar 7, 2013

Meow


Posted: Mar 3, 2015 11:09 PM    Msg. 15 of 98       
Quote: --- Original message by: Zetren
Quote: --- Original message by: TailsTheGamer
Thanks man! Had to use hud_widescreen 0 to fix the squashed HUD :P


Does yours appear like this? Notice an element of the HUD displayed incorrectly at Top-middle.

http://screenshot.xfire.com/s/130303691-4.jpg


Yes, I have this too.


Edited by TailsTheGamer on Mar 3, 2015 at 11:22 PM


Btcc22
Joined: Dec 17, 2012


Posted: Mar 4, 2015 12:02 AM    Msg. 16 of 98       
Tails, that should be fixed if you redownload from the first post. Make sure you only have one widescreen fix enabled before entering a game.

Matt: That's strange. I'll have to set a W8.1 VM up and take a closer look.
Edited by Btcc22 on Mar 4, 2015 at 12:09 AM


The_Purrminator
Joined: May 30, 2014

(SBB) Michelle


Posted: Mar 4, 2015 12:22 AM    Msg. 17 of 98       
Quote: --- Original message by: TailsTheGamer
http://i38.servimg.com/u/f38/17/78/77/04/2015-026.jpg
Edited by TailsTheGamer on Mar 3, 2015 at 11:22 PM


For this simple reason I disabled os hudscaling and use hac hudscaling.


Caesar
Joined: Jul 1, 2013


Posted: Mar 4, 2015 02:26 AM    Msg. 18 of 98       
Just disable FOV because OS allow us to do that.
Edited by Caesar on Mar 4, 2015 at 02:27 AM


TailsTheGamer
Joined: Mar 7, 2013

Meow


Posted: Mar 4, 2015 02:52 AM    Msg. 19 of 98       
Quote: --- Original message by: Btcc22

Tails, that should be fixed if you redownload from the first post. Make sure you only have one widescreen fix enabled before entering a game.


I have redownloaded both and the issue still persists.

I'm not sure if I quite follow, hac_widescreen 0 is not disabling it?

I will use HAC2's hud scaling for now.

Opening and then closing the OS menu temporarily fixes it.
Edited by TailsTheGamer on Mar 4, 2015 at 02:54 AM
Edited by TailsTheGamer on Mar 4, 2015 at 02:55 AM


Btcc22
Joined: Dec 17, 2012


Posted: Mar 4, 2015 03:00 AM    Msg. 20 of 98       
That's strange. I haven't been able to reproduce that problem since fixing it. As long as only one widescreen fix is active before the first time you load a map, it should be fine.
Edited by Btcc22 on Mar 4, 2015 at 03:02 AM


TailsTheGamer
Joined: Mar 7, 2013

Meow


Posted: Mar 4, 2015 08:12 AM    Msg. 21 of 98       
Quote: --- Original message by: Btcc22

That's strange. I haven't been able to reproduce that problem since fixing it. As long as only one widescreen fix is active before the first time you load a map, it should be fine.
Edited by Btcc22 on Mar 4, 2015 at 03:02 AM


Maybe I did something wrong?

IDK, I wasn't the first person to have this issue so I'm not worried about it. I was confirming that I had the same issue as the other person as they asked.


Flash44x
Joined: Jan 3, 2007

What would you have your arbiter do?


Posted: Mar 4, 2015 09:29 AM    Msg. 22 of 98       
Quote: --- Original message by: Xx1Talon1xX
I'm not sure whats wrong, when I have the loader in Controls and hac.dll in the main directory and then try running the game I get to see halo splash screen and then it crashes to blackness with a white box and then I get a message of, Halo has crashed......

Im not sure if its you or me, but If I remove the loader, the game will play and I see more servers but no other hac stuff works
Same here.


Xx1Talon1xX
Joined: Feb 2, 2015

Mexicans, Mexicans Everywhere!


Posted: Mar 4, 2015 02:05 PM    Msg. 23 of 98       
That day I installed Xfire to my pc and it was on when the issue happen, but at the moment I'm at work and can't try turning it off....

Anyone else try what Zetren did?


Btcc22
Joined: Dec 17, 2012


Posted: Mar 4, 2015 02:13 PM    Msg. 24 of 98       
Quote: --- Original message by: Zetren
Here's a crash report after installing the new hac and new os. Turning off xfire has seemed to fix it


Turns out I uploaded the new hac.dll to the wrong folder, so that explains why it didn't fix anything. My bad. Could you try again?
Edited by Btcc22 on Mar 4, 2015 at 02:16 PM


Btcc22
Joined: Dec 17, 2012


Posted: Mar 4, 2015 03:59 PM    Msg. 25 of 98       
Seems that it'll occasionally crash on launch if you're running OS, HAC and Xfire in-game at the same time. I'll take a closer look to see if there's anything that can be done about that, on top of the Windows 8.1 thing.


Kinnet
Joined: Dec 27, 2013

Don't feed the hand that bites you.


Posted: Mar 6, 2015 03:59 AM    Msg. 26 of 98       
Thanks for the help, the OS hud "mixer?" was the problem


bourrin33
Joined: Oct 19, 2009

HEK not installed tho


Posted: Mar 7, 2015 10:29 AM    Msg. 27 of 98       
That's an issue which existed before, OS tries to check for a .yelo map instead of a .map and crashes. This is why you should uninstall OS shortly after finishing TSC:E


DaLode
Joined: Oct 4, 2014

Ho ho hooooly doodle!


Posted: Mar 7, 2015 11:08 AM    Msg. 28 of 98       
omg bourrin if you would stop bashing on OS so much that'd be great


DaLode
Joined: Oct 4, 2014

Ho ho hooooly doodle!


Posted: Mar 7, 2015 11:25 AM    Msg. 29 of 98       
I actually agree. Go HAC2!


FtDSpartn
Joined: May 1, 2009

Thank you.


Posted: Mar 7, 2015 09:12 PM    Msg. 30 of 98       
Got a 'Failed to load gametype icon!' and a 998 error.

loader.dll in controls, hac.dll in main folder.

Edit: Should have noted this - Windows 7 x64

Edited by FtDSpartn on Mar 7, 2015 at 09:31 PM


Xx1Talon1xX
Joined: Feb 2, 2015

Mexicans, Mexicans Everywhere!


Posted: Mar 7, 2015 09:16 PM    Msg. 31 of 98       
Quote: --- Original message by: FtDSpartn
Got a 'Failed to load gametype icon!' and a 998 error.

loader.dll in controls, hac.dll in main folder.


If your Win8, then it won't work. Which is the boat I'm in....


stunt_man
Joined: Sep 22, 2009

GMYF - Now hosting proper MLG gametypes!


Posted: Mar 8, 2015 03:02 AM    Msg. 32 of 98       
Quote: --- Original message by: Zetren
Not our fault Scythe and Kornman thought they could just ignore and sweep aside a patch which 90% of the halo community use. At the end of the day I'll be choosing Hac 2 if these crashes continue.


Me too I play more MP than SP and have already uninstalled OS because of the compatibility issues with HAC2.


Super Flanker
Joined: Oct 5, 2012

The length of your life depends on my aim.


Posted: Mar 8, 2015 10:51 AM    Msg. 33 of 98       
Quote: --- Original message by: Altearose
Hac is garbage, praise OS. Without OS, there won't be Hac anyways. The guys that worked on OS made the codes public and I don't even think the creator of Hac credited them and Hac is nothing but a collection of different codes from other Halo CE apps compiled into one file but I'm still amazed he could compressed a bunch of stuff into one small file and making them work like charm.

#TruthHasSetMeFree #SayNoToLies #PraiseOS #HacSucks


M8 your weed is hac'ing with your head.


ChieftainSnipe
Joined: Jul 14, 2013

I like Halo with Controllers


Posted: Mar 9, 2015 03:02 AM    Msg. 34 of 98       
Quote: --- Original message by: Danger_zone_98
Get this several times

http://i.imgur.com/rj8Jmc4.png


And then this

http://i.imgur.com/BI1mBzO.png


Yep, I got the same thing. I kept the loader.dll in 'controls' folder and the hac.dll in the main Halo Custom Edition folder.

What do I need to do in order to get the right compat fix? I also wanted reach style chat box btw even with OS.


Btcc22
Joined: Dec 17, 2012


Posted: Mar 9, 2015 09:03 AM    Msg. 35 of 98       
Quote: --- Original message by: Altearose
Hac is garbage, praise OS. Without OS, there won't be Hac anyways. The guys that worked on OS made the codes public and I don't even think the creator of Hac credited them and Hac is nothing but a collection of different codes from other Halo CE apps compiled into one file but I'm still amazed he could compressed a bunch of stuff into one small file and making them work like charm.

#TruthHasSetMeFree #SayNoToLies #PraiseOS #HacSucks


I'm sure you don't actually believe anything you post but for the benefit of those that might, I'll just point out that since HAC is also open source, it wouldn't be difficult to catch me out if your claims were actually true. Aside from that, it'd be difficult to steal code for features that didn't exist at the time of HAC's release.

To posters still having problems, there's an issue with HAC 2 + OS + Windows 8 which I still need to investigate.
Edited by Btcc22 on Mar 9, 2015 at 09:06 AM

 
Page 1 of 3 Go to page: · [1] · 2 · 3 · Next

 
Previous Older Thread    Next newer Thread





Time: Thu October 19, 2017 4:01 PM 296 ms.
A Halo Maps Website