A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo Custom Edition (Bungie/Gearbox) »Halo CE Technical / Map Design »OS - Help needed - compilation

Author Topic: OS - Help needed - compilation (6 messages, Page 1 of 1)
Moderators: Dennis

Tom638
Joined: Dec 7, 2014

H5 was a dissapointment


Posted: Jul 30, 2015 09:03 AM    Msg. 1 of 6       
When i compile my map in os_tool with the arguments build-cache-file-ex yelo2 0 1 1 levels\T638\T638 it gets as far as streaming tags and then throws the EXCEPTION_ACCESS_VIOLATION error at me, then crashes without an error log. Solutions anyone?

If it helps at all, it prints EAX: 0x00000000 directly after streaming tags.

It also says
Invalid format in data_files\-bitmaps
Invalid format in data_files\-sounds
Invalid format in data_files\-loc

Edited by Tom638 on Jul 30, 2015 at 09:04 AM


Roushyy
Joined: Jun 25, 2015

Character animator.


Posted: Jul 30, 2015 09:28 AM    Msg. 2 of 6       
Quote: --- Original message by: Tom638

-snip-


EXCEPTION_ACCESS_VIOLATION is caused by Tool not having sufficient permissions to write to a directory. Run it as administrator.

As for the invalid format error, I'm not sure. The only thing I can think of is that your tags in those directories are corrupted.


teh lag
Joined: May 6, 2008


Posted: Jul 30, 2015 10:17 AM    Msg. 3 of 6       
Quote: --- Original message by: War Master V

EXCEPTION_ACCESS_VIOLATION is caused by Tool not having sufficient permissions to write to a directory. Run it as administrator.

As for the invalid format error, I'm not sure. The only thing I can think of is that your tags in those directories are corrupted.


This is not correct. It's a result of the application crashing because it tried to access an invalid section of memory, usually because it encountered an unexpected condition that causes it to behave incorrectly. It is possible that directory permissions could cause such an error, but it also occurs (for example) when a map's model data exceeds the maximum allowed vertex / index buffer size.

Tom, it looks like you're building with shared cache files on. (That's the second boolean parameter in build-cache-file-ex). The "invalid format" message you're getting is about bad data in the shared caches, and it might be related to the application crashing. Set the second boolean parameter to false so it doesn't try to access an invalid shared cache.
Edited by teh lag on Jul 30, 2015 at 08:02 PM


Tom638
Joined: Dec 7, 2014

H5 was a dissapointment


Posted: Aug 3, 2015 05:41 AM    Msg. 4 of 6       
Thanks for the help but I've fixed the problem. I set the parameters to build-cache-file-ex yelo2 1 1 1 and it worked, perfectly. I have a feeling it was something to do with "yelo2" conflicting with the last version i compiled, as it was modified between the two compilations.

Such a shame OS_Tool doesn't recognize the problem and highlight any sort of solution like it does when a bitmap is corrupt or a script fails to compile.


DOOM899
Joined: Jul 23, 2013

{DM} [gamesmaster] if i can ill help maybe


Posted: Aug 3, 2015 08:09 AM    Msg. 5 of 6       
Quote: --- Original message by: Tom638
Thanks for the help but I've fixed the problem. I set the parameters to build-cache-file-ex yelo2 1 1 1 and it worked, perfectly. I have a feeling it was something to do with "yelo2" conflicting with the last version i compiled, as it was modified between the two compilations.

Such a shame OS_Tool doesn't recognize the problem and highlight any sort of solution like it does when a bitmap is corrupt or a script fails to compile.
hold on build-cache-file-ex yelo2 1 1 1 I been using the wrong tool pere mote os_tool build-cache-file-ex "" 0 0 1 wow I didn't know that


MEGA_VKNG
Joined: Dec 23, 2013


Posted: Aug 3, 2015 12:49 PM    Msg. 6 of 6       
iirc yelo2 would be the shared maps name.

 

 
Previous Older Thread    Next newer Thread







Time: Thu May 23, 2019 8:15 PM 312 ms.
A Halo Maps Website