A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo Custom Edition (Bungie/Gearbox) »Halo CE General Discussion »[Release] SOI's SIngleplayer Adventure

Page 5 of 7 Go to page: · 1 · 2 · 3 · 4 · [5] · 6 · 7 · Prev · Next
Author Topic: [Release] SOI's SIngleplayer Adventure (230 messages, Page 5 of 7)
Moderators: Dennis

OctaVinyl
Joined: Dec 8, 2015

¡Voy A comer tù corazon!


Posted: May 31, 2016 02:55 AM    Msg. 141 of 230       
About that. I did upload a video of the exception happening. It ends with a black screen in the video.


SOI_7
Joined: Mar 23, 2012

Tatsumaki best waifu


Posted: May 31, 2016 04:24 AM    Msg. 142 of 230       
I'm inclined to think that the issue starts exactly when the "switch_bsp" command is triggered. Either that or the "object_teleport" command (we have clarified that the warthog is not the issue). But I don't think so, because the same command works in all the other maps, so my last theory is that the BSP could be broken somehow.

Maybe run "switch_bsp 2" while playing and see what happens


OctaVinyl
Joined: Dec 8, 2015

¡Voy A comer tù corazon!


Posted: May 31, 2016 06:37 AM    Msg. 143 of 230       
Quote: --- Original message by: SOI_7
I'm inclined to think that the issue starts exactly when the "switch_bsp" command is triggered. Either that or the "object_teleport" command (we have clarified that the warthog is not the issue). But I don't think so, because the same command works in all the other maps, so my last theory is that the BSP could be broken somehow.

Maybe run "switch_bsp 2" while playing and see what happens


About that, yup it works with the command, but it lowers my frame rate for a few seconds, which isn't a problem.

I found a way to fix this error however, on my part at least. It's to kill every single wildlife and covenant before proceeding to the panel.


Masters1337
Joined: Mar 5, 2006

halonaminator's unfortunate idol


Posted: May 31, 2016 07:48 AM    Msg. 144 of 230       
Quote: --- Original message by: SOI_7
I'm inclined to think that the issue starts exactly when the "switch_bsp" command is triggered. Either that or the "object_teleport" command (we have clarified that the warthog is not the issue). But I don't think so, because the same command works in all the other maps, so my last theory is that the BSP could be broken somehow.

Maybe run "switch_bsp 2" while playing and see what happens

post the script so people can manually copy it in line by line before the trigger volume is hit. let them determine which line causes the crash.


SOI_7
Joined: Mar 23, 2012

Tatsumaki best waifu


Posted: May 31, 2016 08:28 AM    Msg. 145 of 230       
Quote: --- Original message by: Masters1337
post the script so people can manually copy it in line by line before the trigger volume is hit. let them determine which line causes the crash.


Fair enough. Here it is the full script for the transition that is triggered once the device is activated:

(script dormant extra_mission
(player_enable_input false)
(fade_out 0 0 0 30)
(sleep 60)
(sound_impulse_start "sound\sfx\impulse\doors\garage_out" none 1)
(switch_bsp 2)
(object_teleport (unit (list_get (players) 0)) "before_extra")
(sleep 10)
(object_teleport jeep "before_extra_jeep")
(sleep 40)
(fade_in 0 0 0 30)
(sleep 30)
(player_enable_input true)
(unit_set_enterable_by_player jeep true )
(sleep 40)
(game_save_totally_unsafe))


Quote: --- Original message by: OctaVinyl
About that, yup it works with the command, but it lowers my frame rate for a few seconds, which isn't a problem.

I found a way to fix this error however, on my part at least. It's to kill every single wildlife and covenant before proceeding to the panel.


Uh? If that's the possible issue, perhaps I could fix it clearing the AIs before switching BSP. Weird that it doesn't happen on everyone, though


OctaVinyl
Joined: Dec 8, 2015

¡Voy A comer tù corazon!


Posted: May 31, 2016 09:59 AM    Msg. 146 of 230       
Quote: --- Original message by: SOI_7

Quote: --- Original message by: OctaVinyl
About that, yup it works with the command, but it lowers my frame rate for a few seconds, which isn't a problem.

I found a way to fix this error however, on my part at least. It's to kill every single wildlife and covenant before proceeding to the panel.


Uh? If that's the possible issue, perhaps I could fix it clearing the AIs before switching BSP. Weird that it doesn't happen on everyone, though




Nono. It's fine. I like killing those critters. They're like hopeless grunts (dey aggressive doe). Strange that it mostly happens on me too. When I first played it, it was normal, considering I played it on Heroic.

Oh yeah, it only functions well when I only play on Heroic. It won't cause exceptions on other difficulties. Odd.


MatthewDratt
Joined: Sep 11, 2010

Our President Brags About Sexual Assault


Posted: May 31, 2016 12:32 PM    Msg. 147 of 230       
Quote: --- Original message by: SOI_7
Quote: --- Original message by: Masters1337
post the script so people can manually copy it in line by line before the trigger volume is hit. let them determine which line causes the crash.


Fair enough. Here it is the full script for the transition that is triggered once the device is activated:

(script dormant extra_mission
(player_enable_input false)
(fade_out 0 0 0 30)
(sleep 60)
(sound_impulse_start "sound\sfx\impulse\doors\garage_out" none 1)
(switch_bsp 2)
(object_teleport (unit (list_get (players) 0)) "before_extra")
(sleep 10)
(object_teleport jeep "before_extra_jeep")
(sleep 40)
(fade_in 0 0 0 30)
(sleep 30)
(player_enable_input true)
(unit_set_enterable_by_player jeep true )
(sleep 40)
(game_save_totally_unsafe))


Quote: --- Original message by: OctaVinyl
About that, yup it works with the command, but it lowers my frame rate for a few seconds, which isn't a problem.

I found a way to fix this error however, on my part at least. It's to kill every single wildlife and covenant before proceeding to the panel.


Uh? If that's the possible issue, perhaps I could fix it clearing the AIs before switching BSP. Weird that it doesn't happen on everyone, though


Is that sound a custom sound? Custom sounds can cause crashes like crazy if not properly done.

AI switching bsp I've seen cause crashes before (it did on Takedown: Extermination- I got around this literally by just combining the two BSPs to avoid having to switch).

Unless "jeep" is corrupted (sound? bitmap? shader? animation?), I don't see anything that sticks out.


Jobalisk
Joined: Feb 8, 2014

The haiku master。


Posted: Jun 1, 2016 03:58 AM    Msg. 148 of 230       
just out of question Matt, are you still working on Seirra 117, or is that on hiatus?


SOI_7
Joined: Mar 23, 2012

Tatsumaki best waifu


Posted: Jun 1, 2016 06:41 AM    Msg. 149 of 230       
Quote: --- Original message by: MatthewDratt
Is that sound a custom sound? Custom sounds can cause crashes like crazy if not properly done.


No, Matt, it's the stock sound of the big garage doors in b40. I have actually added it in the second build, the first one didn't have it and it already crashed

Quote: --- Original message by: MatthewDratt
AI switching bsp I've seen cause crashes before (it did on Takedown: Extermination- I got around this literally by just combining the two BSPs to avoid having to switch).


Yeah, it seems that this is the most plausible cause, judging from OctaVinyl's experiments. Luckily it shouldn't be too hard to fix

Quote: --- Original message by: MatthewDratt
Unless "jeep" is corrupted (sound? bitmap? shader? animation?), I don't see anything that sticks out.


Nope, it's all good. I have also tried the script without teleporting the jeep. The issue persists.

Anyway, it seems that I have finally found the possible cause. Now, time to make a last build for a30 before the whole v2 thing for the campaign.

Serious Series: Serious Debugging!
Edited by SOI_7 on Jun 1, 2016 at 06:44 AM


Super Flanker
Joined: Oct 5, 2012

The length of your life depends on my aim.


Posted: Jun 1, 2016 07:02 AM    Msg. 150 of 230       

Edited by Super Flanker on Jun 1, 2016 at 07:02 AM


SOI_7
Joined: Mar 23, 2012

Tatsumaki best waifu


Posted: Jun 1, 2016 11:30 AM    Msg. 151 of 230       
(Hopefully) last take on a30: https://mega.nz/#!wBo3jYZI!8sRFO409M0egwhanpYhnlvm_ewmPf6oZxJhSkzusSC0

If this works, I can finally start the massive bug fixing for V2


OctaVinyl
Joined: Dec 8, 2015

¡Voy A comer tù corazon!


Posted: Jun 1, 2016 11:33 AM    Msg. 152 of 230       
Quote: --- Original message by: SOI_7
(Hopefully) last take on a30: https://mega.nz/#!wBo3jYZI!8sRFO409M0egwhanpYhnlvm_ewmPf6oZxJhSkzusSC0

If this works, I can finally start the massive bug fixing for V2




Guess what. This link is the good one. I am fully able to go to the next BSP now.

Yet there's a small problem still, the Elephant won't start moving.

Edit- Nah, it happened again. Guess I could only play the map once.
Edited by OctaVinyl on Jun 2, 2016 at 03:58 AM


clonecam117
Joined: Dec 11, 2012

Now a professional VFX/particle effect artist.


Posted: Jun 1, 2016 02:13 PM    Msg. 153 of 230       
I love everything that SOI_7 makes, it all comes out really fun and well-made.

Keep it up, buddy!


Jesse
Joined: Jan 18, 2009

Discord: Jesse#4500


Posted: Jun 1, 2016 02:54 PM    Msg. 154 of 230       
Quote: --- Original message by: clonecam117
I love everything that SOI_7 makes, it all comes out really fun and well-made.

Keep it up, buddy!


Even when he drops a dookie!


SOI_7
Joined: Mar 23, 2012

Tatsumaki best waifu


Posted: Jun 1, 2016 04:11 PM    Msg. 155 of 230       
Quote: --- Original message by: OctaVinyl
Guess what. This link is the good one. I am fully able to go to the next BSP now.

Yet there's a small problem still, the Elephant won't start moving.




YES YES YES!!!! THAT'S AWESOME! I'll put that in the OP so that everyone knows!

And about the Elephant, it should move once you have killed the Covenant squads near you, so just take a look around (there's a bridge at the beginning, look up and kill those Covenant, although I'm definitely changing their location in the final build)


Halo305sparts
Joined: Nov 1, 2013

Actually isn't a noob


Posted: Jun 1, 2016 08:29 PM    Msg. 156 of 230       
Love your campaign mod fam. I got a question regarding using your Marine actor variant tags and your Assault Rifle/nade launcher.weapon, Can AI Marines use the grenade launcher or no? If I remember correctly CMT made the Marine AI use br/nade launchers back in spv1/spv2 days, why was it scrapped?


OctaVinyl
Joined: Dec 8, 2015

¡Voy A comer tù corazon!


Posted: Jun 2, 2016 12:03 AM    Msg. 157 of 230       
Quote: --- Original message by: Halo305sparts
Love your campaign mod fam. I got a question regarding using your Marine actor variant tags and your Assault Rifle/nade launcher.weapon, Can AI Marines use the grenade launcher or no? If I remember correctly CMT made the Marine AI use br/nade launchers back in spv1/spv2 days, why was it scrapped?



Well, if you take the rifles of the marines, you'll see that they don't have any grenades loaded.


RadWolfie
Joined: Dec 24, 2013

Programmer


Posted: Jun 2, 2016 01:40 PM    Msg. 158 of 230       

  • (switch_bsp 2) <-- No crash even with those friendly thingy (forgot what they're called. Shame on me...)

  • (object_teleport (unit (list_get (players) 0)) "before_extra") <-- This is where the crash occur.

  • (object_teleport jeep "before_extra_jeep") <-- tested this as well, didn't crash at all even when teleport myself there via console too.


Hmm, "before_extra" is causing the crash. Unless I use "before_extra_jeep" instead of "before_extra", it works fine. I'm not an expert or made a tool to review what this string data relative to. I do know it has to do with a location. It has been tested on your recent uploaded a30_debug zip file.

I hope this is helpful to you since the crash still occurred.


SOI_7
Joined: Mar 23, 2012

Tatsumaki best waifu


Posted: Jun 2, 2016 02:20 PM    Msg. 159 of 230       
Quote: --- Original message by: RadWolfie

  • (switch_bsp 2) <-- No crash even with those friendly thingy (forgot what they're called. Shame on me...)

  • (object_teleport (unit (list_get (players) 0)) "before_extra") <-- This is where the crash occur.

  • (object_teleport jeep "before_extra_jeep") <-- tested this as well, didn't crash at all even when teleport myself there via console too.


Hmm, "before_extra" is causing the crash. Unless I use "before_extra_jeep" instead of "before_extra", it works fine. I'm not an expert or made a tool to review what this string data relative to. I do know it has to do with a location. It has been tested on your recent uploaded a30_debug zip file.

I hope this is helpful to you since the crash still occurred.




*sigh* Since you said that, I have placed a different flag, with a different name, in a different location... but I have the bad feeling that it will crash anyway


RadWolfie
Joined: Dec 24, 2013

Programmer


Posted: Jun 2, 2016 02:31 PM    Msg. 160 of 230       
Not sure if you had tried this one. Copy before_extra_jeep data to before_extra data and just relocate the location a bit. (Not even sure if this is easy to do since I'm not a map maker...)

Or... just use before_extra_jeep when it gets to the end of blocked tunnel? Since this is the one works fine.

Edit: Actually, before_extra works fine if I'm in the vehicle. Soon as I got teleported, I found most likely cause of crash. See the screenshot below, before_extra needs a re-adjustment badly. While before_extra_jeep only need little bit of adjustment since rear wheels are in the ground.

P.S. if I use debug_camera_save/load... the whole world are upside down for some reason? And for some reason it didn't do any mission update/objective from starting point to other end of the map.



Edited by RadWolfie on Jun 2, 2016 at 04:13 PM


OctaVinyl
Joined: Dec 8, 2015

¡Voy A comer tù corazon!


Posted: Jun 2, 2016 04:33 PM    Msg. 161 of 230       
Oh yeah, if nobody saw the edit I did, it seems that the crash happened again. Same button. Ugh. Guess a30 can be played only once for me then.


Super Flanker
Joined: Oct 5, 2012

The length of your life depends on my aim.


Posted: Jun 2, 2016 06:54 PM    Msg. 162 of 230       
Also could you fix weapon pickup?

It seems I have to hold the E key for longer than usual.


Tech
Joined: May 9, 2015


Posted: Jun 3, 2016 02:44 AM    Msg. 163 of 230       
Pros switch with the X key


DOOM899
Joined: Jul 23, 2013

{DM} [gamesmaster] if i can ill help maybe


Posted: Jun 3, 2016 05:47 AM    Msg. 164 of 230       
played all the way thru a10 not one crash, nice map addon.

2nd a30 just one crash at that damn door, cannot get past it.


Super Flanker
Joined: Oct 5, 2012

The length of your life depends on my aim.


Posted: Jun 3, 2016 09:15 AM    Msg. 165 of 230       
Quote: --- Original message by: Tech
Pros switch with the X key


Whatever key binding you use the pick up time would still be the same unless.....


RadWolfie
Joined: Dec 24, 2013

Programmer


Posted: Jun 3, 2016 12:10 PM    Msg. 166 of 230       
Quote: --- Original message by: DOOM899
played all the way thru a10 not one crash, nice map addon.

2nd a30 just one crash at that damn door, cannot get past it.


The only fix for it is to do these step first (do not approach the end of the tunnel, otherwise you will be automatic move on to next mission). Open console via ` key then type in each command from top to bottom.

  • switch_bsp 2

  • object_teleport (unit (list_get (players) 0)) before_extra_jeep

  • wake extra_mission


Then you are able to continue on throughout the game-play for a30 map.
Edited by RadWolfie on Jun 3, 2016 at 12:11 PM


Jobalisk
Joined: Feb 8, 2014

The haiku master。


Posted: Jun 5, 2016 03:06 PM    Msg. 167 of 230       
I recently had the same problem with a different map where the game would crash during a BSP switch and teleport. The issue I has is that I would teleport into a BSP the script would then wait until I reached a trig volume before teleporting me to the next one. I had a ghost that I would drive to get to this trigger volume. I then teleported to the next BSP and the game crashed, however if I did not drive the ghost and walked over to the trig volume the game would not crash. I then set it so that the player was forced to jump out of the ghost before teleporting, it still crashed. I then set up a second trig volume that would force the player out of the ghost and stop the player from reentering the ghost. the player would then walk the short distance to the trig volume and teleport out. However this still caused the game to crash. finally I simply took out the ghosts completely and forced the player to walk. doing this meant the game did not crash. anyway, what I'm trying to say is that it is perhaps the warthog that is causing the game to crash. I would like to point out that the crash I was getting was from opensauce and not from the game itself.


bandinada5
Joined: Mar 29, 2013


Posted: Jun 6, 2016 01:04 PM    Msg. 168 of 230       
idk, but there's bug in a30.map when you heading to the gate and open it using the device. and after that, game crash. any idea ? i already update a30 to version 2 on CE3 website. but still same problem

EDIT : i guess, i should try a30_debug. because i saw, octavinyl works with it
Edited by bandinada5 on Jun 6, 2016 at 01:28 PM


Super Flanker
Joined: Oct 5, 2012

The length of your life depends on my aim.


Posted: Jun 6, 2016 02:19 PM    Msg. 169 of 230       
Quote: --- Original message by: bandinada5

idk, but there's bug in a30.map when you heading to the gate and open it using the device. and after that, game crash. any idea ? i already update a30 to version 2 on CE3 website. but still same problem

EDIT : i guess, i should try a30_debug. because i saw, octavinyl works with it
Edited by bandinada5 on Jun 6, 2016 at 01:28 PM


Op is already aware and is trying his/her best to fix it.


SOI_7
Joined: Mar 23, 2012

Tatsumaki best waifu


Posted: Jun 6, 2016 02:25 PM    Msg. 170 of 230       
Quote: --- Original message by: Super Flanker
Op is already aware and is trying his/her best to fix it.


LOLWAT


Jobalisk
Joined: Feb 8, 2014

The haiku master。


Posted: Jun 6, 2016 02:53 PM    Msg. 171 of 230       
Quote: --- Original message by: SOI_7
Quote: --- Original message by: Super Flanker
Op is already aware and is trying his/her best to fix it.


LOLWAT


peeps on this thread...


WWLinkMasterX
Joined: Mar 29, 2009

subliminal message.


Posted: Jun 7, 2016 12:26 AM    Msg. 172 of 230       
̶A̶l̶t̶i̶s̶ SOI is a GURL???!!??


TheHaloKnight
Joined: Jun 11, 2015


Posted: Jun 7, 2016 12:31 AM    Msg. 173 of 230       
maybe red means wrong?


MatthewDratt
Joined: Sep 11, 2010

Our President Brags About Sexual Assault


Posted: Jun 7, 2016 02:21 AM    Msg. 174 of 230       
Quote: --- Original message by: WWLinkMasterX
̶A̶l̶t̶i̶s̶ SOI is a GURL???!!??


There's people on here who are boys?


SOI_7
Joined: Mar 23, 2012

Tatsumaki best waifu


Posted: Jun 7, 2016 05:16 AM    Msg. 175 of 230       
I'm 100% sure the last time I checked I was a boy

 
Page 5 of 7 Go to page: · 1 · 2 · 3 · 4 · [5] · 6 · 7 · Prev · Next

 
Previous Older Thread    Next newer Thread







Time: Thu September 21, 2017 3:36 PM 468 ms.
A Halo Maps Website