A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo Custom Edition (Bungie/Gearbox) »Halo CE General Discussion »Sentinel Beam Issue Solved! (BAD NEWS)

Author Topic: Sentinel Beam Issue Solved! (BAD NEWS) (17 messages, Page 1 of 1)
Moderators: Dennis

Halo Noob Modder117
Joined: Jan 22, 2016


Posted: Jan 22, 2017 10:53 PM    Msg. 1 of 17       
Hey everyone. Some of you might remember the thread a while ago regarding the good old H3 sentinel beam not working properly.

Well today I ran some tests. Aside from the Zteam and Takedown sentinel beam not having a fire sound I decided to rip other sentinel beams and test the results to examine a theory...

That theory was created under the assumption that HEK corrupts tags (as most mention) and guess what? Upon extracting SOI and some other 'test subjects' ALL of them suffered the same fate, the loss of the fire sound.

Guess I won't be adding this to the Unified Asset Collection I was working on...


Masters1337
Joined: Mar 5, 2006

halonaminator's unfortunate idol


Posted: Jan 22, 2017 10:56 PM    Msg. 2 of 17       
use the real time editor to inspect the tags in memory. Also did you try Halo Tag Converter?


Halo Noob Modder117
Joined: Jan 22, 2016


Posted: Jan 23, 2017 02:01 AM    Msg. 3 of 17       
I've never heard of this real time editor thing you speak of... I extract tags using hek+.

Tag converter? Isn't that for converting Combat Evolved tags into Custom Edition tags?

Master could you try extracting them yourself and see if you get the same result? I'm curious if this is just me or the actual program.


Masters1337
Joined: Mar 5, 2006

halonaminator's unfortunate idol


Posted: Jan 24, 2017 09:44 AM    Msg. 4 of 17       
It's going to be the program. There are several ways to rip tags from a map, the real time editor, HEK+ and it's predecessor Halo Tag Converter which can also rip from CE maps. I believe both are up on halomaps and a search should find them for you.

Edit: Can't find the real time editor, so here: https://www.dropbox.com/s/7fz9tvqkq1iua1v/gameditor%201.1.rar?dl=0
Edited by Masters1337 on Jan 24, 2017 at 09:47 AM


Super Flanker
Joined: Oct 5, 2012

The length of your life depends on my aim.


Posted: Jan 24, 2017 12:36 PM    Msg. 5 of 17       
Quote: --- Original message by: Masters1337
https://www.dropbox.com/s/7fz9tvqkq1iua1v/gameditor%201.1.rar?dl=0


Halo Noob Modder117
Joined: Jan 22, 2016


Posted: Jan 24, 2017 08:29 PM    Msg. 6 of 17       
Ah man I swear if I get another error this week...

Failed to locate window 'Halo'.


Masters1337
Joined: Mar 5, 2006

halonaminator's unfortunate idol


Posted: Jan 24, 2017 08:30 PM    Msg. 7 of 17       
you have the game loaded I assume? and running the latest version?


Halo Noob Modder117
Joined: Jan 22, 2016


Posted: Jan 24, 2017 10:29 PM    Msg. 8 of 17       
Okay I got it working... Magically works after opening and closing it twenty times...

I see you can edit tags live like its an in-game guerrilla... So what am I doing with this exactly?
Edited by Halo Noob Modder117 on Jan 24, 2017 at 10:52 PM


Masters1337
Joined: Mar 5, 2006

halonaminator's unfortunate idol


Posted: Jan 24, 2017 11:10 PM    Msg. 9 of 17       
you can compare the tag as the game is reading it form the map file, so you don't have to worry about it being corrupted when extracted through HEK+ or HTC.


Halo Noob Modder117
Joined: Jan 22, 2016


Posted: Jan 24, 2017 11:18 PM    Msg. 10 of 17       
Ah I see... So I should examine the tags and see if any variable was altered.

Knowing my luck, I'll just find an inconclusive answer.


Masters1337
Joined: Mar 5, 2006

halonaminator's unfortunate idol


Posted: Jan 24, 2017 11:41 PM    Msg. 11 of 17       
there is no such thing as luck. It's all numbers and values and knowing what to look for.


Halo Noob Modder117
Joined: Jan 22, 2016


Posted: Jan 25, 2017 12:25 AM    Msg. 12 of 17       
Oh believe me, if your using my junk you'd get errors that don't even exist on the internet with no solution regardless of copying tutorials to the mouse pointer location perfection.

Example: 3ds. Regardless of linking my model to the 'frame' thing, 3ds complains saying there are too many actors or there is nothing to export.

Scripts that seem to work for everyone else don't work for me (though my extracted scripts from the base game's scenarios do).

My icon bitmaps don't show up regardless of following all the tutorials. When I edit pelican decals and 'TOOL' them back over the decals have black squares beneath them.

Hell even when I rip people's stuff I get errors nobody else has ever heard of despite the things being ripped and placed elsewhere with no problems...
Edited by Halo Noob Modder117 on Jan 25, 2017 at 12:26 AM
Edited by Halo Noob Modder117 on Jan 25, 2017 at 12:27 AM


Masters1337
Joined: Mar 5, 2006

halonaminator's unfortunate idol


Posted: Jan 25, 2017 12:50 AM    Msg. 13 of 17       
Most people have those issues at one point or another. You just aren't doing things work and need to learn them one at a time.


Jesse
Joined: Jan 18, 2009

Discord: Jesse#4500


Posted: Jan 25, 2017 01:29 AM    Msg. 14 of 17       
Quote: --- Original message by: Halo Noob Modder117


Example: 3ds. Regardless of linking my model to the 'frame' thing, 3ds complains saying there are too many actors or there is nothing to export.


My icon bitmaps don't show up regardless of following all the tutorials. When I edit pelican decals and 'TOOL' them back over the decals have black squares beneath them.


(1) Make sure there isn't more than one root frame. Basically, you can only have ONE object titled as 'frame' that everything is ultimately connected to.

(1.5) make sure that everything you're trying to export IS either directly or indirectly linked to the root 'frame'. One way to test this is to click on the 'frame' and move it around, if everything is set up, the objects in question will move along with the 'frame'.

(2) compile the bitmaps in question, open them in guerilla, go to the compression settings (pull down bar) and select 'compressed with explicit alpha'. Recompile your bitmap and the settings should take place.

If course, make sure you have a proper alpha channel to dictate transparency. (And use "shader_transparent_glass" as the shader type.


Halo Noob Modder117
Joined: Jan 22, 2016


Posted: Jan 25, 2017 07:19 AM    Msg. 15 of 17       
I FOUND THE ISSUE! I THINK!

So using that editing thing I found this in the 1st person animation tags...

Under the 'animations' tab the name is: first-person fire-1%0.

Beneath this is another line of text that is highlighted in red saying: invalid enum index 0.

So this must be the firing error, so the question is, what the hell is this and how do you fix it?


The Master
Joined: Aug 8, 2014

~En Lepanto la victoria y la muerte en Trafalgar~


Posted: Jan 25, 2017 10:31 AM    Msg. 16 of 17       
So I just realized this is topic #50000

thought I'd point it out.


SBB_Michelle
Joined: Nov 4, 2015

I am me!


Posted: Jan 25, 2017 12:44 PM    Msg. 17 of 17       
That has nothing to do with te siresound not working, as expressed in your other topics it is because the attachment that uses a function to check if the weapon is firing is not working correctly.

Also, the realtime editor has to be launched as admin when you get "failed to locate window"

 

 
Previous Older Thread    Next newer Thread





Time: Tue August 22, 2017 10:52 AM 406 ms.
A Halo Maps Website