A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo Custom Edition (Bungie/Gearbox) »Halo CE Technical / Map Design »Campaign audio bug and cutscene freeze

Author Topic: Campaign audio bug and cutscene freeze (5 messages, Page 1 of 1)
Moderators: Dennis

AerialAceFiM
Joined: Mar 15, 2017


Posted: Mar 17, 2017 03:42 PM    Msg. 1 of 5       
I was wondering if anyone could explain why when I compile a campaign map such as a10 using tool, even without custom tags, I get various audio and music cutoffs and become frozen in place in cutscenes and after Keyes gives me his pistol if I skip the cutscene prior.


Super Flanker
Joined: Oct 5, 2012

Synthetic furnishings, rails and no safety.


Posted: Mar 17, 2017 03:48 PM    Msg. 2 of 5       
http://forum.halomaps.org/index.cfm?page=topic&topicID=48114

A quick scroll through there should provide the answer but a quick tldr;

You can't grab campaign tags from where ever, rip them, add them to your tagset, expect them to compile correctly and play well there are lots of little annoying things which require fixes here and there.

Once you get going though it does iron out, but getting a campaign to work right does require alot of patience and practice.

That being said given the age of this website I am sure someone at some point has been able to compile and author a successfull set of tag and map files which play perfect homage to the complete combat evolved campaign.
Edited by Super Flanker on Mar 18, 2017 at 02:23 PM


AerialAceFiM
Joined: Mar 15, 2017


Posted: Mar 17, 2017 04:01 PM    Msg. 3 of 5       
Thanks for the quick reply. I've been trying all sorts of different things over the past couple of days just trying to get a10 to run properly when compiled. So far, no luck, and I can't figure out if it's the result of corrupt tags, missing tags, or script problems.


Super Flanker
Joined: Oct 5, 2012

Synthetic furnishings, rails and no safety.


Posted: Mar 18, 2017 06:16 AM    Msg. 4 of 5       
Post/screenshot the debug info/feedback from tool.


AerialAceFiM
Joined: Mar 15, 2017


Posted: Mar 18, 2017 01:26 PM    Msg. 5 of 5       
03.18.17 13:25:24 tool pc 01.00.00.0609 ----------------------------------------------
03.18.17 13:25:24 reference function: _write_to_error_file
03.18.17 13:25:24 reference address: 42ca20
03.18.17 13:25:24 Couldn't read map file './toolbeta.map'
03.18.17 13:25:25 WARNING: 1 clusters in structure_bsp levels\a10\a10_space have no background sound or sound environment.
03.18.17 13:25:25 WARNING: command list look_at_halo could be ambiguously attached to BSPs #1 and #8
03.18.17 13:25:25 WARNING: command list look_at_halo could be ambiguously attached to BSPs #1 and #8

This is all I get in debug.txt when I compile it in tool.

 

 
Previous Older Thread    Next newer Thread





Time: Fri March 24, 2017 3:53 PM 172 ms.
A Halo Maps Website