A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo Custom Edition (Bungie/Gearbox) »Halo CE General Discussion »OS Tool won't build my OS Scenario and OS Sapien Crashes

Author Topic: OS Tool won't build my OS Scenario and OS Sapien Crashes (11 messages, Page 1 of 1)
Moderators: Dennis

GirtheDoge
Joined: Jul 14, 2017

Been playin Halo since 07


Posted: Aug 6, 2017 08:56 PM    Msg. 1 of 11       
I've finally managed to place ai and other CMT tags in a map(not all the tags though) with OS Sapien. Whenever I successfully place CMT's TSC:Evolved Tags down and I try to build the map with OS tool, It says it can't load the scenario heres the output

C:\Program Files (x86)\Microsoft Games\Halo Custom Edition>tool build-cache-file levels\test\tutorial\test
Couldn't read map file './toolbeta.map'
tag data 'hs_syntax_data_definition' too large.
failed to load scenario tag 'levels\test\tutorial\test'
tag data 'hs_syntax_data_definition' too large.
failed to load scenario tag 'levels\test\tutorial\test'
need to get the following tags:

### FAILED TO LOAD SCENARIO.

Cache pack file bitmaps hits: 0 for 0.00M
Cache pack file bitmaps adds/misses: 0 for 0.00M
Cache pack file sounds hits: 0 for 0.00M
Cache pack file sounds adds/misses: 0 for 0.00M
Cache pack file loc hits: 0 for 0.00M
Cache pack file loc adds/misses: 0 for 0.00M

Ok, now the other problem is that when I load specific tags in a map and place them down, OS Sapien crashes(Brute tags) not immediatly but when i reopen the map it crashes. someone help plz


OrangeJuice
Joined: Jan 29, 2009

discord was killing the forums anyways


Posted: Aug 6, 2017 09:24 PM    Msg. 2 of 11       
try:

os_tool build-cache-file levels\test\tutorial\test


or

os_tool build-cache-file-ex "" 0 0 0 levels\test\tutorial\test


You used the wrong tool, use os_tool
Edited by OrangeJuice on Aug 6, 2017 at 09:25 PM


GirtheDoge
Joined: Jul 14, 2017

Been playin Halo since 07


Posted: Aug 6, 2017 09:49 PM    Msg. 3 of 11       
OMG thanks but I still have another problem about the brute tag causing sapien to crash. Is it corrupt?


Jobalisk
Joined: Feb 8, 2014

The haiku master。


Posted: Aug 7, 2017 12:34 AM    Msg. 4 of 11       
Quote: --- Original message by: GirtheDoge
OMG thanks but I still have another problem about the brute tag causing sapien to crash. Is it corrupt?


more likely its missing, try to find the tag using the path it specifies in tool. if you can't find it then find a similar tag from lets say plasmarifle.light if its a light tag that's missing and make a copy at the appropriate path name then rename it to whats missing.


MosesofEgypt
Joined: Apr 3, 2013


Posted: Aug 7, 2017 12:50 AM    Msg. 5 of 11       
Mozz has a broken dependency scanner. It doesn't recursively scan tags in the selected folder, but if you have it scan your entire tags directory it'll tell you if anything is broken.


Edited by MosesofEgypt on Aug 7, 2017 at 12:51 AM


GirtheDoge
Joined: Jul 14, 2017

Been playin Halo since 07


Posted: Aug 7, 2017 01:39 PM    Msg. 6 of 11       
Thanks, moe but whenever I select my tags directory and I scan it, the log says it couldnt load anything and the scanner was going in a loop scanning my entire tags directory again and again


MosesofEgypt
Joined: Apr 3, 2013


Posted: Aug 7, 2017 02:36 PM    Msg. 7 of 11       
Could you screencap this? I've never heard of this happening. Also, if you're using the old version of mozz that can be found on the CE3 website, don't. Install the MEK. You can find it here:

http://forum.halomaps.org/index.cfm?page=topic&topicID=49967


GirtheDoge
Joined: Jul 14, 2017

Been playin Halo since 07


Posted: Aug 7, 2017 04:33 PM    Msg. 8 of 11       
nvm I thought it was in a loop but it says it couldnt load stuff here's a sample of the output(its pretty big and it just says it cant load anything)


    effects\lights\coop teleport.lens_flare
    Could not load 'effects\lights\coop teleport.lens_flare'
    Could not load 'effects\lights\large explosion.lens_flare'
    Could not load 'effects\lights\small explosion.lens_flare'
    Could not load 'lens flares\b40 orange glow.lens_flare'
    Could not load 'lens flares\c20 dim blue round.lens_flare'
    Could not load 'lens flares\fluorescent glow-flicker.lens_flare'
    Could not load 'lens flares\fluorescent glow.lens_flare'
    Could not load 'lens flares\hazard light.lens_flare'
    Could not load 'lens flares\inner engine.lens_flare'
    Could not load 'lens flares\large explosion.lens_flare'
    Could not load 'lens flares\large forerunner glow.lens_flare'
    Could not load 'lens flares\large fuzzyblue.lens_flare'
    Could not load 'lens flares\rectangular blue.lens_flare'
    Could not load 'lens flares\rectangular purple.lens_flare'
    Could not load 'levels\a10\devices\alert_light\alert_light2.lens_flare'
    Could not load 'levels\a10\devices\lifepod device\effects\lifepod explosion.lens_flare'
    Could not load 'levels\a10\devices\shield charge\shield charge ring.lens_flare'
    Could not load 'levels\a10\devices\shield charge\shield charge.lens_flare'
    Could not load 'levels\a10\devices\space_battle\explosion_space.lens_flare'
    Could not load 'levels\a10\poa_explosions\poa_fireflash large.lens_flare'
    Could not load 'levels\a10\poa_explosions\poa_fireflash.lens_flare'
    Could not load 'levels\a10\scenery\poa large exhaust.lens_flare'
    Could not load 'levels\a10\scenery\poa small exhaust.lens_flare'
    Could not load 'levels\a30\devices\beam emitter\beam.lens_flare'
    Could not load 'levels\a30\devices\torpedo_bridge\emitter.lens_flare'
    Could not load 'levels\a30\scenery\holo control indicator\holo indicator.lens_flare'
    Could not load 'levels\a50\devices\light_ceiling\spotlight small.lens_flare'
    Could not load 'levels\a50\devices\light_ground\light ground spotlight small.lens_flare'
    Could not load 'levels\a50\devices\shuttle bay doors\shield.lens_flare'
    Could not load 'levels\b30\devices\doors\door small\locklight.lens_flare'
    Could not load 'levels\b30\devices\interior tech objects\holo control room display\holo control room display.lens_flare'
    Could not load 'levels\b40\devices\b40_generator_fx\generator glow.lens_flare'
    Could not load 'levels\b40\devices\b40_generator_fx\generator light.lens_flare'
    Could not load 'levels\b40\devices\b40_generator_fx\generator overload glow.lens_flare'
    Could not load 'levels\b40\devices\b40_generator_fx\generator overload light.lens_flare'
    Could not load 'levels\b40\devices\b40_outerdoor\b40_locklight.lens_flare'
    Could not load 'levels\b40\devices\b40_spotlight\b40_big.lens_flare'
    Could not load 'levels\b40\devices\b40_spotlight\b40_med.lens_flare'
    Could not load 'levels\b40\devices\b40_spotlight\b40_small.lens_flare'
    Could not load 'levels\b40\scenery\b40_ctorch\ctorch.lens_flare'
    Could not load 'levels\c10\scenery\cyan point light\light.lens_flare'
    Could not load 'levels\c10\scenery\green point light\light.lens_flare'
    Could not load 'levels\c10\scenery\orange point light\light.lens_flare'


    help I also changed the tagset to OS v4 and it still doesnt work
    Edited by GirtheDoge on Aug 7, 2017 at 04:36 PM
    Edited by GirtheDoge on Aug 7, 2017 at 04:40 PM
    Edited by GirtheDoge on Aug 7, 2017 at 04:46 PM


MosesofEgypt
Joined: Apr 3, 2013


Posted: Aug 7, 2017 06:16 PM    Msg. 9 of 11       
Can you load ANY tags? If not then it's probably a permissions issue with python. Try to claim user ownership of the halo custom edition directory. This has been a problem with lots of people using my tools.

Also, I suggest you download the MEK from here: https://bitbucket.org/Moses_of_Egypt/mek/downloads/

I did a bad and accidentally linked you to an outdated version of mozzarilla. Just delete what I told you to download before and download this one and read the readme to install it. There is also troubleshooting section in the readme that should help you fix any issues. Sorry for wasting your time with the old version.


OrangeJuice
Joined: Jan 29, 2009

discord was killing the forums anyways


Posted: Aug 7, 2017 07:35 PM    Msg. 10 of 11       
Or it just has a lot of janked dependencies because they're CMT tags,

Looks like you need to extract a10, a30, a50, b30, b40, c10, and c20


GirtheDoge
Joined: Jul 14, 2017

Been playin Halo since 07


Posted: Aug 7, 2017 09:24 PM    Msg. 11 of 11       
Yeah but my tagset is from tsc:evolved tagset i didnt extract the yelo maps. i downloaded it. btw I tried to extract spv3s tags but sapien wouldnt accept them. sapien didnt even load any map

and moe its fine and I also. it was a permission issue

the cmt tagset has alot of broken dependencies. My estimate is probauly 100s and 100s of broken dpendencies. How do I fix a broken dependency quickly?
It couldnt scan CMT vehicles,sounds,Shader_environment tags,particle_systems,particles,bipeds and some other tags. It scanned most tags though
Edited by GirtheDoge on Aug 7, 2017 at 10:38 PM

 

 
Previous Older Thread    Next newer Thread





Time: Fri October 20, 2017 11:08 PM 235 ms.
A Halo Maps Website