A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo Custom Edition (Bungie/Gearbox) »Halo CE General Discussion »Tried to add more elements for a structure_scenario_bsp

Author Topic: Tried to add more elements for a structure_scenario_bsp (7 messages, Page 1 of 1)
Moderators: Dennis

DeadHamster
Joined: Jun 8, 2014


Posted: Mar 2, 2018 11:42 AM    Msg. 1 of 7       


With or without portals, with multiple exporters. Same error. What'd I do?


Edit: Tool compiled it fine, after tweaking the Portals it looks like OS_tool compiled as well. Appears that OS_tool couldn't handle all the geometry in a single subcluster, which is strange because I've had much more in prior BSPs.

HOWEVER, even after compiling the tag is corrupt and crashes Guerilla/Sapien when trying to load it. What's going on?





Edited by DeadHamster on Mar 2, 2018 at 11:55 AM


Halonimator
Joined: Dec 15, 2014

https://imgur.com/ZBjOJ4L


Posted: Mar 2, 2018 11:59 AM    Msg. 2 of 7       
Show us your map in 3dsmax first, so we can see what you need to fix.


DeadHamster
Joined: Jun 8, 2014


Posted: Mar 2, 2018 12:25 PM    Msg. 3 of 7       
Have a blast


OS_Tool compiles the BSP and it crashes, tool compiles the BSP and it loads. Trying to run radiosity now but she's stuck.


OrangeJuice
Joined: Jan 29, 2009

halohek.pbworks.com


Posted: Mar 2, 2018 02:00 PM    Msg. 4 of 7       
Here's an older topic that might clear some things up that someone with your problem progressed on: http://forum.halomaps.org/index.cfm?page=topic&topicID=49824

It's the third post, with a few trial and error findings from super flanker on what they did wrong
Edited by OrangeJuice on Mar 2, 2018 at 02:02 PM


DeadHamster
Joined: Jun 8, 2014


Posted: Mar 2, 2018 02:14 PM    Msg. 5 of 7       
Quote: --- Original message by: OrangeJuice

Here's an older topic that might clear some things up that someone with your problem progressed on: http://forum.halomaps.org/index.cfm?page=topic&topicID=49824

It's the third post, with a few trial and error findings from super flanker on what they did wrong
Edited by OrangeJuice on Mar 2, 2018 at 02:02 PM



Unfortunately none apply here. I only have 2 sub-objects; The BSP and the Portals.

The BSP compiles, I can see it in Sapien using debug_structure , however it hangs up when I try to launch radiosity. Never starts the countdown.


Halo Noob Modder117
Joined: Jan 22, 2016

I guess I'm just going to have to rip your tags


Posted: Mar 4, 2018 10:26 AM    Msg. 6 of 7       
Goodness don't tell me your getting those errors with that fantastic map you've been showing off recently...


DeadHamster
Joined: Jun 8, 2014


Posted: Mar 4, 2018 01:37 PM    Msg. 7 of 7       
I am, on the new bridge/cityscape BSP.

So it compiles now, I can open the BSP and save it fine. If I look in Sapien with debug_structure or debug_portals I can see both compiled without issue.

But when I run radiosity in Tool or Sapien as soon as it starts to calculate it freezes. Program locks up and makes no progress.



Edit: After several hours the lightmaps began to compile in Tool. Something is wonky, but at the very least it's not broken. Errors seem to be related to the amount of geometry (19k verts) and the lack of proper portalling, causing apparently too much geometry to be compiled into a single cluster.

I did not have this issue, however, with BSP's containing far more polys. Not sure why it came up here, so there must be some other underlying issue with the map's actual geometry that I'm not seeing.




Edit: So this may be a compounded issue. An old friend called Inigo Montoya directed me to a simmilar issue he faced in Gephyrophobia; because the plasma-tether rails were highly repeated in their UV mapping, having them set to High in shader quality took forever to tesselate/uv unwrap the BSP for lightmaps. What would take several days was done in minutes.

Setting all materials to medium quality allowed Sapien to make minimal progress. I'm guessing it's because of the sea bed texture, where the dirt is very very heavily tiled over a large, flat surface. Doing more debugging now to try and work around this.


So I fixed it, the original error message related to BSP portalling not being setup or setup efficiently. To anybody that sees this post for future reference; Portal the BSP. Check that your portal properly divides level geometry. Check that your portals compile properly.

The lightmaps issue was unrelated, and was solved by modifying the amount of tiling in 3DS max, and the shader quality in guerilla.
Edited by DeadHamster on Mar 4, 2018 at 03:23 PM

 

 
Previous Older Thread    Next newer Thread







Time: Fri September 21, 2018 10:54 AM 234 ms.
A Halo Maps Website