A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
»Forums Index »Halo Custom Edition (Bungie/Gearbox) »Halo CE General Discussion »Best 3ds max version for halo ce

Author Topic: Best 3ds max version for halo ce (13 messages, Page 1 of 1)
Moderators: Dennis

The Gravemind
Joined: Jul 26, 2016

I Am The Monument To All Your Sins


Posted: Aug 13, 2018 02:32 AM    Msg. 1 of 13       
I have read that newer versions of max are not compatible with jms exporters. So I was wondering which version would be the best to work with for halo ce.


Banshee64
Joined: Dec 4, 2012

oify


Posted: Aug 13, 2018 03:29 AM    Msg. 2 of 13       
I use the JMS max script in 3ds max 2017 (and I think i've done it in 2019) as well

If you're trying to use the original exporter I think it only work on 3d studio max 6 or 3ds max 8 iirc


The Gravemind
Joined: Jul 26, 2016

I Am The Monument To All Your Sins


Posted: Aug 13, 2018 03:29 PM    Msg. 3 of 13       
thanks I was planning to get the 2019 version


R93_Sniper
Joined: Feb 13, 2011

When in Doubt, RUN!


Posted: Aug 14, 2018 12:05 AM    Msg. 4 of 13       
Max 8 is most compatible as that's what was intended for CE. There are some exporters that work with newer versions but not entirely sure which ones those are anymore


SBB_Michelle
Joined: Nov 4, 2015

Floof


Posted: Aug 14, 2018 12:15 AM    Msg. 5 of 13       
Everyone needs to stop telling people that they should use max 8. Max 8 depends on a deprecated Windows API for it's max script, so they won't all work properly. You also can't use some newer scripts and plugins, rendering is broken on windows 7 and up. Don't use max 8. If you want to go old school, use 9. But I suggest using a newer version personally.


R93_Sniper
Joined: Feb 13, 2011

When in Doubt, RUN!


Posted: Aug 14, 2018 02:58 AM    Msg. 6 of 13       
Quote: --- Original message by: SBB_Michelle
Everyone needs to stop telling people that they should use max 8. Max 8 depends on a deprecated Windows API for it's max script, so they won't all work properly. You also can't use some newer scripts and plugins, rendering is broken on windows 7 and up. Don't use max 8. If you want to go old school, use 9. But I suggest using a newer version personally.


I personally use Max 2016 cuz its nice and because i dont do CE stuff anymore. I'm just relaying the deprecated information that everyone gives out here

Sidenote to OP; Don't use the newest max version (2019 in this case) until it's put out for its current year. It's unstable as all hell until the named year matches the current one


DeadHamster
Joined: Jun 8, 2014

https://discord.gg/Neu4EJM


Posted: Aug 14, 2018 04:00 PM    Msg. 7 of 13       
Max 2010 or bust.


il Duce Primo
Joined: Apr 22, 2007

CMT Team Leader


Posted: Aug 14, 2018 06:28 PM    Msg. 8 of 13       
Quote: --- Original message by: SBB_Michelle
Everyone needs to stop telling people that they should use max 8. Max 8 depends on a deprecated Windows API for it's max script, so they won't all work properly. You also can't use some newer scripts and plugins, rendering is broken on windows 7 and up. Don't use max 8. If you want to go old school, use 9. But I suggest using a newer version personally.

Best version of 3dsmax for developing for halo CE is.... 3dsmax8. What newer scripts do you use that are necessary for making halo ce stuff, and why would rendering help for halo ce?

The reason why version 8 is the best for Halo ce is the main built in exporter and most tools designed for halo support max 8. Most of the things in the newer version of max are nice in developing for other games but have little to no use for halo development. A possible problem might be if you're using the newest version of windows, but i think that has been resolved and is no longer an issue.


SBB_Michelle
Joined: Nov 4, 2015

Floof


Posted: Aug 14, 2018 06:58 PM    Msg. 9 of 13       
I'm talking about rendering issues on the UI and viewports. They bug out all the time for me when I try to use max 8.

Setting the theme of Windows to basic could fix it I think, but that has the side effect of slowing down and breaking some other applications. And Windows 7 is the last Windows that supports this feature.


The Gravemind
Joined: Jul 26, 2016

I Am The Monument To All Your Sins


Posted: Aug 14, 2018 07:33 PM    Msg. 10 of 13       
I have installed the 2019 version and so far the gbx model importer seems to be working except it doesn't automatically apply materials. I haven't really done much and I haven't tested the jms exporter yet.
Edited by The Gravemind on Aug 14, 2018 at 08:47 PM


il Duce Primo
Joined: Apr 22, 2007

CMT Team Leader


Posted: Aug 14, 2018 07:51 PM    Msg. 11 of 13       
If you already have the latest version of max then thatll work more than enough.


SBB_Michelle
Joined: Nov 4, 2015

Floof


Posted: Aug 14, 2018 09:00 PM    Msg. 12 of 13       
Since we're all on different max versions, if anyone wants to share an fbx, I suggest going to the advanced settings when exporting and using one of the old binary formats so max 8 users can enjoy.


The Gravemind
Joined: Jul 26, 2016

I Am The Monument To All Your Sins


Posted: Aug 14, 2018 10:44 PM    Msg. 13 of 13       
I can confirm that max 2019 works perfectly, I have just made my first model!

 

 
Previous Older Thread    Next newer Thread







Time: Thu July 18, 2019 8:57 PM 235 ms.
A Halo Maps Website