A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
Viewing User Profile for: D0ubl3 HeLiX
About Contact
Joined: Aug 27, 2010 07:28 PM
Last Post: Oct 1, 2011 12:30 PM
Last Visit: Nov 4, 2018 03:50 AM
Location:
Occupation:
Interests:
Your Age: 19
What Games do you play: Halo, CoD
Avatar:
- Environment Artist -
Email: {hidden}


Send Private Message
Post Statistics
D0ubl3 HeLiX has contributed to 29 posts out of 469529 total posts (.01%) in 3,398 days (.01 posts per day).

20 Most recent posts:

The plugin was written for the specific version of max when it was developed (can't remember which, exactly), so it doesn't run on many later versions, because Max has changed so much. A pretty good alternative for Blitzkrieg for the newer Max versions, is Blue Streak. I believe you can find it in the utilities section here. Also, if you are running 64-bit version, to import WRL files, since 64-bit doesn't have this ability, there is also a utility for that.


Haha, good stuff bobbysoon. You're a great person/asset for the community! See you around!


Alright, so I was curious about what was going on between you and I. I figured out that Max reverted to DirectX 9.0, but since I changed it to 10 I can see the lines just fine. (As long as edged faces is enabled.) But yeah, it was strange that unchecking "Edges Only" in the display properties did allow me to see the lines in DirectX 9. It's strange to note that checking "Vertex colors" also enabled the lines in the viewport. I don't know what was going on with that, but with DirectX 10 all is well. Thanks for all of your work. I tried the new importer and the lines are red and have perfectly centered pivots! Awesome work!

P.S. OpenGL is good was well. Better performance than DX10 on my rig too!
Edited by D0ubl3 HeLiX on Sep 3, 2011 at 03:21 PM


Okay, so I ran tool on some geometry that I knew had only a few errors. Tool spits out that there are 3 edges open:

### ERROR edge #49 is open (red).
### ERROR edge #70 is open (red).
### ERROR edge #241 is open (red).
### ERROR failed to build collision geometry.
### ERROR failed to import collision bsp.


So, I import the .wrl and find that the edges are not highlighted in red, but rather a light blue-ish color. I have the .wrl file here > http://www.mediafire.com/?891ztkh5l46yhdt. Perhaps the issue with colors is only a 3ds Max thing?
(As a side note, other .wrl files that had other edge issues did import as colored red, so I don't really know what's going on here. They were z-buffered and degenerates I believe...)

Also one note, if I have my mesh selected when I click the button to import the .wrl and I proceed to import, the object that was selected is deleted from the scene. Also, the reason that I couldn't see the edges was because they are imported with "Edges Only" checked in the display properties. Not entirely sure why the aren't visible with that checked, but at least I figured it out.


Edit: Oh, and drag-n-drop install seemed to work fine this time!
Edited by D0ubl3 HeLiX on Sep 1, 2011 at 11:44 PM

Halo CE Technical / Map Design » Why must you be so mean? :c Sep 1, 2011 11:25 PM (Total replies: 15)

I suppose trying to run as administrator would be worth a shot and only take a few seconds?

Halo CE Technical / Map Design » Exception Sep 1, 2011 11:23 PM (Total replies: 6)

I'm kind of going out on a limb here, but it's probably some geometry error that seems to be making a reference to -1 for something, maybe sky? You should try using adolif2's bsp fixer program which you can find here: http://forum.halomaps.org/index.cfm?page=topic&topicID=38668


Hey,

Using 3ds Max 2011 64-bit here. Just so you know.

I dragged-and-dropped the .mzp onto max, but it threw an error:
---------------------------
MAXScript FileIn Exception
---------------------------
-- Runtime error: fileIn: can't open file - "C:\Program Files\Autodesk\3ds Max 2011\UI\\MacroScripts\Import WRL (beta).mcr"
---------------------------
OK
---------------------------

Anyways, it I opened up the .mzp file with winrar and went to install it manually, and found that the files were copied correctly and everything (I think), so I just went into customize UI and made a button from there. Not critical, but an extremely minor annoyance.

Once I got everything working, I went to import a .wrl, and everything seemed to go OK.
However, the color of the geometry was black, and I couldn't see it in the viewport. Maybe it's too small, I'm not quite sure. I went to the display tab and checked display box or whatever and it rendered a box around the "geometry" so that's how I located my error spots. Still way better than converting VRML 1 > VRML 2 and import into another program, export, import into Max. Which wasn't really working that well anyways.

Can't say how much I appreciate all of your work. I think it's great that people are still making stuff for this game so many years out and all. Awesome stuff here once you sift through some of the BS that's typical from many communities.


Hmm..the script seems to be running better for me at least.

One major problem though...
It throws the error:
---------------------------
MAXScript Rollout Handler Exception
---------------------------
-- Unable to convert: undefined to type: String
---------------------------
OK
---------------------------




and highlights line 863 which is:
pushPrompt ("Saving "+dataPath+"...")


Edit: I commented out that line to see if it would continue just fine, and success! 2 minutes and 4 seconds for 30,988 triangles. Not too bad I suppose! Now for getting those pesky .wrl's into 64bit 3ds Max?
Edited by D0ubl3 HeLiX on Aug 31, 2011 at 06:04 PM


I tried that, I still see the MXS gc while saving, but I managed to export in under 6 minutes! Hurray! Apparently that did the trick, or something else that I have done. I don't know but thanks for your help!


Verts are definitely welded correctly. There are still over 16,000 of them, but that's how it has to be. Interestingly enough, I started export last night, Max proceeded to hang so I just hit hibernate. I woke it up this morning and it was done? Very strange...maybe it finished right before I hit it, or maybe I'm on to something? I haven't ran the geometry through tool yet though, so who knows if it's even valid.


I've been having the same issue as well. It takes BlueStreak an immeasurable amount of time to export my BSPs from Max. I'm currently using 2011 but I also had this problem on 2010 so I'm not sure what's going on there. My previous solution was to export from 3ds Max and import it into 3ds Max 9 and use the blitzkrieg exporter, but obviously that introduces geometry errors and is a colossal pain in the neck. Terrible work flow as well. BlueStreak has never been able to export a full BSP from Max for me, and even with smaller models it takes many minutes. I have no idea what I'm doing wrong here? I click "Export JMS Data" and it makes Max hang immediately. Am I alone with this problem?
Edited by D0ubl3 HeLiX on Aug 30, 2011 at 12:00 AM


You talking about the largest grenade in the game?

http://www.youtube.com/watch?v=jQxq02yGa5Q < (7:28) It's so big...

Halo CE General Discussion » [MAP] A remake of sorts of Powerhouse Sep 16, 2010 01:54 PM (Total replies: 210)

What do you mean? Like where he inserts the shells? If so, it's close, but im trying to fix it.

Halo CE General Discussion » [MAP] A remake of sorts of Powerhouse Sep 11, 2010 03:41 PM (Total replies: 210)

Got some reach weapons pretty much done. Models aren't mine, but I modified them some to get them how I wanted, however; I did texture them.

Pistol:


Shotgun:


Rocket Launcher:




Halo CE General Discussion » [MAP] A remake of sorts of Powerhouse Sep 9, 2010 07:40 PM (Total replies: 210)

convert it back to editable poly? i only did that to get an accurate tri count...

Halo CE General Discussion » [MAP] A remake of sorts of Powerhouse Sep 8, 2010 04:45 PM (Total replies: 210)

@StatutoryTrOy

I'll pack up all of my models for scenery and the map, as well as all the textures i've used. I'll send you a link in a PM to the download.

Only thing I ask is I get credit for the BSP...

Halo CE General Discussion » [MAP] A remake of sorts of Powerhouse Sep 2, 2010 01:40 PM (Total replies: 210)

Is the model ripped too? or just the texture?

Halo CE General Discussion » [MAP] A remake of sorts of Powerhouse Sep 2, 2010 12:58 PM (Total replies: 210)

Quote: --- Original message by: darkassassin14
i was asking if in reach is the gametype "generator defense" in this map?


No, you cannot play generator defense on this map in Halo CE. If you're asking if we will be able to play it on powerhouse in the game Halo: Reach, then I personally do not know, but I hope so.

Halo CE General Discussion » [MAP] A remake of sorts of Powerhouse Sep 1, 2010 07:44 PM (Total replies: 210)

Quote: --- Original message by: darkassassin14
lol that was mean. hey is generator defense on this map?


Quote: --- Original message by: Advancebo
are you daft? no.


lol. Definitely not...i've never tried any type of scripting...but if anyone want's to take a crack at the HUD (jesse) that'd be awesome...

Halo CE General Discussion » [MAP] A remake of sorts of Powerhouse Sep 1, 2010 12:25 AM (Total replies: 210)

Yes, I agree, it's not perfect. I don't want it to be "perfect." I want it to remind you of the original and play quite similar to it as well. Yes, it's unfinished, however; I do plan to remain working on it. If I can't get around to finishing it, even with people's help I will probably release all of my .max files for it so everyone else can mess with it (but don't count on that happening anytime soon, if at all...)


Time: Sun December 15, 2019 7:56 PM 281 ms.
A Halo Maps Website