A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
Viewing User Profile for: anasshole
About Contact
Joined: Jun 15, 2013 03:39 PM
Last Post: Jun 15, 2013 07:18 PM
Last Visit: Jul 27, 2013 09:29 PM
Location: USA
Occupation: IT Systems Engineer
Interests:
Your Age: 37
What Games do you play: Halo, AOE II
Email: {hidden}


Send Private Message
Post Statistics
anasshole has contributed to 5 posts out of 469529 total posts (0.00%) in 2,375 days (0.00 posts per day).

20 Most recent posts:
Halo CE General Discussion » Strange Server Issue Jun 15, 2013 07:18 PM (Total replies: 8)

I don't think that is going to be of much help! I already have a full diagram of my infrastructure, had one at the previous data center and only had to update a couple of things on it, IP info, carrier, etc. etc. If you have a thought as to what it would be I would love to hear it!

The only thing I can come up with is something with this router. It's a new router that I didn't use at the old data center. It's also more of a security appliance as well...my previous router was a plain VPN capable business router with no bells or whistles..this one is a sonicwall TZ210 security appliance. though we did not license the extra security services on it and I have them disabled on the WAN and LAN interfaces.
Edited by anasshole on Jun 15, 2013 at 07:18 PM




Just an update....

I kept tinkering with it and figured out which NAT rule was causing the problem but not sure why and disabling that rule stops all connections from functioning...but the server would show up in the lobby and at least attempt to connect on the correct port when that rule was turned off.

Originally I had used the server wizard to create all the mappings as with these Sonicwall devices there are several things that have to be done to enable port forwarding and such and it is just easier to use the wizard to set them all up... I have gone through and deleted all the rules it created and address objects and manually setup the NAT rules, Firewall rules, and my address and service objects and it halfway works now.

Some people can get in from the lobby, others when they try it hangs at negotiating connection then fails to join... also noted that when it does this the lobby does not report a game type or list any stats for the server other than the name of the server and map it is running currently...game type, number of players, ping, and the other stats you see scrolling at the bottom upon clicking on the servers do not appear. Even stranger is that this is a random issue... I have the hanging at negotiating connection issue every so many tries to join but returning to the main menu then reloading the lobby game list will often refresh it and fix it for me.

Strange... I just don't quite get it.
Edited by anasshole on Jun 16, 2013 at 12:33 PM



Update again....

Ok So well... I kept tinkering with the NAT rules and after manually creating one rule at a time to setup a one-to-one NAT I got one server going without issues.

I can load one server and it works just fine... if I start any other servers (same box just using different ports) I still have the hit or miss with people able to get in or not... not sure why but at this point I have my main one up and going and am going to stick with that for now. I will tinker more with it later to see if I can get them all up again but for now I'm happy!

Thanks!
Edited by anasshole on Jun 16, 2013 at 04:46 PM

Halo CE General Discussion » Strange Server Issue Jun 15, 2013 05:36 PM (Total replies: 8)

I have my own block of IP's. The IP is not the problem, the problem is the port. The IP is properly resolved when trying to join it is the port that gets screwed up somehow from the lobby.

I have 5 IP addresses and my halo server instances run on one of them. I also have that server completely NAT'd so that it uses the IP for all inbound and outbound traffic. I thought at first just using a standard port forwarding that outbound traffic going out on the first IP of the block with the Halo server traffic setup to come in on the last IP of the block was causing some issues so I NAT'd it to use the same IP for outgoing as incoming without luck.

I also tried reconfiguring my port forwarding and NAT to run my servers off the first IP of the block without luck there either.

I have my own circuit in the data center with a provider..... the data center is just a co-lo for my hardware. I actually own, manage, and run the physical servers there, I lease the rack space and circuit from them.

Halo CE General Discussion » Strange Server Issue Jun 15, 2013 04:46 PM (Total replies: 8)

@OrangeJuice

While I appreciate the reply did you even read my post? I listed in my original post the server is hosted at a data center and that I had already tried various ports.

I have several Halo instances on this server and each one is using the -port switch to specify the port they are running on to separate them... I am also using the -cpu switch to separate the processes as well.

This setup was in fine working order prior to changing data centers which in turn caused an ISP/carrier change. The only other change made was the router. Prior to moving, everything was working fantastic.

None of the servers now work from the lobby...only direct IP and/or joining from Xfire. Port doesn't matter, and I while I am currently using Gandanur as my server tool to eliminate any possible issues with that I also have a SAPP server running and tried with no server mods/tools at all and the problem persists.

Halo CE General Discussion » Strange Server Issue Jun 15, 2013 04:02 PM (Total replies: 8)

:D

Halo CE General Discussion » Strange Server Issue Jun 15, 2013 03:57 PM (Total replies: 8)

First some details...

I am IT systems engineer... I have been hosting servers off and on for years.

I am quite familiar with IT, networking gear, and how to properly set things up.

This issue has stumped me though and I am hoping someone has seen it before.

I recently moved my server farm to a new data center and in the process switched ISP carriers as well as routers and this is when the problem started.. I think the issue may be the router but have not been able to test that possibility as of yet.

When I launch my server, it loads just fine and I can join it via direct IP address without issues. I can also join from my favorite list or from browsing the servers from within Xfire. Taking it one step further I can also join directly from Halorank.com and it connects right up, no sweat.

the problem is only from the main, normal Halo lobby. My game shows up in the list but when trying to connect to it after it negotiates a connection it attempts to connect on some random, most often 5 digit, port.

First, the port it tries to connect on is not even opened/forwarded on my router, so it isn't making it through to my server.

Second, even if I were to open the port (which I can't really do as the port changes every time you try to connect) the Halo DS is not listening on that random port, it is listening on 2302. I have also tried other ports with same issues as well as other servers located in this same farm.

The fact that I can join via direct IP and/or through Xfire pretty much tells me the ports are forwarded correctly and from an operational standpoint everything is as it should be. I just cannot figure out why when trying to join only form the lobby that it tries the connection on that random port.

Any help, thoughts and/or ideas would be greatly appreciated. At this point I am suspecting the router and some sort of compatibility/communication problem between it and the Gamespy master servers but cannot find much on this problem elsewhere and no settings adjustments have seemed to make any difference at all.

Thanks!

Ass


Time: Sun December 15, 2019 7:25 PM 281 ms.
A Halo Maps Website