A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
Viewing User Profile for: lilpod13
About Contact
Joined: Oct 5, 2013 05:44 PM
Last Post: Jan 26, 2017 04:52 PM
Last Visit: Apr 26, 2017 07:27 AM
Location:
Occupation:
Interests:
Your Age:
What Games do you play:


Send Private Message
Post Statistics
lilpod13 has contributed to 13 posts out of 469463 total posts (0.00%) in 2,238 days (.01 posts per day).

20 Most recent posts:
Halo CE Technical / Map Design » Changing when a biped stumbles? Jan 26, 2017 04:52 PM (Total replies: 7)

If you set the hard and soft ping thresholds to 1, it makes the animations stop playing. Not too sure if the marines could move while getting hit, didn't have a chance to play with it much yet, but I'll post what I find out about it later.

Edit: If you set the hard ping thresholds for the marines on the lower side (but NOT at 0) they can take a few shots before they get stumbled. Anything higher makes it hard to stumble them since I bet the threshold is the fraction of body damage done to the character. Also I'm guessing that the interrupt time is how long the damage can count towards a stumble before it drops off, or maybe damage refreshes the timer before it drops off entirely.
Edited by lilpod13 on Jan 26, 2017 at 07:16 PM

Halo CE Technical / Map Design » Changing when a biped stumbles? Jan 26, 2017 02:55 PM (Total replies: 7)

Thanks, that's exactly what I was looking for!

Halo CE Technical / Map Design » Changing when a biped stumbles? Jan 26, 2017 12:14 AM (Total replies: 7)

I've noticed that whenever a marine is hit by any projectile (even if it does 1 damage) that he will play a stumble animation where he can't do anything for a decent amount of time based on where you hit him. Meanwhile elites, grunts, and jackals only sometimes stumble when they take a considerable amount of damage.

I'd like to be able to change when a character can stumble, but have no idea where to look. I've looked at .biped, .gbxmodel, .collision geometry, and .actor tags but didn't see anything that could point towards a stun animation or when it could be triggered. Does anybody have a clue where I could find anything on how this works? Could it be hard-coded into the engine based on the type of unit the character is? (elite, grunt, marine, etc.)

Halo CE Technical / Map Design » Game Globals... why do you do this? Mar 28, 2014 10:16 PM (Total replies: 9)

Found out what it was, I was running everything in HEK+ as administrator but tool, so I guess it couldn't find the globals or something stupid along those lines... thanks for the help everyone!

Halo CE Technical / Map Design » Game Globals... why do you do this? Mar 26, 2014 06:43 PM (Total replies: 9)

Do you know exactly which registry error I should fix? I've already fixed the ones that I can see are related to HEK but there are errors in there from with games/programs and I don't feel safe cleaning all of those errors up since that could (possibly) mess them up. Is it one of the invalid file classes or an unused file extension, since those are the ones I don't feel safe removing.

Halo CE Technical / Map Design » Game Globals... why do you do this? Mar 24, 2014 10:43 PM (Total replies: 9)

As far as I can tell there is nothing missing or any broken links. I have already tried reinstalling HEK+ several times, tried ripping globals from several maps, but I still get the same exact errors. I'll probably just rip globals and try to fix the tag eventually... HEK+ will hopefully get the field right that I'm missing.

Halo CE Technical / Map Design » Game Globals... why do you do this? Mar 23, 2014 08:26 PM (Total replies: 9)

Hey all, got another problem. THIS time it is about the globals. Everytime I try to compile ANY scenario in tool, it does the normal output, but then I get THIS:

game globals didn't specify multiplayer information

Everything else is running fine. I can open scenarios in sapien but I can't compile them.

I've tried using HEK+'s default globals, tried using globals ripped other maps (several MP maps and campaign maps), opened it in guerilla and checked to make sure there wasn't anything missing (to my knowledge). It says cyborg_mp for the biped and flag as the weapon under multiplayer information. I googled the error and tried everything I saw on it but nothing has worked. Any suggestions?


Yeah I did rip the first one from SP, but the second error came from when I ripped a new copy of the scenario. Looks like I might have to reinstall halo combat evolved to get a new map file, or maybe delete the map file and repair.

Edit: Okay, I've figured it out that it is happening after I open it with sapien, because the original a30 scenario tag has scripts and the like but after I save it there are no scripts. I honestly have no clue on how to fix this now, since it only happens on a30 and it happens to no other map I have edited. Also guerilla is now getting an error text when I open it, saying that it fixed the corrupted flag fields and that the scenario tag may be corrupted.

Looks like I won't be editing a30 anytime soon
Edited by lilpod13 on Mar 21, 2014 at 05:09 PM

Halo CE Technical / Map Design » few questions (1rst post) Mar 21, 2014 04:10 PM (Total replies: 10)

Hey antipeople1992!

1) Honestly don't know, you could try searching for an answer

2) The AI DO NOT run out of ammo in singleplayer (running the map through the console) but in multiplayer they do, a way to prevent this (for a long time, not permanently) is to create a new weapon tag for the weapon you want and then increase the rounds initial to 9999 and totals rounds maximum to 9999, giving them a lot of ammo in MP

3) Usually HEK+ screws up with the grenade velocity property when extracting (at least, for me). Usually it will set it to ~.2333333. The way to fix this is to set this to around 8.5 or so for grunts and marines and set it to ~9.5 for elites (elites aren't SUPPOSED to throw grenades, but they can)

Both of these are assuming that you can open the tags with guerilla or another tag editing program.
Edited by lilpod13 on Mar 21, 2014 at 04:27 PM


Found out about the muzzle flash and decals, turns out that for some reason when I reinstalled halo CE it set all the graphics to minimum, that's why I wasn't seeing them.

As for the a30 problem, I found there was some sort of problem with the .map file and it wasn't extracting the scripts correctly. :/

But now I have a new problem: The level was loading fine before, but now I get this error in my debug text file when opening sapien:

03.20.14 16:48:29 file_read('tags\scenery\waterfalls\spray_emitter_medium\bitmaps\waterfall_mist.bitmap') error 0x00000026 'Reached the end of the file. '
03.20.14 16:48:29 couldn't read #5376 bytes from offset #172 in local tag 'tags\scenery\waterfalls\spray_emitter_medium\bitmaps\waterfall_mist.bitmap'
03.20.14 16:48:29 file_read('tags\scenery\waterfalls\spray_emitter_medium\bitmaps\waterfall_mist.bitmap') error 0x00000026 'Reached the end of the file. '
03.20.14 16:48:29 couldn't read #64 bytes from offset #5548 in local tag 'tags\scenery\waterfalls\spray_emitter_medium\bitmaps\waterfall_mist.bitmap'
03.20.14 16:48:29 couldn't read elements for bitmap_group_sequence_block block
03.20.14 16:48:29 file_read('tags\scenery\waterfalls\spray_emitter_medium\bitmaps\waterfall_mist.bitmap') error 0x00000026 'Reached the end of the file. '
03.20.14 16:48:29 couldn't read #48 bytes from offset #5548 in local tag 'tags\scenery\waterfalls\spray_emitter_medium\bitmaps\waterfall_mist.bitmap'
03.20.14 16:48:29 couldn't read elements for bitmap_data_block block
03.20.14 16:48:29 failed to load bitmap tag 'scenery\waterfalls\spray_emitter_medium\bitmaps\waterfall_mist'
03.20.14 16:48:29 failed to load particle tag 'scenery\waterfalls\spray_emitter_medium\waterspray'
03.20.14 16:48:29 failed to load effect tag 'scenery\waterfalls\spray_emitter_medium\jetspray_medium'
03.20.14 16:48:29 failed to load scenery tag 'scenery\waterfalls\spray_emitter_medium\spray_emitter_medium'
03.20.14 16:48:30 EAX: 0x00000000
03.20.14 16:48:30 EBX: 0x0F0DDE01
03.20.14 16:48:30 ECX: 0x00000000
03.20.14 16:48:30 EDX: 0x00000000
03.20.14 16:48:30 EDI: 0x0018EDC8
03.20.14 16:48:30 ESI: 0x00000000
03.20.14 16:48:30 EBP: 0x0018ECA0
03.20.14 16:48:30 ESP: 0x0018EC90
03.20.14 16:48:30 EIP: 0x77DE0C42, 83 C4 04 C2 ?????
03.20.14 16:48:30 EXCEPTION halt in \halopc\haloce\source\tag_files\tag_groups.c,#3142: offset>=0 && offset+size<=data->size

Already tried overwriting the waterfall scenery three times and reinstalling HEK+ once.

I'm thinking about reinstalling Halo CE and HEK and just resetting all my tags and hope my a30 map won't be corrupted and the scenario will open after extracting normal tags and inserting scorpion+cinematic tags.


I was trying to edit A30 using HEK+ and the original scenario tag works fine, I open it up in guerilla and it says the scripts are there, nothing out of the ordinary. After I recompiled the map, I play the map and no scripts are running. I check the NEW scenario tag with guerilla and it now says globals, scripts, references, and source files are now gone(just a blank space). However, when I make a new scenario with A10 the scripts are still there and are all working fine. Any suggestions on how to fix this? (I already tried recompiling the scripts with Zteam's scripts but that didn't work)

Also, the muzzle flash for the assault rifle and pistol are not showing when firing (fps and on other marines/crewman) AND blood decals aren't showing (pre-placed and ones that should be placed when a unit is hit). Help please?

This is the debug text when OPENING the new scenario in Sapien for the first time

03.16.14 21:38:53 sapien pc 01.00.00.0609 ----------------------------------------------
03.16.14 21:38:53 reference function: _write_to_error_file
03.16.14 21:38:53 reference address: 401b13
03.16.14 21:38:53 Couldn't read map file './sapienbeta.map'
03.16.14 21:38:53 CreateDevice succeeded with refresh rate = 0
03.16.14 21:38:54 Sound card doesn't meet minimum hardware requirements. Disabling hardware option.
03.16.14 21:38:54 Increasing sound decompression buffer size to 1048576 bytes
03.16.14 21:38:55 WARNING: cannot create mounted weapons for c_dropship, exceeded MAXIMUM_NUMBER_OF_MOUNTED_WEAPON_UNITS
03.16.14 21:38:55 WARNING: cannot create mounted weapons for c_dropship, exceeded MAXIMUM_NUMBER_OF_MOUNTED_WEAPON_UNITS
03.16.14 21:38:55 WARNING: cannot create mounted weapons for c_dropship, exceeded MAXIMUM_NUMBER_OF_MOUNTED_WEAPON_UNITS
03.16.14 21:38:55 WARNING: cannot create mounted weapons for c_dropship, exceeded MAXIMUM_NUMBER_OF_MOUNTED_WEAPON_UNITS
03.16.14 21:38:55 WARNING: cannot create mounted weapons for c_dropship, exceeded MAXIMUM_NUMBER_OF_MOUNTED_WEAPON_UNITS
03.16.14 21:38:55 WARNING: cannot create mounted weapons for c_dropship, exceeded MAXIMUM_NUMBER_OF_MOUNTED_WEAPON_UNITS
03.16.14 21:38:56 local player 0, weapon (0x0), deleted unexpectedly
03.16.14 21:39:00 WARNING: biped pilot (pilot (pilot_intro)) fell outside world and was erased
(This "fixed corrupt tag flags field" goes on for about 150+ lines above this)
03.16.14 21:39:07 fixed corrupt tag flags field (defending).
03.16.14 21:39:07 fixed corrupt tag flags field (defending search).
03.16.14 21:39:07 fixed corrupt tag flags field (defending guard).
03.16.14 21:39:07 fixed corrupt tag flags field (pursuing).
03.16.14 21:39:07 fixed corrupt tag flags field (attacking).
03.16.14 21:39:07 fixed corrupt tag flags field (attacking search).
03.16.14 21:39:07 fixed corrupt tag flags field (attacking guard).
03.16.14 21:39:07 fixed corrupt tag flags field (defending).
03.16.14 21:39:07 fixed corrupt tag flags field (defending search).
03.16.14 21:39:07 fixed corrupt tag flags field (defending guard).
03.16.14 21:39:07 fixed corrupt tag flags field (pursuing).
03.16.14 21:39:07 the scenario tag 'levels\a30\a3012' may be corrupt.
Edited by lilpod13 on Mar 16, 2014 at 09:42 PM


I was just messing around with B40, adding several encounters in different areas when I just added an encounter on the bridge above BSP_B and messed up the map somehow. I loaded the map and was stuck in a grey void. The biped was able to move but not jump, crouch, or shoot and the HUD was working correctly. It showed the animations for movement but I don't think I was actually MOVING. I decided to remove the encounter and compile the new scenario in tool, but it failed to load the data cache several times. After ~5 tries, it worked and I STILL got the same problem without the encounter. However, the original b40 map still works correctly.

Has anyone else experienced this while editing a campaign map? I think this happened because something got jacked up in the starting cinematic and Halo can't run it. Any help/suggestions would be appreciated since I REALLY don't feel like doing the encounters all over again.

Halo CE Technical / Map Design » Halo CE corrupted Oct 5, 2013 06:01 PM (Total replies: 1)

Hello all, I've got a problem for the past two days that I have no idea how to solve now. I compiled a scenario I made in sapien that apparently corrupted some files in Halo CE. The pop-up is what happens when I attempt running Halo CE, but Halo PC runs fine.

We have detected that one of the Halo PC files is missing or corrupted. We recommend removing and reinstalling the game.
(damnation_marine_defense_flood_v1)

I first tried to find the map file and delete it, but realized that I am unable to see it due to the files only being able to be seen by the program it was made by(is there a way to make them visible?). I have already tried uninstalling Halo CE and reinstalling, but it did not work and I got the same error. I also tried renaming a similar map to the same name and recompiling it with tool, but I still get the same error. Can anybody help?

Edit (6:28):
---FIXED--- I realized Guerrila can see the .map file and delete... I feel stupid---FIXED---
Edited by lilpod13 on Oct 5, 2013 at 06:26 PM


Time: Wed November 20, 2019 11:17 AM 172 ms.
A Halo Maps Website