A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
Viewing User Profile for: marco213
About Contact
Joined: Jun 2, 2015 12:36 AM
Last Post: Jun 5, 2015 12:49 PM
Last Visit: Jun 17, 2015 07:20 PM
Location: Canada
Occupation:
Interests:
Your Age:
What Games do you play:


Send Private Message
Post Statistics
marco213 has contributed to 7 posts out of 469465 total posts (0.00%) in 1,634 days (0.00 posts per day).

20 Most recent posts:
Halo CE Technical / Map Design » custom map unjoiable Jun 5, 2015 12:49 PM (Total replies: 14)

Quote: --- Original message by: SS Flanker
Odd. I see in no way what the relevance of running radiosity would have over server problems.

I know, right?

But I did several tests to come to this conclusion.

1. I first made a map, with texture and used the radiosity method in sapien. Result is that host could join, but other could not. But the texture works just fine, just unjoinable.

2. I made another map(same model, just a different map name), but this time, with no texture, and used the radiosity method in sapien and the result was that everything was working fine.

3. I did another map, but this time, with texture, and used the lightmaps method from tool, and it was working again.

It might sounds weird, but it really did the trick for me!
Edited by marco213 on Jun 5, 2015 at 01:02 PM

Halo CE Technical / Map Design » custom map unjoiable Jun 5, 2015 01:48 AM (Total replies: 14)

Quote: --- Original message by: Maniac1000
http://hce.halomaps.org/index.cfm?fid=2299
That one is good.


Very good tutorial, I managed to do a better map than just a box. And I found the problem while doing so.

Apparently, doing the lightmap into sapien, using the console command radiosity_quality, radiosity_start, radiosity_save makes the multiplayer map unjoinable when there's texture. That method was doing fine when there was no texture. Doing the tool command lightmaps with texture did the trick!

Thanks for the help guys :)
Edited by marco213 on Jun 5, 2015 at 01:49 AM

Halo CE Technical / Map Design » custom map unjoiable Jun 3, 2015 11:03 PM (Total replies: 14)

Quote: --- Original message by: Maniac1000
do all the starting points have a team index of 0?
not 100% sure but that should still work fine on slayer games but red team is team index 1 and blue is index 0 for team game types.

All team index are 0, and I always put Slayer mode, because I know I did not putted the objectives yet, but its worth giving it a try.

After setting half the spawnpoint to team index to 1, and uploaded the map on my website
www.gratz.ca/mt3.zip
Still the same problem: host can join, others can not. I really appreciate your help!

And since the map is soo basic, can someone recommend good tutorial that I can follow? The one i followed might not have been the greatest one, and I am willing to try again with a better guide.

Halo CE Technical / Map Design » custom map unjoiable Jun 3, 2015 01:38 PM (Total replies: 14)

Quote: --- Original message by: Twinreaper

Just need to ask since it wasn't listed in your steps. Were these spawn points neutral or default team assigned? They need to be neutral or else the map will only be playable under a team gametype. Being unable to join the map would indicate either a "max player" issue or it means a spawn issue.
Edited by Twinreaper on Jun 3, 2015 at 01:15 PM


For my spawnpoints, I made sure the type 0 is all game for all of them.
http://i.imgur.com/B6D18DM.png

as for the max player, I doubt it, because the host create a 4 player server, and I am able to create a game with another map,custom or not, with no problem. My map is causing problem somehow.

Thanks for the help tho!

Halo CE Technical / Map Design » custom map unjoiable Jun 3, 2015 12:44 AM (Total replies: 14)

I did gave the right map. The map name was not changed either.

I gave a link to the map, http://grarz.ca/MT22.zip

Now, I deleted the old map from both computers, downloaded the zip file for my website, putted the map on both computers, started a game on a custom map that I found on this website, everything is fine, I can connect. I change the map to another map, works fine. But as soon as I change to the map I just freshly downloaded, The host load the map just fine, the the other computer get a unable to join message...

You can download the map for yourself, see what's wrong, it's just a huge cube with weird texture on the floor (I'm still learning!)

Maybe it is the way I made my map in 3ds max? It's quite disappointing to know my map is not working in multiplayer...

Edited by marco213 on Jun 3, 2015 at 12:47 AM

Halo CE Technical / Map Design » custom map unjoiable Jun 2, 2015 10:10 AM (Total replies: 14)

I do not, but there might be something cached, since i did the tool command "build-cache-file" to fix some bugs. But since I'm at it, i should tell you guys the step I made to make my map, maybe I did something wrong.

I firstly created the map in 3dsmax, created a frame, linked it, added the texture in the data\levels\MT2\bitmaps and assigned the textures.

I then exported it as a jms file using the script "JMS_Exporter_v1-0-1" in the models folder.

Then I did the tool command bitmaps, because I did had multiple texture, and selected my bitmaps folder.

Then I used the command structure.

I then went in guerrilla, opened the scenario file and added it a sky, a starter equipment, and made it multiplayer.

I then opened it in Sapien, did some console command (radiosity_quality 1, radiosity_start(wait till the RBG goes to 0), radiosity_save) to make my map visible, added multiple spawn point and made sure they were available on all games, saved the scenario.

Then did the tool command build-cache-file, in which created the .map file, and thus how I shared it to my friend and found out its unjoinable.

I might be doing something wrong, if so, let me know!

Edited by marco213 on Jun 2, 2015 at 10:18 AM

Halo CE Technical / Map Design » custom map unjoiable Jun 2, 2015 01:14 AM (Total replies: 14)

hey guys,
I recently made a very simple map, with basic textures. It's basically a box. I load it, host it in-game, and ask my friend to join. he says every time he tries to join, it says unable to join the server. He then made a server. I tried to join his, and I got the same error. we picked another map, and it works just fine. Same thing when I tried to host with a different map. Any idea on what the problem could be?

Yes my port is fine, I can host other map but mine. On guerilla, on the map's scenario, I made sure to select multiplayer, and add a weapon. I'll link the map in case you wanna take a look at it:

http://gratz.ca/MT22.zip

Any help would be great! I'm still new at this.. some info about i builded the map are found below.

Edit: the problem was solved. Read below for more information


Edited by marco213 on Jun 5, 2015 at 01:50 AM


Time: Thu November 21, 2019 9:53 AM 203 ms.
A Halo Maps Website