A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
Viewing User Profile for: IsoDidact
About Contact
Joined: Jun 24, 2018 10:35 PM
Last Post: Jul 14, 2018 05:33 AM
Last Visit: Jul 14, 2018 04:40 PM
Website:  
Location:
Occupation: Astronomy PhD Student
Interests:
Your Age: 23
What Games do you play:
Avatar:


Send Private Message
Post Statistics
IsoDidact has contributed to 7 posts out of 467070 total posts (0.00%) in 29 days (.24 posts per day).

20 Most recent posts:
Halo CE Technical / Map Design » AI behavior on scenery Jul 14, 2018 05:33 AM (Total replies: 3)

Thanks for the help, guys. I'm just incorporating the structures into the BSP and slowly whittling away at the edge errors now.

Halo CE Technical / Map Design » AI behavior on scenery Jul 9, 2018 10:30 PM (Total replies: 3)

Hey all,

I've run into a bit of a problem with the map I'm working on. I downloaded the icefields base as a scenery tag, and placed in in my map with Sapien. I want there to be an elite and some grunts wandering around inside the base, but I can't seem to get the AI to behave properly. I placed their spawn points in the base, along with firing positions. However, when I walk into the base, they are unable to move around, and just stand there while shooting at me.

I know that this has to do with the fact that the structure I placed them in is a scenery and not part of the BSP. Is there any workaround to this? I tried placing the firing positions both on the ground under the base, and in the air on the walkways in the base. I even tried checking 3d firing positions, but I can't get them to behave properly. The only thing I haven't placed are move positions, but I figured those would only be relevant if I wanted to script them to move.

The simplest fix seems to be to make the base model a part of the bsp, which I'm working on, but I'm getting a lot of texture oddities and edge errors when I do this. Is there any way to get AI to work on scenery?


Looks like that did it, thanks!


So I've converted the forerunner balcony from AotCR / Two Betrayals into a piece of scenery, and everything seems to be in order except for the textures. In Gmax they look fine, but after linking the shader_models in the gbxmodel, the object looks like this:



I tried using a different shader_model, and there is no patchy, transparent effect. The only thing I can see is that there is no multimap for the texture I want to use, but I'm not sure if that is relevant.

Any help is appreciated!


Thanks, that fixed my problem! I didn't realize you needed to actually collapse modifiers to apply them to the mesh, so that's good to know.


Hey all,

So I'm taking a crack at designing my own map, and I'm having trouble getting the textures to work properly. In Gmax, my map looks like this:



But when I export the jms, set up the bitmaps with tool, compile the scenario, then run lightmaps, I get this:



The textures are there, but are not mapped in the way I want at all. I can't seem to figure out where in my process that I've screwed up. Could it be in the way I set up the bitmaps / shaders?
Edited by IsoDidact on Jul 4, 2018 at 12:41 PM
Edited by IsoDidact on Jul 4, 2018 at 12:43 PM

Halo CE Technical / Map Design » Single player map won't load? Jun 24, 2018 10:50 PM (Total replies: 1)

Hey all,

I'm jumping back into CE after a >7 year hiatus and am trying to modify a multiplayer map into a single player map. I've ran into a problem however.

I'm modifying the map Extinction, and thus far I really haven't changed much. I modified the map textures and got rid of all the scenery, vehicles, and weapons to give myself a blank slate to work with. When I compile the map or load it in sapien, there are no issues at all. However, when I try to load the map using "map_name <map>" from the main menu, nothing happens. Other campaign levels load just fine.

I have the 'solo' flag checked in the .scenario file, and I have one player starting location, as well as a player starting profile that tells the character to spawn with an assault rifle and a pistol.

Can you guys think of any reason that the map won't even load?

**EDIT**

I actually figured out my problem. The drive where Halo CE is installed requires administrator permission to modify any files. Sapien and Guerilla weren't being run in administrator mode, so any changes I made just didn't get saved. Oddly enough, both Sapien and Guerilla 'remember' all of my changes, so when I open the scenario after closing the programs, the changes persist. The actual files remain unchanged however. I'm not sure if there's a way for me to make the changes 'permanent', as it were, so if anyone could shed light on this it'd be great.

I've tried making the Halo CE folder freely modifiable without any permissions, but guerilla still refuses to actually save anything. Running it in administrator mode makes it 'forget' anything I changed. I haven't changed too much so I'll probably just start the whole thing over.
Edited by IsoDidact on Jun 25, 2018 at 03:52 AM


Time: Sun July 22, 2018 5:03 AM 219 ms.
A Halo Maps Website