A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
Viewing User Profile for: egordiac
About Contact
Joined: Jun 13, 2020 04:56 PM
Last Post: Jun 23, 2020 01:55 AM
Last Visit: Jun 23, 2020 09:01 AM
Your Age:
What Games do you play:

Send Private Message
Post Statistics
egordiac has contributed to 8 posts out of 464918 total posts (0.00%) in 30 days (.27 posts per day).

20 Most recent posts:

The level is parented/linked to an object called frame. It also has a multi material attached. Still the same error.

I was following wildrender's first tutorial on how to make a halo ce map, when he got to the part with Bluestreak's JMS exporter, he saved the file and everything worked for him. But for me, when I clicked the export jms data buttton, it gave me the error:

Unknown propetry: "name" in undefined

The version of my JMS exporter is 1.0.2 (but I have tried with 1.0.1)

Quote: --- Original message by: MrChromed
We have some plans to resume the project and some multiplayer Firefight maps we were developing once one of our current projects, Forge for Halo CE, is done

That sounds great, glad this game still has an active modding community.

I want to play a map called Firefight Descent (which is technically specified as an offline map) with my friend, but the problem is that whenever I specify a gamemode haloceded gives me an exception and crashes, probably because it wasn't meant to play singleplayer/campaign maps. But is it possible? Is there a gamemode that I can download to host those maps on a server?

Actually no, I've just read an article, saying the ai does not sync over network, so it's impossible.
Edited by egordiac on Jun 15, 2020 at 11:23 AM

OOOOH That actually worked!! What I did was install sapp 10.2.1 and change my port to 2304. I don't think changing it to 2304 worked before. Anyways, thank you to everyone who helped, I can finally play halo with my friends!

Hmmm the commands I use are:
sv_name Halo_DS
sv_public 1
sv_maxplayers 12

sv_mapcycle_timeout 15
sv_mapcycle_add timberland slayer


Output of sapp when I load it is:

Loading SAPP...
Starting threads...
Searching for Halo functions...
Patching Halo's code for codecaves...
Loading commands...
Failed to open Custom Commands file!
Loading Lua scripts...
Loading settings...
Failed to open Events file!
Failed to open Mapvotes file!
Failed to open Mapcycle file!
Failed to open SAPP init file!
Network thread has been started!
SAPP Version 10.2 CE by sehВ, originally by Termy || halo.isimaginary.com
Successfully loaded sapp.dll!
External IP Received: [my ip here]:2302

I do see it in my lan, so I don't think there's an issue with the ip??

I already have the server port as 2302 and client port 2303 in the network settings. With different settings the server doesn't show up.

I've been testing a dedi server for some of my friends and I to play on. I create the server, open up the game on the same computer (for testing purposes, because I don't have 2 computers). I have sv_public set to 0, so that the server is LAN. The server shows up in the LAN list, but when I try to join it, it fails, retries 4 times and gives me the "Unable to join game." error. Why is that?

Time: Sun July 12, 2020 6:50 AM 156 ms.
A Halo Maps Website