A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
Viewing User Profile for: Vlad
About Contact
Joined: Sep 29, 2008 11:16 PM
Last Post: Dec 23, 2009 03:13 PM
Last Visit: Jul 15, 2010 04:20 PM
Location:
Occupation:
Interests:
Your Age:
What Games do you play:
Avatar:
We're heroes;we always arrive in the nick of time.


Send Private Message
Post Statistics
Vlad has contributed to 68 posts out of 469461 total posts (.01%) in 4,069 days (.02 posts per day).

20 Most recent posts:
Halo CE Technical / Map Design » Vlad's Questionarium, Take Two Dec 23, 2009 03:13 PM (Total replies: 8)

It's a wondrous thing called 'Xfire'. Yeesh.

If I take the model_animations from Coldsnap, won't that wreak havoc with the other vehicle animations?

Edit: I was thinking of a different file. I believe it's currently using the correct file, but I'll check anyway.
Edited by Vlad on Dec 23, 2009 at 03:23 PM

Halo CE Technical / Map Design » Vlad's Questionarium, Take Two Dec 19, 2009 08:38 PM (Total replies: 8)

One: Where might I find the correct animations?

Two: So, I'd have to edit bitmaps.map in order to return the file size back to normal?

Halo CE Technical / Map Design » Vlad's Questionarium, Take Two Dec 19, 2009 06:07 PM (Total replies: 8)

Hello again!

My mod has been going along sluggishly (ah, procrastination...), and I have only two questions that I can think of at this moment.

One: Unusable vehicle
I imported the civilian warthog from Coldsnap (with Tiamat's permission), and there were no errors or misplaced files that I knew/know of. It loaded just fine, compiled just fine, everything was dandy. My happiness, however, was cut short by the inability to use the darned thing. There are no messages saying 'Press E to enter -thingamabobber-', and I can't enter it. It still flies around like a normal vehicle, but it is not drivable to the extent of my tests. Is there a way to make it usable, or is it bugged if not on Coldsnap without a file or two that I don't know of?

Two: Irregular file size
The original that I'm modding off of is 48.6 MB, and my mod is generally around that; but, sometimes it jumps to the 90's and above. This has happened on one other mod I've tried, and I have yet to figure out why. It seems to happen irregularly.
I just remembered a Tool output, I'll put it in here: "Cache pack file bitmaps adds/misses: 1056 for 53.49M", and "cache pack file sounds adds/misses: 648 for 14.96M". I haven't seen any reference to missing bitmaps anywhere else, only the Tool output.


So, any help available? It'd be appreciated. Thanks.

Halo CE General Discussion » How does the needler reload? Nov 20, 2009 06:28 PM (Total replies: 51)

Maybe... there's a slot... in the bottom, under the handle? That area doesn't seem used...


Hah! I think I delt with that near-exact crash report just yesterday!

Alright, so:
-Do you have any custom vehicles on the map?
*If so, delete them from the map by doing Guerilla>mapname.scenario>Vehicles (not from the palette)
*If that doesn't work, delete them all from the .scenario AND the palette
*If that still doesn't work, put your head between your legs and kiss your butt goodbye
*If you aren't that flexible, try removing them from your globals.globals, also.


I think the error report is caused by a corrupt or broken vehicle tag; if my suggestion doesn't work, then I don't know.

EDIT: Phrase reconstruction
Edited by Vlad on Nov 20, 2009 at 06:24 PM

Halo CE Technical / Map Design » Various issues/questions Nov 20, 2009 04:03 PM (Total replies: 2)

Quote: --- Original message by: killer kiwi
Quote: What do I do to get as many vehicles as possible to spawn?

if you wont to have more than 6 differnt types of vehicles you will have to write a script to get them to spawn.

But if you wont 6 or less you can just put them into the vehicles section in the globles.globles tag.

if you need more help on this add killerkiwi011 to xfire



Killer, I already knew that. It's how I get them to spawn in the first place. My problem is that only a few of the vehicles are spawning when I test the map; I can still get them via all_vehicles.

Halo CE Technical / Map Design » Various issues/questions Nov 20, 2009 06:25 AM (Total replies: 2)

Hiya,

It's been a while since I've been to the forums, and I never did anything noteworthy while I was active, so I don't expect any of you to remember me. But, just today I started to mod again, and ran into several obstacles that both cunning ideas and a now tired friend on Xfire helped to fix. But, now that I'm all cunning-ed out and he doesn't know what to do, I came here.

I'm trying to mod chronopolis v.3 (I don't care about your opinions on what's a good map to mod, unless it is something like "that map/item is unmoddable for so-and-so". Same for vehicle/weapon choices.); I'm trying to make a more RP-friendly version. I may or may not release it publicly, as right now it's just a theory.
Okay, so I'm trying to use the following vehicles:
Red Civilian Hog- using same from map
Bulldog- Same from map
Police Warthog- http://hce.halomaps.org/index.cfm?fid=4888
Transport Hog- Not sure where I got it; I probably pulled it off one of the RPG_Beta maps
Bobcat- http://hce.halomaps.org/index.cfm?fid=4644
Original LAAG Warthog (standard chaingun Hog)

My problem lies, I think, spread around. The tags for the LAAG and Police Hog got mixed, so now I have two Police Hogs that think they both have a turret (which is invisible). The Bulldog is flippable, but not drivable; and the red civilian hog seems to be working just fine.
I think this is also where things got loopier. I have two of EVERY vehicle type on each team index (my friend on Xfire told me to do this), going all the way to Team Index of 5. With the gametype's vehicle spawn settings to default, only the transport warthog and the red civilian show. With the settings to 4 of each, only the red civilian spawns. The code 'cheat_all_vehicles' gives me all the vehicles, which is how I discovered the problems with the Police Hogs and the Bulldogs.



On the day (well, two days technically, as I've been at this roughly six or so hours and it is now 3 AM) I started this, I got several errors with Sapien (fixed by deleting all vehicles in the map, through Guerilla), reinstalled HEK twice, tried with a completely empty tags folder, got a headache, deleted things in the wrong order, so all in all, everything's jumbled.


Anyway, my main questions ARE:

What do I do to get as many vehicles as possible to spawn?
Will I have to take the (Police Hog/LAAG Hog/ Red Civilian Hog) out for it to work?
(if one of the hogs has to be removed) Can you suggest a vehicle as a replacement?



I have also changed the biped and weapons, but I don't think that affects vehicles. Links to tutorials/items would be appreciated

Thanks,
Vlad


Note: Extra details upon discovery or request will be posted in the first post (ie, this one) in the form of edits. I apologize for any confusion when reading the above, as I wrote it at 3 AM.


IMPORTANT EDIT:
I've fixed some of my troubles! Woohoo!
-On the police warthog, I wasn't aware that a .vehicle came with the tagset; it works dandy now. I also assigned it a different folder in tags\vehicles so there wouldn't be any misdirects.
-The bulldog never started to work, so I replaced it with the 'Infernus' conversion from GTA
-I scrapped the Red Civilian hog entirely, so the LAAG works fine now. I replaced it with the Pimped Civilian by Inkscape; except for where I had to make a new folder and rename a few files, it works fine

Questions that still exist:
-How do I spawn all six vehicles across the map, with the most laid out as possible?
-Is there a limit for how many vehicles per type on the team index?

I know all the vehicles spawn normally, because I placed one of each on Team Index '0', and they all were there.
Edited by Vlad on Nov 20, 2009 at 05:30 PM


EDIT 2:
Ok, all my vehicle related issues have been solved; now it's on to weapons.
I have a silenced SMG and the revolver to star by default, but when my friend hosted it, something with his gametype's weapon preferences changed it; instead of teh SMG/Revolver, there was a BR that shot tank shots, and a default pistol with the revolver's model and animations. I looked, and I don't see either of those in the globals, or the .scenario. How can I remove them from the map entirely?
Edited by Vlad on Nov 20, 2009 at 07:45 PM


CURRENT ISSUES:
1: For some reason, during the private beta tests, the map occasionally exceptions when a player exits a vehicle. What causes exceptions, and what can be done to improve upon it?
2: I found programs to change the strings, but they don't work; the other programs fail to see the file that I stare at in confusion.
3: (as a possibility) Is there a complicated process to giving each team a different biped?
Edited by Vlad on Nov 21, 2009 at 03:56 AM
Edited by Vlad on Nov 23, 2009 at 05:10 PM
Edited by Vlad on Nov 24, 2009 at 05:07 AM


Quote: --- Original message by: chrisk123999
Your missing some shaders.
It even tells you.
Need to get the fallowing tags:
scenery\base_scenery\tags\base_good\shaders\example_tutorial_metal_floor.shader_environment
Open up the gbxmodel in Guerilla and change fix the red text at the way bottom of it.
For that one, I would just simply change it to look for the shader in the tutorial map folder.


I know it told me, I didn't know how to fix it because I don't have that tag. and I wanted a better weapon rack, not a way to fix the one with above error message- later today, I'm going to try Gamma's suggestion of the ones from A10.

Edit: Gamma, you rock.
Edited by Vlad on Jun 1, 2009 at 08:20 PM


Anybody know of a weapons rack that works? The one I have gives me this message:


05.26.09 14:09:31 sapien pc 01.00.00.0609 ----------------------------------------------
05.26.09 14:09:31 reference function: _write_to_error_file
05.26.09 14:09:31 reference address: 401b13
05.26.09 14:09:31 Couldn't read map file './sapienbeta.map'
05.26.09 14:09:32 CreateDevice succeeded with refresh rate = 0
05.26.09 14:09:32 Sound card doesn't meet minimum hardware requirements. Disabling hardware option.
05.26.09 14:09:32 Increasing sound decompression buffer size to 1048576 bytes
05.26.09 14:09:37 file_open('tags\scenery\base_scenery\tags\base_good\shaders\example_tutorial_metal_floor.shader_environment') error 0x00000003 'The system cannot find the path specified. '
05.26.09 14:09:37 couldn't open shader_environment tag 'example_tutorial_metal_floor.shader_environment'.
05.26.09 14:09:37 failed to load gbxmodel tag 'scenery\weapons_rack_tags\weapons rack tags\rack\rack'
05.26.09 14:09:37 failed to load scenery tag 'scenery\weapons_rack_tags\weapons rack tags\rack\weapons_rack'
05.26.09 14:09:56 failed to load scenario tag 'levels\test\outpost_rio_classic\riosvs'
05.26.09 14:09:56 need to get the following tags:
05.26.09 14:09:56 scenery\base_scenery\tags\base_good\shaders\example_tutorial_metal_floor.shader_environment
05.26.09 14:09:56
05.26.09 14:09:56 game_load() failed.



I remove it from the Scenery Palette, and Sapien opens it with only a message about stencil bitmaps.


Is there a way to tell what exactly is corrupted, or will it reveal itself in due time?


Hi,

I'm sure that this has been asked and answered a few times, but I did a search and did not see what I was looking for.

I've been trying to get a map (outpost_rio_classic) to be ready for a machinima, but Sapien started giving me the following error.

05.25.09 21:00:46 sapien pc 01.00.00.0609 ----------------------------------------------
05.25.09 21:00:46 reference function: _write_to_error_file
05.25.09 21:00:46 reference address: 401b13
05.25.09 21:00:46 Couldn't read map file './sapienbeta.map'
05.25.09 21:00:46 CreateDevice succeeded with refresh rate = 0
05.25.09 21:00:47 Sound card doesn't meet minimum hardware requirements. Disabling hardware option.
05.25.09 21:00:47 Increasing sound decompression buffer size to 1048576 bytes
05.25.09 21:00:48 the meter definition ui\hud\cyborg shield does not specify a stencil bitmap group.
05.25.09 21:00:48 the meter definition ui\hud\cyborg body does not specify a stencil bitmap group.
05.25.09 21:00:49 EAX: 0x09BE8B38
05.25.09 21:00:49 EBX: 0x00000101
05.25.09 21:00:49 ECX: 0x00000000
05.25.09 21:00:49 EDX: 0x00ADD580
05.25.09 21:00:49 EDI: 0x0013E408
05.25.09 21:00:49 ESI: 0x00000000
05.25.09 21:00:49 EBP: 0x0013E2E0
05.25.09 21:00:49 ESP: 0x0013E2D0
05.25.09 21:00:49 EIP: 0x7C90E514, C3 8D A4 24 ?????
05.25.09 21:00:49 EXCEPTION halt in \halopc\haloce\source\tag_files\tag_groups.c,#3157: #-1 is not a valid object_function_block index in [#0,#4)


I ripped/extracted globals.globals, fully extracted *everything* from both CE and PC Blood Gulch, and still, the map I try to open doesn't. I did, however, try other classic maps. Only a few opened, and here's the error report for one that opened (Gephyrophobia):

05.25.09 21:06:00 sapien pc 01.00.00.0609 ----------------------------------------------
05.25.09 21:06:00 reference function: _write_to_error_file
05.25.09 21:06:00 reference address: 401b13
05.25.09 21:06:00 Couldn't read map file './sapienbeta.map'
05.25.09 21:06:00 CreateDevice succeeded with refresh rate = 0
05.25.09 21:06:00 Sound card doesn't meet minimum hardware requirements. Disabling hardware option.
05.25.09 21:06:00 Increasing sound decompression buffer size to 1048576 bytes
05.25.09 21:06:02 the meter definition ui\hud\cyborg shield does not specify a stencil bitmap group.
05.25.09 21:06:02 the meter definition ui\hud\cyborg body does not specify a stencil bitmap group.
05.25.09 21:06:06 WARNING: 22 clusters in structure_bsp levels\test\gephyrophobia\gephyrophobia have no background sound or sound environment.
05.25.09 21:06:06 local player 0, weapon (0x0), deleted unexpectedly



Since I am still an utter n00b at the whole modding thing, I have not been able to figure this out.

On an unrelated and less important note, how do I change the maneuverability and speed of an air vehicle? Does it have to do with the mass?

Halo CE Technical / Map Design » Couple questions... Feb 8, 2009 09:43 PM (Total replies: 5)

New question regarding HEK+ -

I am trying to open a custom made map (One of the RPG beta ones. I want to play around with it.), but HEK+ keeps crashing on a file. I think it is called cyborg_hands_multipurpose.bitmap, or some variation of that. Any help on how to successfully extract everything from a custom map?

More questions:
After/if I get the question above done successfully, what all would I have to change to change the player biped? The whole female spartan thing bugs me.

I think I can figure out how to change guns, but no guarantee.

Halo CE Technical / Map Design » Couple questions... Jan 25, 2009 05:57 PM (Total replies: 5)

Yeah, I used guerilla to find the scope option in the shotgun.weapon tag. But is there more to modify, so I don't get errors?

And after the 1-9 thing, it generally doesn't do that command again-Edit- each time I retry that command with that map-. So I would have to add the shader_environment before I do that, right?
Edited by Vlad on Jan 25, 2009 at 05:58 PM

Halo CE Technical / Map Design » Couple questions... Jan 25, 2009 05:42 PM (Total replies: 5)

Hi,
I have a few questions about various bits/pieces of map making, so a few of them may sound nooby. I will look at the Tutorials section of hce.halomaps.org before I ask, so... yeah.

Was going to ask: How do I add scope to a shotgun? Do I only need to change the .weapon file, or is there other stuff I need to modify? I only want zoom, no accuracy modifiers. It would be for awesomeness, and my brother asked me to add a scoped shotgun.
Found: http://hce.halomaps.org/index.cfm?fid=1533 - Is this tutorial good?

Was going to ask: Whenever I try adding texturing with UVW Map, the cliffs are always stretched and ugly looking, but don't even show in Sapien. I am using Gmax.
Found: http://hce.halomaps.org/index.cfm?fid=1530 / http://hce.halomaps.org/index.cfm?fid=1530 - Are these good?

Was going to ask: Sometimes, when I run cmd.exe and use tool bitmaps levels\mapname\bitmaps, it gives me all kinds of weird errors (I can't get them to show again, otherwise I'd post an example). I also get a thing asking about a texture I added. I think it has a list, 1-9 with a variety of answers. I just use 1, and it has some error saying that it didn't work (I think).

And also, to add custom vehicles to a map, is there an easier way than having to change the globals.globals thing?

The third one is a bit vague, but in order to get the errors I'd have to start a map completely from scratch... again. Are the tutorials I listed good ones?

Side notes
I am using Yayap's tutorial as a base (Yes, I know about the friggin' grenades!)
Speaking of grenades, how do I get them in the starting equipment?

Halo CE Technical / Map Design » Sapien crash? Jan 22, 2009 10:14 PM (Total replies: 12)

I've just started mapping, I don't know the details. Yeesh.

Halo CE Technical / Map Design » Sapien crash? Jan 22, 2009 08:53 PM (Total replies: 12)

Why would I rip/rerip Blood Gulch? The map I'm talking about I made like 3 days ago. And I didn't put any vehicles in yet, only 2 weapons (Would that be part of it?).

Halo CE Technical / Map Design » Sapien crash? Jan 22, 2009 01:17 PM (Total replies: 12)

If you mean weapon tags, I'm using original H1 weapons.

This what you wanted?

01.21.09 14:18:08 sapien pc 01.00.00.0609 ----------------------------------------------
01.21.09 14:18:08 reference function: _write_to_error_file
01.21.09 14:18:08 reference address: 401b13
01.21.09 14:18:08 Couldn't read map file './sapienbeta.map'
01.21.09 14:18:09 CreateDevice succeeded with refresh rate = 0
01.21.09 14:18:09 Sound card doesn't meet minimum hardware requirements. Disabling hardware option.
01.21.09 14:18:09 Increasing sound decompression buffer size to 1048576 bytes
01.21.09 14:18:10 file_open('tags\vehicles\vehicle.material_effects') error 0x00000002 'The system cannot find the file specified. '
01.21.09 14:18:10 couldn't open material_effects tag 'vehicle.material_effects'.
01.21.09 14:18:10 failed to load vehicle tag 'vehicles\warthog\mp_warthog'
01.21.09 14:18:10 file_open('tags\vehicles\vehicle.material_effects') error 0x00000002 'The system cannot find the file specified. '
01.21.09 14:18:10 couldn't open material_effects tag 'vehicle.material_effects'.
01.21.09 14:18:10 failed to load vehicle tag 'vehicles\ghost\ghost_mp'
01.21.09 14:18:10 file_open('tags\vehicles\vehicle.material_effects') error 0x00000002 'The system cannot find the file specified. '
01.21.09 14:18:10 couldn't open material_effects tag 'vehicle.material_effects'.
01.21.09 14:18:10 failed to load vehicle tag 'vehicles\scorpion\scorpion_mp'
01.21.09 14:18:11 file_open('tags\vehicles\vehicle.material_effects') error 0x00000002 'The system cannot find the file specified. '
01.21.09 14:18:11 couldn't open material_effects tag 'vehicle.material_effects'.
01.21.09 14:18:11 failed to load vehicle tag 'vehicles\banshee\banshee_mp'
01.21.09 14:18:11 file_open('tags\vehicles\vehicle.material_effects') error 0x00000002 'The system cannot find the file specified. '
01.21.09 14:18:11 couldn't open material_effects tag 'vehicle.material_effects'.
01.21.09 14:18:11 failed to load vehicle tag 'vehicles\c gun turret\c gun turret_mp'
01.21.09 14:18:11 file_open('tags\vehicles\vehicle.material_effects') error 0x00000002 'The system cannot find the file specified. '
01.21.09 14:18:11 couldn't open material_effects tag 'vehicle.material_effects'.
01.21.09 14:18:11 failed to load vehicle tag 'vehicles\rwarthog\rwarthog'
01.21.09 14:18:11 failed to load globals tag 'globals\globals'
01.21.09 14:18:11 couldn't load game globals (get new tags)
01.21.09 14:18:11 need to get the following tags:
01.21.09 14:18:11 vehicles\vehicle.material_effects
01.21.09 14:18:11 vehicles\vehicle.material_effects
01.21.09 14:18:11 vehicles\vehicle.material_effects
01.21.09 14:18:11 vehicles\vehicle.material_effects
01.21.09 14:18:11 vehicles\vehicle.material_effects
01.21.09 14:18:11 vehicles\vehicle.material_effects
01.21.09 14:18:11
01.21.09 14:18:11 game_load() failed.

Halo CE General Discussion » Human Campaign Jan 21, 2009 05:22 PM (Total replies: 832)

Short version:
Reach got raped.

Halo CE Technical / Map Design » Sapien crash? Jan 21, 2009 05:13 PM (Total replies: 12)

Hallo,
Whenever I try to open my .scenario file in Sapien it just crashes. I don't know if there has been a modified Sapien released, but if so, I'm using the standard one. I would throw in a screenshot, but my computer freezes for like 2 seconds while it tries to open it. All I get is the Sapien window with nothing on it, it just sits there for 2-3 seconds before closing without any reason.

I'm using Yayap's tutorial (I know about grenades), and I have redone it twice now.

Halo CE Technical / Map Design » Skys the limit help?!? Jan 21, 2009 02:58 PM (Total replies: 2)

The Skys The Limit 3rd person only allows you to look from directly behind. Kinda useless. The Insert is to change your field of view when in 1st person.


Time: Tue November 19, 2019 1:50 AM 516 ms.
A Halo Maps Website