A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
Viewing User Profile for: ziko
About Contact
Joined: Feb 26, 2011 09:14 PM
Last Post: Sep 13, 2018 09:21 AM
Last Visit: Sep 26, 2018 09:19 AM
Website:  
Location: Australasia
Occupation: Student
Interests: Creating
Your Age: 21
What Games do you play: Halo Custom Edition
Avatar:
Raw!
Email: {hidden}


Send Private Message
Post Statistics
ziko has contributed to 89 posts out of 467807 total posts (.02%) in 2,852 days (.03 posts per day).

20 Most recent posts:
Halo CE General Discussion » Lumoria Tagset Sep 13, 2018 09:21 AM (Total replies: 2)

Thanks alot, i was able to get the scripts aswell!

Halo CE General Discussion » Firefight Descent II - A call for help. Sep 12, 2018 07:17 AM (Total replies: 35)

Im happy to help, although i don't have much experience. I'd love to see this project go through! I loved the original!

Halo CE General Discussion » Lumoria Tagset Sep 12, 2018 01:06 AM (Total replies: 2)

Hey all, wondering if anyone has the full Lumoria tagset. I was hoping to modify the campaign and add my own assets.

I tried extracting the scenario tag from HEK+ but there was way too many errors when compiling between model_animations and scripting.

Unless there is another way around this.

Thanks, Ziko.

Halo CE General Discussion » Quick Scripting Question May 10, 2016 06:02 AM (Total replies: 24)

Great to hear that your back! I've been looking forward to playing this since your last post (last year), This map is defiantly fresh and unique, with innovative RPG elements that make the map feel alive, such as having the pillar of autumn map as the HUB to launch into your next mission, marines walking around and talking and also the addition of loading up maps within maps!

This map has a lot of potential and hopefully be implemented into other maps and built upon in the future!

I'm defiantly up for beta testing, I added you on steam.


Im glad to hear that your well, It would of been tragic to lose another talented developer in the HaloCE community. I am a big fan of your work and are always excited to see updates on your youtube channel about the progress of upcoming projects.

Don't stress about upcoming projects and meeting deadlines, you have already contributed a lot to this community and taken a lot of constructive criticism with it.

The most important thing is to attend to your health and well being as that is the most important priority! Take a break, relax and get your life back on track.

Hope to hear from you soon!

Halo CE General Discussion » [WIP] Membership System Apr 4, 2016 07:40 AM (Total replies: 20)

Wow, this is innovative!

Halo CE General Discussion » [Release] Neophobia Public Beta Apr 4, 2016 05:10 AM (Total replies: 42)

Wow that is impressive!

To me, The luscious, green open world is what really makes Halo a stand out among others.


I would love to see the Halo 2 Anniversary biped implemented, It looks sweet! but im assuming that would have to be built from the ground up as we cant export stuff from the xbone.

Thats awesome that you guys are custom rigging the Halo CEA biped, cant wait to test it out.


Awesome, your new tagset got the h2a battle rifle working in my map!

Couple of things though, that you probably already now!

-No HUD for ammo count or grenades
-No reticle for weapon
-Ammo count of br is flickery (not solid)

It would be good if i could send you a pic of my in-game with battle rifle but im unsure how to on the forums.

Apart from that things are looking good, the weapon model, animations, sound and texture is spot on!

Cant wait for future updates!


Tried to import the h2a_br_weapon into my map, it will not allow me to because tool is complaining that im missing the "dreamweb\weapons\human\battle_rifle\_h2a\bitmaps\h2a_br_nrml.bitmap" file, this tag didn't come with dreamweb_release file.

Just a heads up!

Halo CE Technical / Map Design » Navpoints scripting HELP! Jun 25, 2015 07:15 AM (Total replies: 2)

Hey again, Im trying to place nav points in my .yelo singleplayer map but i cannot seem to get my script working, im using activate_team_nav_point_flag script but it keeps giving me this error that i dont know how to solve, im referencing the halo scripting bible.

my script:
(script startup AI_Nav
(activate_team_nav_point_flag default player objective 0.6)
(sleep_until (volume_test_objects trigger4 (players)) 15)
(deactivate_team_nav_point_flag player objective)
)

objective: flag in sapien
default: waypoint marker
player: assigned team

debug/ERROR:
06.25.15 21:00:09 [scripts_equiptest_visr line 99] this is not a valid navpoint name: default player objective 0.6)
06.25.15 21:00:09 recompiling scripts after scenarios were merged.
06.25.15 21:00:09 [scripts_equiptest_visr line 98] this left parenthesis is unmatched.: (script startup AI_Nav

Im certain that i am implementing this code right! I cannot understand why it is erroring me im sure you must enter the script like: (activate_team_nav_point_flag <navpoint> <team> <cutscene_flag> <real>).

Please help!
Ziko


SAME POST IN http://forum.halomaps.org/index.cfm?page=topic&topicID=48362

Hey dude thanks for getting back to me and uploading a tutorial about this!

But i am still suffering issues after following all your steps in the tutorial.

I am suffering errors when compiling the scripts in OS_sapien which is preventing me to create my .map file, Im sure it is an issue between the 5 .hsc scripts in my 'data/levels/EQUIPTEST/scripts' folder , i have a feeling that there conflicting with eachother.

###NOTES###

#I have enabled the VISR script in the cmt_features file located in my 'MFOLDER' and then ran the batch file.

#I have placed the armor_module VISR in my map but i cannot equip or use it. :(

#I have already followed your tutorials including: Installing, Folder and File Creation, File Editing / Find-Replacing, Preprocessing, Level Globals, Sapien Prep and Armor Abilities (Modules?)

###Steps I followed to try get it working!###

I compiled the scripts with my hssp_EQUIPTEST.bat file and received the 'out' folder that contains 5 hsc files ( __components_apis, _components_cmt,_components_globals, _components_scenario and _components_shared).

I then copied these files from the 'MFOLDER' <- (This files on the desktop) into my halo directory 'data/levels/EQUIPTEST/scripts' folder.

I also have my pre-exsisting scripts.hsc file in the 'data/levels/EQUIPTEST/scripts' folder for my map to run!

I then opened my .scenario file in OS_Sapien and tried to compile the scripts but I receive the following error ' bellow.

debug.txt from OS_Sapien

06.17.15 16:17:08 sapien pc 01.00.09.0620 ----------------------------------------------
06.17.15 16:17:08 reference function: _write_to_error_file
06.17.15 16:17:08 reference address: 401b13
06.17.15 16:17:08 CreateDevice succeeded with refresh rate = 0
06.17.15 16:17:08 Sound card doesn't meet minimum hardware requirements. Disabling hardware option.
06.17.15 16:17:12 Increasing sound decompression buffer size to 1048576 bytes

06.17.15 16:22:28 [_components_cmt line 29] there is already a variable by this name.: curr_player_weapon_type none)

06.17.15 16:22:28 [_components_scenario line 29] there is already a variable by this name.: curr_player_weapon_type none)

06.17.15 16:22:28 [_components_shared line 48] there is already a variable by this name.: curr_player_weapon_type none)

06.17.15 16:22:28 recompiling scripts after scenarios were merged.
06.17.15 16:22:28 there is already a variable by this name.: curr_player_weapon_type none)

06.17.15 16:22:28 there is already a variable by this name.: curr_player_weapon_type none)

06.17.15 16:22:28 there is already a variable by this name.: curr_player_weapon_type none)

As previously stated i believe they are conflicting with eachother as i have noted out (;;) in Notepad++ the particular variable among the compiled .hsc files and that has worked but causes other multiple errors and conflict between the scripts!

I would really appreciate if you or anyone could provide me a solution to this! or telling me that i have done something wrong!

I really want the VISR feature in my map! Thanks Ziko


Hey dude thanks for getting back to me and uploading a tutorial about this!

But i am still suffering issues after following all your steps in the tutorial.

I am suffering errors when compiling the scripts in OS_sapien which is preventing me to create my .map file, Im sure it is an issue between the 5 .hsc scripts in my 'data/levels/EQUIPTEST/scripts' folder , i have a feeling that there conflicting with eachother.

###NOTES###

#I have enabled the VISR script in the cmt_features file located in my 'MFOLDER' and then ran the batch file.

#I have placed the armor_module VISR in my map but i cannot equip or use it. :(

#I have already followed your tutorials including: Installing, Folder and File Creation, File Editing / Find-Replacing, Preprocessing, Level Globals, Sapien Prep and Armor Abilities (Modules?)

###Steps I followed to try get it working!###

I compiled the scripts with my hssp_EQUIPTEST.bat file and received the 'out' folder that contains 5 hsc files ( __components_apis, _components_cmt,_components_globals, _components_scenario and _components_shared).

I then copied these files from the 'MFOLDER' <- (This files on the desktop) into my halo directory 'data/levels/EQUIPTEST/scripts' folder.

I also have my pre-exsisting scripts.hsc file in the 'data/levels/EQUIPTEST/scripts' folder for my map to run!

I then opened my .scenario file in OS_Sapien and tried to compile the scripts but I receive the following error ' bellow.

debug.txt from OS_Sapien

06.17.15 16:17:08 sapien pc 01.00.09.0620 ----------------------------------------------
06.17.15 16:17:08 reference function: _write_to_error_file
06.17.15 16:17:08 reference address: 401b13
06.17.15 16:17:08 CreateDevice succeeded with refresh rate = 0
06.17.15 16:17:08 Sound card doesn't meet minimum hardware requirements. Disabling hardware option.
06.17.15 16:17:12 Increasing sound decompression buffer size to 1048576 bytes

06.17.15 16:22:28 [_components_cmt line 29] there is already a variable by this name.: curr_player_weapon_type none)

06.17.15 16:22:28 [_components_scenario line 29] there is already a variable by this name.: curr_player_weapon_type none)

06.17.15 16:22:28 [_components_shared line 48] there is already a variable by this name.: curr_player_weapon_type none)

06.17.15 16:22:28 recompiling scripts after scenarios were merged.
06.17.15 16:22:28 there is already a variable by this name.: curr_player_weapon_type none)

06.17.15 16:22:28 there is already a variable by this name.: curr_player_weapon_type none)

06.17.15 16:22:28 there is already a variable by this name.: curr_player_weapon_type none)


As previously stated i believe they are conflicting with eachother as i have noted out (;;) in Notepad++ the particular variable among the compiled .hsc files and that has worked but causes other multiple errors and conflict between the scripts!


I would really appreciate if you or anyone could provide me a solution to this! or telling me that i have done something wrong!

I really want the VISR feature in my map! Thanks Ziko
Edited by ziko on Jun 17, 2015 at 02:42 AM


Hey Guys, I was wondering if some one could help me out regarding putting the VISR script from tsc:e into my own map. I was wondering how exactly i can integrate the VISR script from the cmt_b30_evolved_source_release_scenario 'script' files into my own scenario/map

I have nothing written/scripted in my Equip_test scripts.hsc file as i am unsure what to exactly place in the script to get the VISR working!( I AM A NOOB!)

I've tried to follow the cmt_b30_evolved_source_release_scenario tutorial but i am unsure of how to connect the .hsh and .hs into the primary script .hsc of my scenario.

I am using notepad++ as well as the hspp file from halomaps.org to 'preprocess' my scripts.

Ive put the 'scripts' folder from the cmt_b30_evolved_source_release_scenario dir into my 'data' folder then inside that folder into my Equip_test(scenario name) folder.

this might sound a little confusing i'll try to send a screen shot of how it is setup!

I've also renamed all the 'TEST' and 'test' text in the .hs/.hsh files inside the 'src' folder to my scenario name and aswell as the batch files that preprocess my script (Equip_test).

Whenever i try run hspp_Equip_test the batch file i have the following error:

The system cannot find the path specified
---------------------------------------------
script analysis
---------------------------------------------
/_components_apis.hs
stdin:1: error: cannot create output file

/_components_globals.hs
stdin:1: error: cannot create output file

/_components_shared.hs
stdin:1: error: cannot create output file

/_components_cmt.hs
stdin:1: error: cannot create output file

/_components_scenario.hs
stdin:1: error: cannot create output file

IOerror: [Errono 2] No such file or directory: 'out/scenarios/test/main/__components_apis.hsc'
----------------------------------------
script analysis
----------------------------------------
the system cannot find the path specified
..done!

I wish i could send a picture of my directory setup but i dont know how to on these forums!

If anyone could give me a solution or send me a pic of how my directory should be setup in order to get the VISR script working would be much appreciated!

Thanks Ziko

Halo CE Technical / Map Design » HEK+ OS_Tool-Ex .yelo issue Mar 9, 2015 08:51 PM (Total replies: 7)

Yes that did work in OS_tool.exe cmd but I don't understand why the function is not working in hek+ GUI. Would it have something to do with the definitions file in the plugins?

Halo CE Technical / Map Design » HEK+ OS_Tool-Ex .yelo issue Mar 9, 2015 08:33 AM (Total replies: 7)

Correct, this is the strangest issue that I have come by so far. The last thing I want to do is reinstall Halo!

Halo CE Technical / Map Design » HEK+ OS_Tool-Ex .yelo issue Mar 9, 2015 07:12 AM (Total replies: 7)

I used the convert scenario tag to yelo tag function with memory upgrades through the GUI of HEK+

I typed the command into OS_tool and had the exact same output

Halo CE Technical / Map Design » HEK+ OS_Tool-Ex .yelo issue Mar 9, 2015 06:58 AM (Total replies: 7)

Hi all, I've recently encountered a problem that i am unable to compile my .scenario tag into a .yelo file. My Output file only displays the commands for OS_Tool.exe and doesn't convert the .scenario file into a .yelo file. This issue only occurs when i try create a .yelo file the other functions work fine.

Output/Dump Text:

unicode-strings source-directory
bitmaps source-directory
bitmap source-file
structure scenario-directory bsp-name
structure-lens-flares bsp-name
structure-breakable-surfaces structure-name
collision-geometry source-directory
physics source-file
sounds directory-name platform<xbox,wav,ogg> ogg_only_value_flag<quality or bitrate>
sounds_by_type directory-name type <round to 64 samples:yes/no>
build-cache-file <scenario-name>

windows-font
hud-messages <path> <scenario-name>
lightmaps <scenario> <bsp index> <quality> <stop threshhold>
process-sounds <root path> <substring> <gain+|gain-|gain=|maximum-distance|minimum-distance> <value>
merge-scenery <source scenario> <destination scenario>
zoners_model_upgrade
import-device-defaults <defaults|profiles> <savegame path>
Process completed...

Help would be much appreciated as i am in current work of a single player map!

Halo CE Technical / Map Design » Scripting Noob Help! Feb 7, 2015 02:42 AM (Total replies: 2)

Hey guys I have been looking all over the internet on finding a way to solve my issue and i can't find anything!

Heres my issue:

During the introduction cut scene/cinematic of a single player map, How do you make the player (me!) run/walk to a set destination then start the mission in that spot?

e.g during cutscene/cinematic the player is running away from enemies and jumps off a cliff into a river, then the player starts the mission in the river.

I really hope you guys can tell me how to perform this task in a basic way to solve this!

thanks ziko

Halo CE Technical / Map Design » Common Debug.txt errors. Dec 15, 2012 11:24 PM (Total replies: 56)

I recently installed Open Sauce and in the download it included OS Sapien, OS Guerilla, OS tool and Open Sauce. When i tried to open OS Sapien it showed me the scenario files to open so I chose bloodgulch.scenario and it would not load! So i tried the same thing in Normal Sapien and the exact same problem occurred! (This problem did not occur before I installed Open Sauce)

The Debug Text

12.16.12 15:07:15 sapien pc 01.00.00.0609 ----------------------------------------------
12.16.12 15:07:15 reference function: _write_to_error_file
12.16.12 15:07:15 reference address: 401b13
12.16.12 15:07:15 Couldn't read map file './sapienbeta.map'
12.16.12 15:07:16 CreateDevice succeeded with refresh rate = 0
12.16.12 15:07:16 Sound card doesn't meet minimum hardware requirements. Disabling hardware option.
12.16.12 15:07:16 Increasing sound decompression buffer size to 1048576 bytes
12.16.12 15:07:16 file_open('tags\cmt\hud\bitmaps\damage.bitmap') error 0x00000003 'The system cannot find the path specified. '
12.16.12 15:07:16 couldn't open bitmap tag 'damage.bitmap'.
12.16.12 15:07:16 file_open('tags\h2\hud\bitmaps\misc\postgame_carnage_report.bitmap') error 0x00000003 'The system cannot find the path specified. '
12.16.12 15:07:16 couldn't open bitmap tag 'postgame_carnage_report.bitmap'.
12.16.12 15:07:16 failed to load hud_globals tag 'ui\hud\default'
12.16.12 15:07:16 the meter definition ui\hud\cyborg body does not specify a stencil bitmap group.
12.16.12 15:07:16 failed to load globals tag 'globals\globals'
12.16.12 15:07:16 couldn't load game globals (get new tags)
12.16.12 15:07:16 need to get the following tags:
12.16.12 15:07:16 cmt\hud\bitmaps\damage.bitmap
12.16.12 15:07:16 h2\hud\bitmaps\misc\postgame_carnage_report.bitmap
12.16.12 15:07:16 .bitmap
12.16.12 15:07:16
12.16.12 15:07:16 game_load() failed.


12.16.12 15:07:23 sapien pc 01.00.00.0609 ----------------------------------------------
12.16.12 15:07:23 reference function: _write_to_error_file
12.16.12 15:07:23 reference address: 401b13
12.16.12 15:07:23 Couldn't read map file './sapienbeta.map'
12.16.12 15:07:23 CreateDevice succeeded with refresh rate = 0
12.16.12 15:07:23 Sound card doesn't meet minimum hardware requirements. Disabling hardware option.
12.16.12 15:07:23 Increasing sound decompression buffer size to 1048576 bytes
12.16.12 15:07:23 file_open('tags\cmt\hud\bitmaps\damage.bitmap') error 0x00000003 'The system cannot find the path specified. '
12.16.12 15:07:23 couldn't open bitmap tag 'damage.bitmap'.
12.16.12 15:07:23 file_open('tags\h2\hud\bitmaps\misc\postgame_carnage_report.bitmap') error 0x00000003 'The system cannot find the path specified. '
12.16.12 15:07:23 couldn't open bitmap tag 'postgame_carnage_report.bitmap'.
12.16.12 15:07:23 failed to load hud_globals tag 'ui\hud\default'
12.16.12 15:07:23 the meter definition ui\hud\cyborg body does not specify a stencil bitmap group.
12.16.12 15:07:23 failed to load globals tag 'globals\globals'
12.16.12 15:07:23 couldn't load game globals (get new tags)
12.16.12 15:07:23 need to get the following tags:
12.16.12 15:07:23 cmt\hud\bitmaps\damage.bitmap
12.16.12 15:07:23 h2\hud\bitmaps\misc\postgame_carnage_report.bitmap
12.16.12 15:07:23 .bitmap
12.16.12 15:07:23
12.16.12 15:07:23 game_load() failed.


Time: Mon December 17, 2018 1:13 PM 531 ms.
A Halo Maps Website