A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
Viewing User Profile for: moosebreathman
About Contact
Joined: Jan 14, 2017 09:52 PM
Last Post: May 15, 2019 10:25 AM
Last Visit: May 15, 2019 10:25 AM
Location: Canada
Your Age:
What Games do you play:

Send Private Message
Post Statistics
moosebreathman has contributed to 9 posts out of 464918 total posts (0.00%) in 1,273 days (.01 posts per day).

20 Most recent posts:
Halo CE Technical / Map Design » 'Pop' Issue for FP Ready Animation May 15, 2019 10:25 AM (Total replies: 6)

First, thanks for taking the time to watch those videos and help me out. Second, I found the solution to my problem. My controllers for both upper arms did not have key frames at the end of the animation which meant that there was an off-camera difference in their position between the end of the ready and the start of the idle. I new about this from the moment I blocked out the animation in Max, but when I went to test it in-game, there was no pop or any visible change in the positions of the arms, so I let it slide. I guess when Halo is actually interpreting the animation the upper arm had some level of control over the position of the wrist that was different than how I had my IK setup in Max. That's just my guess though, I only like making stuff move, all the technical stuff is not exactly my forte. Now I can finally move on to the next thing.

Thanks for your help, appreciate it.

Gif of the culprit for reference:


Halo CE Technical / Map Design » 'Pop' Issue for FP Ready Animation May 15, 2019 05:57 AM (Total replies: 6)

Quote: --- Original message by: The Gravemind

Quote: --- Original message by: DeadHamster
I'm not saying you're a liar, but I've watched that animation about 50 times now in 3ds and Halo, and I can't see any difference.

If you're sure there is, and I trust you, check that the hand's node has a keyframe on the last frame of the animation. If you had moved keyframes or adjusted the time, you may have the last frame of the hands animation playing beyond the time of the animation, and Halo may not be interpolate between them if that's the case. I don't THINK that's the case, but it's the only thing I could think of off hand. It's been a while since I've done animating and it was never my forte.

I agree with hamster cause I don't see nothing wrong and your last key frame could be to blame. I have never worked on fp animation but I've noticed that halo sometimes can't interpolate certain keys for bipeds correctly. I guess it's bit like a hiccup. Maybe I don't see anything because gifs reduce frames and it cut the error you mentioned. Or the cyborgs's animation graph might have an IK point which basically keep the marker(usually left hand) still in place. IK calculations are not perfect and they will "snap" in place. The only way to fix this that I have noticed is by editing your animation in max through trial and error or edit the IK point in your graph by removing "left hand". Great animation by the way.

edit: just remembered that the cyborg animation graph is for 3rd person animation, not sure if it affects fp animation in anyway but its worth a shot
Edited by The Gravemind on May 14, 2019 at 09:00 PM

Thanks for the compliment man, I definitely appreciate it!

I realized that my first gifs weren't showing the hitch too well, so I cooked up a better demonstration that actually has them side by side in slow motion. I think it's much easier to see now:

Note: Both clips are slightly different in length which is why the 3ds render ends sooner. They are both playing back at the same speed though. If you for some reason don't catch it, the left hand's hitch is the pause in its movement right before it rests back into the idle.

I took Hamster's advice and checked my keyframes in Max and everything looked fine. The final frame of the ready is exactly the same as the first frame of my idle so the transition should be smooth (there is only a small difference in the upper arm's rotation which isn't noticeable in-game). I think you might be right with it just being a hiccup in how the game interpolates the animation. I was going to try out a few things later and play around a bit with the left hand's timing and posing to see if a slightly different entry won't have the hitch.

On the topic of trial and error, I'm currently using the default version of Halo CE's mod tools and am wondering if there is any better, community made versions of things like Tool or Guerrilla that would make getting animations into the game less of a hassle. Right now I'm just using the Tool console and the Halo animation editor to get stuff in the game, and while it's not difficult to do, it's a couple minutes of jumping between windows and typing in console commands that I wouldn't mind a skip for.

Any further help/advice you, or anyone else has with this issue would be greatly appreciated by me. It's obviously a small enough hitch that it can get by anyone who hasn't seen the animations thousands of times, and so in that sense it's not that big of a deal. However when I put an animation in to this game, I like to imagine a world where that was - for instance - the actual ready that shipped with the disc. After switching to the pistol thousands of times, you'd probably notice and maybe even get bothered by a small hitch in its animation. With that being said, nobody every switched off the pistol when playing, so this one would probably go unnoticed, haha...

Halo CE Technical / Map Design » 'Pop' Issue for FP Ready Animation May 14, 2019 05:51 AM (Total replies: 6)

Hey guys,

I've been making a ready animation for the pistol in my spare time and it's pretty much complete, so I decided to load it into my game and see how it looks. Everything was fine with it, except for at the end when the Chief's left hand has a slight pop as it settles into the idle pose. I thought this was pretty odd, as playing it back in Max doesn't yield this particular issue. I'm wondering if this is just a bug with the game or if there is something I don't know about ready animations and how to create or implement them.

For your information here are some technical facts that might help:

-Right now I have a custom Ready, Idle, and Move animation for the pistol. They all use the exact same frame count as the Bungie animations.

-My first person models and rig are the default and the only changes I've made to the rig was adding stuff like IK controllers and helpers for animating in Max.

-I use 3ds Max 2017

This is what it looks like in Max:

This is what is looks like in-game:

Notice how the left hand stops briefly near the end of the animation in-game. I'm not sure if it's a problem with the last bit of the ready animation or if it's something with the switch into the idle. This isn't the biggest deal, but I did put a decent amount of work into the animation and would like it play as intended. Any help would be appreciated, thanks!

Edited by moosebreathman on May 14, 2019 at 05:54 AM
Edited by moosebreathman on May 14, 2019 at 06:09 AM

Halo CE Technical / Map Design » Weapon Sway Jul 16, 2018 10:06 AM (Total replies: 3)

Ah yes, you are right! Although I seem to have a problem importing the default pistol overlay animations into max. After I've linked gun to wrist, I import the overlay animation in and at the first frame the importer stops and doesn't add any more. This is my first time trying to open an overlay animation so I'm not really sure if I'm doing something wrong.
Edited by moosebreathman on Jul 16, 2018 at 10:07 AM

Halo CE Technical / Map Design » Weapon Sway Jul 15, 2018 12:06 PM (Total replies: 3)

Is there anywhere I can edit the amount of weapon sway there is when looking around in first person? I want to tone down the amount of sway on the pistol to better fit my animations and I'm not the best with Guerrilla when it comes to finding stuff (if it's even there to begin with!).

I'm trying to export some first person animations I've made and am not to familiar with the whole process of getting content working in HEK(just basic tutorial stuff I did to gauge interest). My max is the 2017 version and I don't want to mess it up by installing Blitzkrieg in my directory if it isn't compatible. In the case that Blitzkrieg doesn't work, could anybody refer me to a alternate method of extracting animations? I messed around with the ghost importer which I used to get the point of origin poses and animation lengths, but I couldn't get it to export what I made over the animation that was initially loaded. Maybe it can do it and I'm just to dumb to figure it out. Any help would be appreciated.

Edit: Thanks for the help guys! I went on and downloaded the CAD exporter and was able to get my stuff working in game!

Edited by moosebreathman on Feb 22, 2017 at 01:43 AM
Edited by moosebreathman on Feb 22, 2017 at 08:43 PM

Halo CE General Discussion » How to get Ghost's animation importer Jan 15, 2017 08:39 PM (Total replies: 5)

I was looking to create some custom reload animations for the original Halo weapons and would like to download Ghost's animation importer.

This is the link that various video tutorials send you to: http://ghost.halomaps.org/bluestreak/animation

My problem is the site never loads and I don't know if it is just not available anymore or if the site is temporarily down. If it is not available anymore could someone link me to a alternative animation importer. I used the search on this site to try and find one, but I couldn't.

I appreciate the help. After I made my original post I found out that since I am a secondary school student I can get myself an education license for 3dsmax and won't be needing gmax anymore.

I'm literally just getting started with Halo CE map making and have a question about the reference models used for size scaling included within the tutorial level data files.

The video tutorial I'm watching says to merge the "tutorial.max" file into 3dsmax so I can use them. Problem is I'm using gmax and the merge feature will only open ".gmax" files. I tried changing the file extension from a ".max" to a ".gmax" and it will show up in the merge window with the thumbnail, but when I open it nothing happens. I'm just starting with gmax so I don't know if there is somewhere I am supposed to look after I have merged the file in order for the reference master chief model to show up.

I figure just changing the file extension probably doesn't work. If that is the case, can anybody tell me if there is a way to convert it, or if there is another file for reference models I can use?

Time: Thu July 9, 2020 4:37 PM 1,031 ms.
A Halo Maps Website