A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
Viewing User Profile for: Halomind
About Contact
Joined: Feb 10, 2017 02:47 AM
Last Post: Feb 23, 2017 04:13 PM
Last Visit: Mar 24, 2017 11:50 PM
Website:  
Location:
Occupation:
Interests:
Your Age:
What Games do you play:


Send Private Message
Post Statistics
Halomind has contributed to 18 posts out of 462287 total posts (0.00%) in 78 days (.23 posts per day).

20 Most recent posts:

Quote:
There is a thing you do where you purposefully create toolbeta. But it ruins everything so never do it.

OP reinstall???


I will get into possibly reinstalling it and testing out whatever works again, but since the my original problem was solved for this post, I'll start a new post for whatever problems I might possibly have in the future. Much thanks to everyone for the input and time, massively exceed my expectations!
Edited by Halomind on Feb 23, 2017 at 04:14 PM


Quote: --- Original message by: Spartan314
Just curious...
How did you even find a toolbeta.map


I just went into my Halo Custom Edition folder and typed "toolbeta" into my search bar, found the file, then deleted.


Quote: --- Original message by: DeadHamster
Wait.



Did you do that thing where you create a file called toolbeta.map?


Because your error messages don't list "Missing toolbeta.map"


If you made a toolbeta.map, delete it.


Back at it

I tried both DeadHamster and Aex's suggestions and found that deleting my toolbeta.map finally got rid of the "map corrupt" error. Much thank's for the input guys, but the field.scenario file still doesn't seem to have been created.

Any further suggestions?


Definitely going to try these suggestions once testing this week in school is over, will update soon.


Quote: Try jms exporter 104e or junglegym.


Tried but to no success. At this point I'm kinda at a loss, this "map file is corrupt" error never appeared before working on my own level, when I compiled the tutorial.scenario file provided by the HEK before starting this, it appeared to compile fine, but now when I try to compile the tutorial.scenario file, it gives me the error. Maybe I possibly moved around or deleted a file I wasn't supposed to somewhere, I'm thinking I'll just reinstall everything at this point and then try again with a clean slate.


Quote: --- Original message by: DeadHamster
...


Try exporting to a different directory, instead of levels\test\tutorial


How would you go about that? Unless I'm doing it wrong, I made a models folder in the levels folder, directory being C:\Program Files (x86)\Microsoft Games\Halo Custom Edition\data\levels\models

Then typing into tool.exe, I put "tool.exe structure levels field" I get the same result.
I tried using the cd\ command to change the directory to my created directory C:\ Halo but tool refuses any directory other than C:\Program Files (x86)\Microsoft Games\Halo Custom Edition


Quote: OHHH ! ! And are you using the Max 8 version of Blitzkrieg instead of the Max 5 version that comes with the HEK?


I've actually been using the version that came with HEK, I'll update whether it works or not.

UPDATE: downloaded blitzkrieg from link provided by OrangeJuice, replaced blitzkrieg.dle in the plugin folder of 3ds Max 8 as well as the 4 .dll files in windows\System32, re-exported the map, compiled, got the "map file is corrupt" error in the end.
Edited by Halomind on Feb 14, 2017 at 11:26 AM


Quote:
BTW Halomind the actual geometry doesn't seem to be the problem as it looks too simple to go wrong. I should also point out that although your debug info does state that "map file appears corrupt" tool was still able to compile the .jms data successfully.

The next step would be to open guerilla, assign a sky .tag to the map and check the multiplayer option.


The .jms file does appear to have compiled correctly in the prompt but I still have the issue of only having the field.scenario_structure_bsp file and not the field.scenario file created.

picture of directory when looking for a file with guerilla.
http://imgur.com/a/pzXmx


Quote: Upload the .max file, I'll take a look tonight and figure it out.

Here's my .max file for download, link is safe.

http://jmp.sh/I1OLhLZ


Quote: --- Original message by: DeadHamster
Right click the geometry; convert to editable mesh.
You should collapse all the modifiers before export, and be sure it's a mesh before export. Try that let me know how it goes.


Here's the geometry collapsed, and I right clicked the level to make it into a editable mesh.

http://imgur.com/a/JHB3f

Ran 3ds Max 8 as administrator, made into a editable mesh, re-saved and re-exported, ran tool.exe as administrator and I got the same error.


Quote: Are you running all your programs as an administrator? If Halo is in your program files directory, you'll need administrator rights in order to properly access the files in there.


At the moment still getting the same error. I ran 3ds Max 8 as administrator, re-saved the .max file and re-exported it into a .jms file (using the export method rather than running the JMS exporter script since I wasn't allowed to drag and drop the .ms file)

I then ran tool.exe as administrator and am still getting same "map file corrupt" message followed by the level compiling.


Quote:
I definitely recommend completing the HEK tut but it'd also help to give is a screen cap of your map and maybe a copy and paste of tools debug output.


Here are the images for my current map in 3ds Max and tool.exe compiling that map.
(Sorry, not sure how to properly paste a picture into this post.)

http://imgur.com/a/Hq9jA

Here is the text from debug.txt from the Halo Custom Edition directory.

02.10.17 07:03:50 tool pc 01.00.00.0609 ----------------------------------------------
02.10.17 07:03:50 reference function: _write_to_error_file
02.10.17 07:03:50 reference address: 42ca20
02.10.17 07:03:50 map file appears corrupt


Was able to export using the JMS exporter but I'm still getting the map file is corrupt message.

The tutorial I'm using is this
http://hce.halomaps.org/hek/index.html?start=references/level_design/mp_level_design/mp_ld_level_creation_part_01.html

but I've only completed the Level Creation - Part 1.

Do I need to add more to the map to successfully compile it?


Quote: --- Original message by: DeadHamster
use this;

http://hce.halomaps.org/index.cfm?fid=3819

instead of Blitzkrieg. See if that fixes the error.

I've never actually used Blitzkrieg as I've never had a copy of Max8.


Any clarification on how to use this? Do I do anything with the JNS_Exporter_v1-0-2.ms file?


At the moment I am trying to create a simple box level with a flat plane and that's all. I've followed the tutorial from the Halo PC Editing Resource on the first part of creating a simple level, at the moment my current .max and .jms file are located in a created directory as was instructed by the tutorial. Directory being

C:\Halo\data\levels\test\tutorial\models

I also saved the same .max and .jms files in the Halo CE directory, that being

C:\Program Files (x86)\Microsoft Games\Halo Custom Edition\data\levels\test\tutorial\models
(though for some reason I can't visibly see the files in the Halo CE directory, as opposed to the Halo directory where I can visibly see the files.)

Once I get compiling with tool, I type in what was instructed into the command prompt, that being "tool.exe structure levels\test\tutorial field"
(field being the name of the .max and .jms file)

Full path entered into prompt: C:\Program Files (x86)\Microsoft Games\Halo Custom Edition>tool.exe structure levels\test\tutorial field

First line to output is "map file appears corrupt" followed by what appears to be the level being compiled.

Also noted, opening guerrilla showed that only the field.scenario_structure_bsp was created and not the field.scenario

Any solution to this? Is my syntax off or is it the level geometry?



Edited by Halomind on Feb 10, 2017 at 08:34 PM
Edited by Halomind on Feb 10, 2017 at 08:35 PM
Edited by Halomind on Feb 10, 2017 at 08:47 PM

Halo CE Technical / Map Design » Blitzkrieg.dle Error code: 126 Feb 10, 2017 01:43 PM (Total replies: 4)

Quote: --- Original message by: Super Flanker
If access is being denied make sure you are running .exe's as an admin or that you have full admin rights.

Other than that try copying the 4 .dll's into the 3dsmax directory too.


FIXED This suggestion solved the issue

For future reference:

For me at least running as an admin didn't solve the error, but extracting the 4 .dll files and blitzkrieg.dle into my plugins folder for 3dsmax8 fixed the error. 3dsmax8 can now export using blitzkrieg.

Much thanks!

Halo CE Technical / Map Design » Blitzkrieg.dle Error code: 126 Feb 10, 2017 10:46 AM (Total replies: 4)

Currently have two holdups at the moment.

=======================================================

I have copied the 4 .dll files from my Blitzkrieg folder in my Halo Custom Edition directory (C:\Program Files (x86)\Microsoft Games\Halo Custom Edition\blitzkrieg\MAX5) into the windows system32 folder as stated in other forum posts regarding this error, followed by a reboot of the system.

The 4 .dll files being :
msvcp70.dll
msvcp70d.dll
msvcr70.dll
msvcr70d.dll

I am then met with the error code 127 at the startup of 3ds max 8

DLL <C:\Program Files (x86)\Autodesk\3dsMax8\plugins\Blitzkrieg.dle>
failed to initialize.
Error code: 127 - The specified procedure could not be found.

==========================================================

Now going along with Super Flanker's information, I've downloaded the Blitzkrieg Installer V2.2 following all the instruction but was met with an error upon startup

That error stating "Access to the path 'C:\Program Files\BlitzkriegInstaller\' is denied"

I was not aware that the Blitkrieg installer would have its own directory prior to the installation process.

Could I not just skip the blitzkrieg installer and use the 4 .dll files given by it to place in the C:Windows\System32\ folder myself?

Any suggestions for these situation?
Edited by Halomind on Feb 10, 2017 at 10:46 AM
Edited by Halomind on Feb 10, 2017 at 11:07 AM

Halo CE Technical / Map Design » Blitzkrieg.dle Error code: 126 Feb 10, 2017 02:54 AM (Total replies: 4)

Following the Halo PC Editing Resource, I copied the Blitzkrieg.dle file into the 3dsMax8 plugin directory and I get this error on startup of 3dsMax8.

DLL <C:\Program Files (x86)\Autodesk\3DSMax8\Plugins\Blitzkrieg.dle>
fail to initialize.
Error code: 126 - The specified module could not be found.

Help would be very much appreciated!
Edited by Halomind on Feb 10, 2017 at 02:55 AM


Time: Fri April 28, 2017 12:30 AM 281 ms.
A Halo Maps Website