A Community discussion forum for Halo Custom Edition, Halo 2 Vista, Portal and Halo Machinima

Home  Search Register  Login Member ListRecent Posts
  
 
Viewing User Profile for: abzstrak
About Contact
Joined: Jun 7, 2017 02:08 PM
Last Post: Jun 18, 2017 11:55 PM
Last Visit: Jun 24, 2017 07:39 AM
Website:  
Location:
Occupation:
Interests:
Your Age:
What Games do you play:


Send Private Message
Post Statistics
abzstrak has contributed to 4 posts out of 464833 total posts (0.00%) in 190 days (.02 posts per day).

20 Most recent posts:
Halo CE General Discussion » Hosting CE Server through NAT'd firewall Jun 18, 2017 11:55 PM (Total replies: 8)

Thanks for confirming it works through NAT with just those two ports, that does help me narrow things down. Although it works for other ports, I have to think that its an issue with the firewall not forwarding properly.


pfsense is a firewall, but it is also a router. There isn't alot of difference except that, in layman terms, a firewall is more advanced.

The cable modem involved is a bridge, it only has a bridges and does not NAT or anything else.

Halo CE General Discussion » Hosting CE Server through NAT'd firewall Jun 17, 2017 02:20 PM (Total replies: 8)

yes, of course ports/ip's are correct.

Firewall is pfsense, other port forwards work fine... so I don't think that's it.

This is an infuriating simple task that seemingly doesn't work the way it should. I have yet to find someone confirming that it works ok through NAT with just those two ports on 1.0.10.... I'm thinking something may have changed when the gamespy stuff changed.

Guess if I get the time I'll wireshark it and look for other traffic.

Halo CE General Discussion » Hosting CE Server through NAT'd firewall Jun 10, 2017 02:44 PM (Total replies: 8)

yea, not the same box. I tried on the same box too (obviously changing the ports) that resulted in the same no joinable behavior. i tried hosting directly out of the game itself, and people cannot join.

There has to be more to it than the two ports. I did try altering the default ports for the heck of it, still didn't work.

I got annoyed and finally forwarded ports 1-65535 to the box, still didn't work....

Halo CE General Discussion » Hosting CE Server through NAT'd firewall Jun 7, 2017 10:22 PM (Total replies: 8)

Anyone have any tips? Ports 2302/2303 don't seem to be sufficient. The server shows in the list, but no ping is listed and no one can join (just negotiates connection until it times out.) I tried enabling upnp, that didn't seem to help at all.

I've tried forwarding a ton of different ports that I've found through googling, nothing helps. Netstat only shows 2302 and 2303 as listening. OS firewall is disabled and OS is stock win7 with no AV or anything getting in the way. haloceded is stock, no mods or anything until I figure out why it doesn't work.

Same happens if I use hosting in game instead of a dedicated server.

Any ideas would be appreciated.
Edited by abzstrak on Jun 7, 2017 at 10:24 PM
Edited by abzstrak on Jun 7, 2017 at 10:24 PM


Time: Wed December 13, 2017 9:36 PM 235 ms.
A Halo Maps Website